在IntelliJ IDEA中使用Freemarker模板

Rajab 发布于 2013/09/07 17:07
阅读 27K+
收藏 2

我装了Freemarker插件,在Web项目中新建test.ftl的文件,Intellij 能感知到上下文的freemarker内容,也有自动补全提示,可是我想混合使用html标签,因此在编辑器右键菜单中选择“Change html template data language to...”选项,设定为html,确实能混合提示html标签和freemarker标签。可是我reformat code后,整个模板的内容完全没有了缩进,没有html那种缩进格式了。我又新建一个hello.html文件,reformat倒是没问题,可是在里面输入类似<#list a as b>这种freemarker标签后,却提示是不认识的标签。

我就是想在html中使用freemarker标签,文件类型扩展名保存成html,然后能格式化,到底要怎么设置呢?



加载中
0
红星xx
红星xx

IDEA全功能版 对 freemarker  语法是 原生支持的,不需要装什么插件, 直接在 IDEA目录树这边 新建 xx.ftl 后缀自动就有语法支持 ,你可以直接在里面编写 html  , 跟 .html 后缀一样的,缩进什么的 ,完全没有问题。如果你不爽 ftl后缀 ,可直接

file->settings->file types -> freemarker template files ->  *.tpl 

不要改为 html 类型 ,会冲突。建议 删掉 重装


0
Rajab
Rajab

引用来自“红星xx”的答案

IDEA全功能版 对 freemarker  语法是 原生支持的,不需要装什么插件, 直接在 IDEA目录树这边 新建 xx.ftl 后缀自动就有语法支持 ,你可以直接在里面编写 html  , 跟 .html 后缀一样的,缩进什么的 ,完全没有问题。如果你不爽 ftl后缀 ,可直接

file->settings->file types -> freemarker template files ->  *.tpl 

不要改为 html 类型 ,会冲突。建议 删掉 重装


是的。我用的喜闻乐见版,已经有模板的语法支持了。可是在ftl文件中格式化代码,缩进全部左对齐了。我不想ftl的扩展名,难道要在ftl文件中写,写完再复制到html文件中吗?html文档可不可以插入freemarker标签?我看设置中有个设置文件夹中的模板语言的,可是没有freemarker。
0
红星xx
红星xx

引用来自“Rajab”的答案

引用来自“红星xx”的答案

IDEA全功能版 对 freemarker  语法是 原生支持的,不需要装什么插件, 直接在 IDEA目录树这边 新建 xx.ftl 后缀自动就有语法支持 ,你可以直接在里面编写 html  , 跟 .html 后缀一样的,缩进什么的 ,完全没有问题。如果你不爽 ftl后缀 ,可直接

file->settings->file types -> freemarker template files ->  *.tpl 

不要改为 html 类型 ,会冲突。建议 删掉 重装


是的。我用的喜闻乐见版,已经有模板的语法支持了。可是在ftl文件中格式化代码,缩进全部左对齐了。我不想ftl的扩展名,难道要在ftl文件中写,写完再复制到html文件中吗?html文档可不可以插入freemarker标签?我看设置中有个设置文件夹中的模板语言的,可是没有freemarker。
写了 这么多 ,完全 没看进去 ,哎 ,建议按我说的 试一遍 再来 。
J
John__Sun
大哥 我也遇到这种情况了,这个红星的回答真的是一点用没有啊,搞什么
0
Rajab
Rajab

是这样的。@红星xx 一格式化代码就没缩进了

0
Rajab
Rajab
@红星xx 十分感谢。
0
d
dmcwll

这个问题最后怎么解决的?

0
胡予
胡予

社区版 不支持 旗舰版才支持 

返回顶部
顶部