运行generate-project.bat报错

空香沾手 发布于 2014/01/24 09:09
阅读 2K+
收藏 0

@江南白衣 你好,想跟你请教个问题:

[INFO] Generating project in ./generated-projects
[INFO] Scanning for projects...
[INFO]
[INFO] ------------------------------------------------------------------------
[INFO] Building Maven Stub Project (No POM) 1
[INFO] ------------------------------------------------------------------------
[INFO]
[INFO] >>> maven-archetype-plugin:2.2:generate (default-cli) @ standalone-pom >>
>
[INFO]
[INFO] <<< maven-archetype-plugin:2.2:generate (default-cli) @ standalone-pom <<
<
[INFO]
[INFO] --- maven-archetype-plugin:2.2:generate (default-cli) @ standalone-pom --
-
[INFO] Generating project in Interactive mode
[INFO] Archetype repository missing. Using the one from [org.springside.examples
:quickstart-archetype:4.3.0-SNAPSHOT] found in catalog local
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 59.136s
[INFO] Finished at: Fri Jan 24 09:09:45 CST 2014
[INFO] Final Memory: 7M/17M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-archetype-plugin:2
.2:generate (default-cli) on project standalone-pom: The desired archetype does
not exist (org.springside.examples:quickstart-archetype:4.1.1-SNAPSHOT) -> [Help
 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e swit
ch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please rea
d the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureExc
eption
请按任意键继续. . .

加载中
1
江南白衣
江南白衣
跑了quickstart没有?
空香沾手
空香沾手
谢谢
0
李泽龙

[INFO] Archetype repository missing. Using the one from [org.springside.examples
:quickstart-archetype:4.3.0-SNAPSHOT] found in catalog local

0
gyl007
gyl007
我跑了 quickstart,再跑generate-project.bat还是报上面的错呃
0
C
ContyChen
编辑 generate-project.bat ,将-DarchetypeVersion=4.1.1-SNAPSHOT 改为  4.3.0-SNAPSHOT
0
tedted
tedted

我也遇到相同问题,最终解决了。

报错信息的意思就是没找着脚本generate-project.bat中指定版本“4.1.1-SNAPSHOT”的archetype。

你只要先去确认自己本机当前安装的archetype,然后修改generate-project.bat中的版本号即可。

确认自己本机当前安装的archetype的办法是,运行你自己下载的springside中的support\maven-archetype\install.bat ,如果运行成功的话,其中就标明了你成功安装的archetype版本号

【例子】

[INFO] Installing C:\tools\dev\springside4-x.x.x.xx\support\maven-archetype\pom.xml to C:\Users\ted\.m2\repository\org\springside\examples\quickstart-archetype\
x.x.x.xx\quickstart-archetype-x.x.x.xx.pom

把你本机的“x.x.x.xx”这段版本号,替换到generate-project.bat中即可。


0
anying
anying
我也遇到了这个问题。我用的是4.2.2.GA 版本。已经把generate-project.bat改成了4.2.2.GA版本。.m2下面的版本也是4.2.2.GA,但还是报找不到@江南白衣
0
anying
anying

引用来自“anying”的评论

我也遇到了这个问题。我用的是4.2.2.GA 版本。已经把generate-project.bat改成了4.2.2.GA版本。.m2下面的版本也是4.2.2.GA,但还是报找不到@江南白衣
问题解决了,如果你用的是GA版本后面的- SNAPSHOT要去掉的
返回顶部
顶部