编译qt时提示没有兼容的库

wanxj 发布于 2013/10/30 15:54
阅读 284
收藏 0
Qt

编译qt时出现以下问题

/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.7.2/../../../libXext.so when searching for -lXext
/usr/bin/ld: skipping incompatible /lib/libXext.so when searching for -lXext
/usr/bin/ld: skipping incompatible /usr/lib/libXext.so when searching for -lXext
/usr/bin/ld: cannot find -lXext
collect2: 错误:ld 返回 1
make[1]: *** [../../lib/libQtGui.so.4.4.3] 错误 1
make[1]: 离开目录“/root/tools/qt/qt-x11-opensource-src-4.4.3/src/gui”
make: *** [sub-gui-make_default-ordered] 错误 2

网上有人说,加一个-m32的参数,但还是不顶用(可能是我加的位置不对)。大家有没有遇到过这样的问题。谢谢了。


加载中
返回顶部
顶部