eclipse创建maven项目,archetype版本为什么这么低

李笑石 发布于 2016/05/31 17:58
阅读 851
收藏 0
用eclipse创建maven项目  默认的用jee1.5   servlet2.5   为啥版本这么低。
加载中
0
jeffsui
jeffsui
正常 ,所以直接编译会失败
0
阿信sxq
阿信sxq
不要用自带的,自己手动配置
0
@ccny
@ccny

1.在 Java-->Installed JREs-->Execution Environment 中设置  javaSE的  配置为  最新的 jdk

2.在pom 中配置上面的内容试试

<dependency>

<groupId>javax.servlet</groupId>

<artifactId>jsp-api</artifactId>

<version>2.0</version>

<!--主是与 tomcat 中的 版本冲突 就加了 作用域 -->

<scope>provided</scope>

</dependency>


<dependency>

<groupId>javax.servlet</groupId>

<artifactId>servlet-api</artifactId>

<version>2.5</version>

<scope>provided</scope>

</dependency>

0
J
Jamie24
可以修改项目空间里面的.settings文件夹里面的文件:org.eclipse.wst.common.project.facet.core,将jdk版本和maven项目修改为自己需要的版本,然后重启一下eclipse就行
返回顶部
顶部