Workerman3在Laravel5的封装 Workerboy

MIT
PHP
跨平台
2015-04-14
zgldh

Workerboy

Workerboy 是 Workerman 3 在 Laravel 5 下的封装。

装上以后就可以用Laravel的artisan命令来管理workerman了。

依赖

PHP 5.4

本产品依赖 PHP的"ext-sockets" 扩展。Windows下就别想了。

为了提升性能,推荐安装"ext-libevent" 扩展。看这里:http://www.workerman.net/install

用法

  1. composer require zgldh/workerboy。

  2. 在config\app.php的providers数组添加zgldh\workerboy\WorkerBoyServiceProvider。

  3. php artisan vendor:publish将workerboy.php配置项输出到config目录下。

  4. php artisan workerboy:create MyApplication新建一个Workerman3应用。

  5. 编辑Event.php文件。写业务逻辑。

  6. 在config/workerboy.php的applications数组里增加刚刚添加的Workerman3应用。

  7. php artisan workerboy:start --deamon启动所有Workerman3应用。

命令

create

workerboy:create ApplicationName创建一个Workerman3应用,默认是Gateway/BusinessWorker模式。workerboy:create ApplicationName --worker-only使用纯Worker模式创建一个Workerman3应用。

start

workerboy:start启动Workerman3所有的应用。默认是调试模式。workerboy:start --deamon以daemon方式启动。

stop

workerboy:stop停止系统。

restart

workerboy:stop重启系统。

reload

workerboy:reload平滑重启。

status

workerboy:status查看状态。

具体请看:http://doc3.workerman.net/install/start-and-stop.html

加载中

评论(0)

暂无评论

暂无资讯

暂无问答

zgldh/workerboy: Workerman3在Laravel5下的封装。

Workerboy是Workerman3在Laravel5下的封装。 装上以后就可以用Laravel的artisan命令来管理workerman了。

2015/04/14 16:47
453
0

没有更多内容

加载失败,请刷新页面

没有更多内容

返回顶部
顶部