文言文编程语言 文言

文言文编程语言 文言

MIT
JavaScript 查看源码»
跨平台
2019-12-18
编辑部的故事

【年终提升】2019尾声,来 OSC·年终盛典收割技术干货,get新技能!>>>

文言(wenyan-lang)是一门采用文言文输入的编程语言,该语言不使用英文字符,仅包含繁体中文字符,并保留繁体引号「」。

特性

语法定义

变量

wenyan JavaScript
吾有一數。曰三。名之曰「甲」。 var a = 3;
有數五十。名之曰「大衍」。 var dayan = 50;
昔之「甲」者。今「大衍」是也。 a = dayan;
吾有一言。曰「「噫吁戲」」。名之曰「乙」。 var b = "alas!";
吾有一爻。曰陰。名之曰「丙」。 var c = false;
吾有一列。名之曰「丁」。 var d = [];
吾有三數。曰一。曰三。曰五。名之曰「甲」曰「乙」曰「丙」。 var a=1,b=3,c=5;

控制

wenyan JavaScript
若三大於二者。乃得「「想當然耳」」也。 if (3>2){ return "of course"; }
若三不大於五者。乃得「「想當然耳」」。若非。乃得「「怪哉」」也。 if(3<=5){return "of course"}else{return "no way"}
為是百遍。⋯⋯ 云云。 for (var i = 0; i < 100; i++){ ... }
恆為是。⋯⋯ 云云。 while (true) { ... }
凡「天地」中之「人」。⋯⋯ 云云。 for (var human of world){ ... }
乃止。 break;

运算

wenyan JavaScript
加一以二。 1+2
加一於二。 2+1
加一以二。乘其以三。 (1+2)*3
除十以三。所餘幾何。 10%3
減七百五十六以四百三十三。名之曰「甲」。 var a = 756-433;
夫「甲」「乙」中有陽乎。 a || b
夫「甲」「乙」中無陰乎。 a && b

容器

数组从 1 开始索引。

wenyan JavaScript
吾有一列。名之曰「甲」。充「甲」以四。以二。 var a = []; a.push(4, 2);
銜「甲」以「乙」。以「丙」 a.concat(b).concat(c);
夫「甲」之一。 a[0]
夫「甲」之其餘。 a.slice(1);
夫「玫瑰」之「「名」」。 rose["name"]
夫「寶劍」之長。 sword.length;

函数

wenyan JavaScript
吾有一術。名之曰「吸星大法」。是術曰。⋯⋯是謂「吸星大法」之術也。 function f(){...}
吾有一術。名之曰「六脈神劍」。欲行是術。必先得六數。曰「甲」。曰「乙」。曰「丙」。曰「丁」。曰「戊」。曰「己」乃行是術曰。⋯⋯是謂「六脈神劍」之術也。 function f(a,b,c,d,e,f){...}
吾有一術。名之曰「翻倍」。欲行是術。必先得一數。曰「甲」。乃行是術曰。乘「甲」以二。名之曰「乙」。乃得「乙」。是謂「翻倍」之術也。 function double(a){var b = a * 2; return b;}

Helloworld demo 

Wenyan:

吾有一數。曰三。名之曰「甲」。
為是「甲」遍。
	吾有一言。曰「「問天地好在。」」。書之。
云云。

等效 JavaScript:

var n = 3;
for (var i = 0; i < n; i++) {
	console.log("問天地好在。");
}

输出:

問天地好在。
問天地好在。
問天地好在。

同时,标点和换行符是完全可选的,与古汉语一致,上面的代码等效于:

吾有一數曰三名之曰「甲」為是「甲」遍吾有一言曰「「問天地好在」」書之云云

 

的码云指数为
超过 的项目
加载中

评论(114)

OSC_TeoFbN
OSC_TeoFbN
楼主是在练习写编译器,大家别在意
麦琪
麦琪
要是拿纯开发的眼光去看,肯定是意义不大。
猫可乐
本来编程就是为了方便,弄这么多字和特殊字符不累赘吗?
大风起兮屁屁凉
大风起兮屁屁凉
牛逼得作者,我只能一句卧槽敬之
我等到花儿也谢了
啥玩应,,,奇门遁甲啊
茶码古道
茶码古道
软件行业里的手工耿
757390
757390
别这么说 手工耿的东西比这个好玩多了
之渊
之渊
这种外星人都看不懂,破解太难了
h_o_r_i_z_o_n
h_o_r_i_z_o_n
可见大家对这种没什么卵用的项目还是喜闻乐见的哈哈哈哈哈哈哈哈
大盘
大盘
用这个开发套系统,交接给下一任,下一任要疯
不能喝奶茶
我打算将这个应用在我们系统里面去😂😂😂😂

文言文编程语言来了,可是好像比英文更难写了!

近日有开发者开源了一门新的编程语言,吸引了大量开发者的目光,短短几天获得了 3k+ star。 该语言名为“文言(wenyan-lang)”,这是一门采用文言文输入的编程语言,该语言不包括英文字符,...

2019/12/19 08:34

没有更多内容

加载失败,请刷新页面

没有更多内容

2
回答
【一周】统一操作系统、文言文编程语言、IntelliJ平台2020年roadmap

回顾一周社区热门资讯 第【五十三】期:20191214-20191220 点击相应标题,跳转阅读全文。 统一操作系统 UOS 龙芯版上线 2020 年,数...

2019/12/22 08:09

没有更多内容

加载失败,请刷新页面

没有更多内容

文言文编程火了,可我完全学不懂

毕竟有易语言在前,有人认为中文可以降低国人学习编程的门槛,也增强汉语的国际地位。然而最近大火的文言文编程语言,让你明白什么叫“中文比英语还难”。 Hello wenyan 最近有个 GitHub 项目...

2019/12/21 18:06
795
0
听说你很厉害,来试试这个...

刚在看开源中国动弹的时候,发现了这样的一条记录 很好奇这里提到的#文言#是什么项目,虽然程序员都是 直肠子, 但是这也太直白了一点。然后就点开了,这一点好像发现了新世界。 文言 项目是什...

2019/12/18 17:20
268
0
文史上最骚的编程语言来了!大四学生发明言文编程语言!秀的我头皮发麻

关注公众号“程序员黄小斜”,选择“置顶或者星标” 一起成为更好的自己! 这两天刷微博、朋友圈、公众号,发现大家都被一个文言文编程的项目圈粉了。 就连中科院计算所研究员、机器翻译领域...

01/04 13:10
97
0
文史上最骚的编程语言来了!大四学生发明言文编程语言!秀的我头皮发麻

关注公众号“程序员黄小斜”,选择“置顶或者星标” 一起成为更好的自己! 这两天刷微博、朋友圈、公众号,发现大家都被一个文言文编程的项目圈粉了。 就连中科院计算所研究员、机器翻译领域...

01/17 21:40
56
0
文史上最骚的编程语言来了!大四学生发明言文编程语言!秀的我头皮发麻

关注公众号“程序员黄小斜”,选择“置顶或者星标” 一起成为更好的自己! 这两天刷微博、朋友圈、公众号,发现大家都被一个文言文编程的项目圈粉了。 就连中科院计算所研究员、机器翻译领域...

01/03 21:17
30
0
文史上最骚的编程语言来了!大四学生发明言文编程语言!秀的我头皮发麻

关注公众号“程序员黄小斜”,选择“置顶或者星标” 一起成为更好的自己! 这两天刷微博、朋友圈、公众号,发现大家都被一个文言文编程的项目圈粉了。 就连中科院计算所研究员、机器翻译领域...

01/02 23:57
15
0
Coding and Paper Letter(七十二)

资源整理。 1 Coding: 1.自动设置GOMAXPROCS以匹配Linux容器CPU配额。 automaxprocs 2.文言文編程語言。今天来自机器之心的推送,虽然我已经先看到了。来自CMU大四的大佬。 wenyan lang 3.此...

2019/12/18 23:03
29
0
ecshop中调用语言切换,实现多国语言

ecshop还是很强大的,稍微改动一下,国际化和繁体的都出来的哦

2014/08/04 16:50
102
0
NO.168 如何做禅道二次开发(4):如何登记菜单

扩展禅道遇到的一个问题就是如何将自己增加的功能登记到菜单中,本篇文章来讲述如何来实现这个功能。 一、菜单的组成 禅道的导航菜单分为三个部分,顶部菜单、模块菜单、功能菜单。 二、菜单...

2016/09/14 15:29
151
1

没有更多内容

加载失败,请刷新页面

返回顶部
顶部