SQLFlow 正在参加 2021 年度 OSC 中国开源项目评选,请投票支持!
SQLFlow 在 2021 年度 OSC 中国开源项目评选 中已获得 {{ projectVoteCount }} 票,请投票支持!
2021 年度 OSC 中国开源项目评选 正在火热进行中,快来投票支持你喜欢的开源项目!
2021 年度 OSC 中国开源项目评选 >>> 中场回顾
SQLFlow 获得 2021 年度 OSC 中国开源项目评选「最佳人气项目」 !
授权协议 Apache-2.0
操作系统 跨平台
软件类型 开源软件
开源组织 蚂蚁金服
地区 国产
投 递 者 h4cd
适用人群 未知
收录时间 2019-05-06

软件简介

SQLFlow 将 SQL 与 AI 结合在一起,扩展了 SQL 语言,使其支持模型训练、预测和推理。它可以连接 MySQL、Hive、SparkSQL 与 SQL Server 等 SQL 引擎,并带有 TensorFlow 和其它机器学习工具包。

  • 此解决方案兼容许多 SQL 引擎,而不是与特定版本或类型兼容。
  • 支持复杂的机器学习模型,包括用于深度学习的 TensorFlow 和用于树的 xgboost。
  • 灵活地配置和运行尖端的 ML 算法,包括指定特征交叉,至少不包含嵌入在 SQL 语句中的 Python 或 R 代码,以及与超参数估计完全集成。

目前支持 MySQL 与 TensorFlow,正在扩展到 Apache Hive、阿里巴巴 ODPS 和 PyTorch。

展开阅读全文

代码

的 Gitee 指数为
超过 的项目

评论

点击加入讨论🔥(8) 发布并加入讨论🔥
发表于AI & 大数据专区
2019/05/08 07:31

蚂蚁金服开源机器学习工具 SQLFlow,让人工智能应用像 SQL 一样简单

5月6日,蚂蚁金服副 CTO 胡喜正式宣布开源机器学习工具 SQLFlow:“未来三年,AI 能力会成为每一位技术人员的基本能力。我们希望通过开源 SQLFlow,降低人工智能应用的技术门槛,让技术人员调用 AI 像 SQL 一样简单。” 与早前的 JavaScript、Swift 等技术极为相似,人工智能技术虽拥趸众多,但门槛极高,不具备广泛的“普适性”,相关的专业人才也非常稀缺。当前人工智能的核心领域是“机器学习”,而深入掌握“机器学习”需要...

8
79
没有更多内容
加载失败,请刷新页面
点击加载更多
加载中
下一页
发表了博客
{{o.pubDate | formatDate}}

{{formatAllHtml(o.title)}}

{{parseInt(o.replyCount) | bigNumberTransform}}
{{parseInt(o.viewCount) | bigNumberTransform}}
没有更多内容
暂无内容
发表了问答
{{o.pubDate | formatDate}}

{{formatAllHtml(o.title)}}

{{parseInt(o.replyCount) | bigNumberTransform}}
{{parseInt(o.viewCount) | bigNumberTransform}}
没有更多内容
暂无内容
FasterXML jackson-databind代码问题漏洞
反序列化
FasterXML Jackson是美国FasterXML公司的一款适用于Java的数据处理工具。jackson-databind是其中的一个具有数据绑定功能的组件。 FasterXML jackson-databind 2.9.10.4之前的2.x版本中存在代码问题漏洞。该漏洞源于网络系统或产品的代码开发过程中存在设计或实现不当的问题。目前没有详细的漏洞细节提供。
CVE-2020-10968 MPS-2020-4658
2022-08-08 18:22
FasterXML jackson-databind代码问题漏洞
反序列化
FasterXML Jackson是美国FasterXML公司的一款适用于Java的数据处理工具。jackson-databind是其中的一个具有数据绑定功能的组件。 FasterXML jackson-databind 2.9.10.5之前的2.x版本中存在安全漏洞。目前没有详细漏洞细节提供。
CVE-2020-14061 MPS-2020-8801
2022-08-08 18:22
FasterXML jackson-databind 代码问题漏洞
反序列化
2.9.10.8 之前的 FasterXML jackson-databind 2.x 错误处理了与 org.docx4j.org.apache.xalan.lib.sql.JNDIConnectionPool 相关的序列化小工具和类型之间的交互。
CVE-2020-36183 MPS-2021-0206
2022-08-08 18:22
go.uuid 安全特征问题漏洞
使用具有密码学弱点缺陷的PRNG
go.uuid是一个用于 Go 的 UUID 包。这个包提供了通用唯一标识符 (UUID) 的纯 Go 实现。支持 UUID 的创建和解析。 go.uuid存在安全漏洞,该漏洞源于g.rand.Read函数中存在不安全的随机性导致攻击者可利用该漏洞可以预测生成的uuid。。
CVE-2021-3538 MPS-2021-7854
2022-08-08 18:22
FasterXML jackson-databind代码问题漏洞
反序列化
FasterXML Jackson是美国FasterXML公司的一款适用于Java的数据处理工具。jackson-databind是其中的一个具有数据绑定功能的组件。 FasterXML jackson-databind 2.9.10.4之前的2.x 版本中存在安全漏洞。目前没有详细的漏洞细节提供。
CVE-2020-11111 MPS-2020-4754
2022-08-08 18:22
Apache Log4j 信任管理问题漏洞
证书验证不恰当
Apache Log4j是美国阿帕奇(Apache)基金会的一款基于Java的开源日志记录工具。 Apache Log4j中存在信任管理问题漏洞,该漏洞源于SmtpAppender没有验证主机名称与SMTPS连接的SSL/TLS证书是否匹配。攻击者可通过实施中间人攻击利用该漏洞拦截SMTPS连接,获取日志消息。
CVE-2020-9488 MPS-2020-6684
2022-08-08 18:22
Apache Log4j2 远程代码执行漏洞
反序列化
Apache log4j是java中常用的日志记录组件。 由于log4j2默认支持JNDI在内的Lookup查找机制,当日志内容中包含${foo.bar}样式的内容时,会查找相应的值进行替换。因此当用户请求中的内容通过log4j作为日志内容记录时,攻击者可能通过恶意构造的内容,触发log4j的lookup方法,进而执行恶意代码。
CVE-2021-44228 MPS-2021-38241
2022-08-08 18:22
io.grpc:grpc-core 内存信息暴露漏洞
通过发送数据的信息暴露
io.grpc:grpc-core 是一个基于 HTTP/2 的 RPC 框架 。 io.grpc:grpc-core在监听器抛出异常和执行器立即关闭同时发生的情况下会导致内存信息泄露,最终会泄漏错误日志,攻击者可能会利用漏洞获取堆栈信息。
MPS-2022-12216
2022-08-08 18:22
FasterXML jackson-databind代码问题漏洞
反序列化
FasterXML Jackson是美国FasterXML公司的一款适用于Java的数据处理工具。jackson-databind是其中的一个具有数据绑定功能的组件。 FasterXML jackson-databind 2.9.10.4之前的2.x版本中存在安全漏洞。目前没有详细的漏洞细节提供。
CVE-2020-10969 MPS-2020-4659
2022-08-08 18:22
Google protobuf 安全漏洞
不正确的行为次序
Google protobuf是美国谷歌(Google)公司的一种数据交换格式。 protobuf-java 存在安全漏洞,该漏洞允许一个小的恶意负载可以通过创建大量导致频繁、重复暂停的短期对象来占用解析器几分钟。
CVE-2021-22569 MPS-2021-19066
2022-08-08 18:22
Apache Commons Compress 资源管理错误漏洞
不可达退出条件的循环(无限循环)
Apache Commons Compress是美国阿帕奇(Apache)基金会的一个用于处理压缩文件的库。 Apache Commons Compress 1.7版本至1.17版本中存在资源管理错误漏洞,该漏洞源于在数据流结束后,ZipArchiveInputStream的读取方法没有返回正确的文件结束符指示。攻击者可通过发送特制的ZIP归档文件利用该漏洞造成拒绝服务。
CVE-2018-11771 MPS-2018-11233
2022-08-08 18:22
FasterXML Jackson-databind服务器端请求伪造漏洞
SSRF
FasterXML Jackson是美国FasterXML公司的一款用于Java的数据处理工具。Jackson-databind是其中的一个具有数据绑定功能的组件。 FasterXML Jackson-databind 2.9.7之前的2.x版本中存在服务器端请求伪造漏洞,远程攻击者可利用该漏洞执行服务器端请求伪造攻击。
CVE-2018-14721 MPS-2019-0021
2022-08-08 18:22
FasterXML Jackson-databind代码问题漏洞
反序列化
FasterXML Jackson是美国FasterXML公司的一款用于Java的数据处理工具。Jackson-databind是其中的一个具有数据绑定功能的组件。 FasterXML Jackson-databind 2.9.8之前的2.x版本中存在安全漏洞。攻击者可利用该漏洞执行代码。
CVE-2018-19362 MPS-2019-0025
2022-08-08 18:22
FasterXML jackson-databind 代码问题漏洞
反序列化
2.9.10.8 之前的 FasterXML jackson-databind 2.x 错误处理了与 org.apache.commons.dbcp2.datasources.SharedPoolDataSource 相关的序列化小工具和类型之间的交互。
CVE-2020-35491 MPS-2020-17697
2022-08-08 18:22
FasterXML jackson-databind反序列化漏洞
反序列化
FasterXML Jackson是美国FasterXML公司的一款适用于Java的数据处理工具。jackson-databind是其中的一个具有数据绑定功能的组件。 FasterXML jackson-databind 2.9.10.4之前的2.x版本中存在安全漏洞,该漏洞源于org.apache.aries.transaction.jms.internal.XaPooledConnectionFactory(aries.transaction.jms)进行了不安全的反序列化。远程攻击者可借助特制的输入利用该漏洞在系统上执行任意代码。
CVE-2020-10672 MPS-2020-4131
2022-08-08 18:22
FasterXML jackson-databind 代码问题漏洞
反序列化
2.9.10.8 之前的 FasterXML jackson-databind 2.x 错误处理了与 org.apache.commons.dbcp2.cpdsadapter.DriverAdapterCPDS 相关的序列化小工具和类型之间的交互。
CVE-2020-36180 MPS-2021-0204
2022-08-08 18:22
Apache Log4j 代码问题漏洞
反序列化
Apache Log4j是Apache基金会的一款基于Java的开源日志记录工具。 在Apache Log4j 2.15.0中解决CVE-2021-44228的修复在某些非默认配置中不完整:当日志配置使用具有上下文查找或线程上下文映射模式时,攻击者可以使用 JNDI 查找模式制作恶意输入数据,从而导致信息泄漏和某些环境中的远程代码执行以及所有环境中的本地代码执行。
CVE-2021-45046 MPS-2021-38665
2022-08-08 18:22
FasterXML Jackson-databind代码问题漏洞
反序列化
FasterXML Jackson是美国FasterXML公司的一款用于Java的数据处理工具。Jackson-databind是其中的一个具有数据绑定功能的组件。 FasterXML Jackson-databind 2.9.8之前的2.x版本中存在安全漏洞。攻击者可利用该漏洞执行代码。
CVE-2018-19361 MPS-2019-0024
2022-08-08 18:22
FasterXML jackson-databind 代码问题漏洞
反序列化
FasterXML Jackson是美国FasterXML公司的一款适用于Java的数据处理工具。jackson-databind是其中的一个具有数据绑定功能的组件。 FasterXML jackson-databind 2.0.0版本至2.9.10版本中存在代码问题漏洞。该漏洞源于网络系统或产品的代码开发过程中存在设计或实现不当的问题。攻击者可利用该漏洞执行恶意的payload。
CVE-2019-17531 MPS-2019-13103
2022-08-08 18:22
FasterXML jackson-databind 代码问题漏洞
反序列化
FasterXML jackson-databind是一个基于JAVA可以将XML和JSON等数据格式与JAVA对象进行转换的库。Jackson可以轻松的将Java对象转换成json对象和xml文档,同样也可以将json、xml转换成Java对象。 FasterXML jackson-databind 2.0系列2.9.10.6之前版本存在代码问题漏洞,该漏洞源于com.pastdev.httpcomponents.configuration.JndiConfiguration。
CVE-2020-24750 MPS-2020-13151
2022-08-08 18:22
没有更多内容
加载失败,请刷新页面
点击加载更多
加载中
下一页
8 评论
150 收藏
分享
OSCHINA
登录后可查看更多优质内容
返回顶部
顶部