Space Cloud 正在参加 2021 年度 OSC 中国开源项目评选,请投票支持!
Space Cloud 在 2021 年度 OSC 中国开源项目评选 中已获得 {{ projectVoteCount }} 票,请投票支持!
2021 年度 OSC 中国开源项目评选 正在火热进行中,快来投票支持你喜欢的开源项目!
2021 年度 OSC 中国开源项目评选 >>> 中场回顾
Space Cloud 获得 2021 年度 OSC 中国开源项目评选「最佳人气项目」 !
授权协议 Apache-2.0
开发语言 Google Go
操作系统 跨平台
软件类型 开源软件
所属分类 云计算Serverless 系统
开源组织
地区 不详
投 递 者 白开水不加糖
适用人群 未知
收录时间 2021-08-13

软件简介

Space Cloud 是一个基于 Kubernetes 的 Serverless 平台,可在任何数据库上提供即时、实时的 API,为您的自定义业务逻辑提供事件触发器和统一 API 。

在大多数情况下,Space Cloud 可帮助你构建现代应用程序,而无需编写任何后端代码。它提供了GraphQL和REST API,你的前端可以以安全的方式直接使用它们。

Space Cloud 旨在通过以下方式简化平台开发:

  • 消除需要写在大多数情况下,任何后端代码。
  • 提供一种简单的方法来为高级用例编写事件驱动的微服务。
  • 通过在 Kubernetes 和 Istio 之上实施云原生实践,确保您的应用程序具有可扩展性。
  • 将安全性作为单独的层引入,以使你的平台更加安全。

特性:

  • 强大的 CRUD:灵活的查询、事务、聚合和跨数据库连接
  • 实时:对您的数据库进行实时查询
  • 文件存储:将文件上传/下载到可扩展的文件存储(例如,Amazon S3、Google Cloud Storage)
  • 可扩展:用于自定义 HTTP 服务的统一 API
  • 事件驱动:在数据库或文件存储事件上触发 webhook 或无服务器功能
  • 细粒度访问控制:与您的身份验证系统集成的动态访问控制(例如,auth0、firebase-auth)
  • Scalable : 用 Golang 编写,遵循云原生实践,可横向扩展
  • 服务网格:无需学习任何内容即可获得服务网格的所有功能!
  • 缩减至零:自动扩展您的 http 工作负载,包括缩减至零

支持的数据库:

  • MongoDB
  • PostgreSQL和 PostgreSQL 兼容数据库(例如 CockroachDB、Yugabyte 等)
  • MySQL和 MySQL 兼容数据库(例如 TiDB、MariaDB 等)
  • 数据库服务器
展开阅读全文

代码

的 Gitee 指数为
超过 的项目

评论

点击引领话题📣
暂无内容
发表了博客
{{o.pubDate | formatDate}}

{{formatAllHtml(o.title)}}

{{parseInt(o.replyCount) | bigNumberTransform}}
{{parseInt(o.viewCount) | bigNumberTransform}}
没有更多内容
暂无内容
发表了问答
{{o.pubDate | formatDate}}

{{formatAllHtml(o.title)}}

{{parseInt(o.replyCount) | bigNumberTransform}}
{{parseInt(o.viewCount) | bigNumberTransform}}
没有更多内容
暂无内容
go.uuid 安全特征问题漏洞
使用具有密码学弱点缺陷的PRNG
go.uuid是一个用于 Go 的 UUID 包。这个包提供了通用唯一标识符 (UUID) 的纯 Go 实现。支持 UUID 的创建和解析。 go.uuid存在安全漏洞,该漏洞源于g.rand.Read函数中存在不安全的随机性导致攻击者可利用该漏洞可以预测生成的uuid。。
CVE-2021-3538 MPS-2021-7854
2022-08-08 18:19
helm 注入漏洞
注入
helm是一款Kubernetes包管理器。 Helm 存在注入漏洞,该漏洞源于从可能不受信任的源加载的数据没有得到适当的处理。
CVE-2021-21303 MPS-2021-1094
2022-08-08 18:19
kubernetes 安全漏洞
对外部实体的文件或目录可访问
Kubernetes是美国Linux基金会的一套开源的Docker容器集群管理系统。该系统为容器化的应用提供资源调度、部署运行、服务发现和扩容缩容等功能。 kubernetes 存在安全漏洞,攻击者可利用该漏洞通过创建具有精心编制的子路径卷装载的pod,以访问卷外的文件和目录,包括主机节点的文件系统上的文件和目录
CVE-2021-25741 MPS-2021-20883
2022-08-08 18:19
GJSON 安全漏洞
拒绝服务
Tidwall Gjson是Tidwall个人开发者的一个基于Go语言的用于与json格式数据进行交互的代码库。 GJSON 存在安全漏洞,该漏洞源于1.9.3之前的GJSON允许ReDoS(正则表达式拒绝服务)攻击。
CVE-2021-42836 MPS-2021-34246
2022-08-08 18:19
Tidwall Gjson 输入验证错误漏洞
对数组索引的验证不恰当
Tidwall Gjson是Tidwall个人开发者的一个基于Go语言的用于与json格式数据进行交互的代码库。 GJSON <=v1.6.5 存在安全漏洞,该漏洞允许攻击者通过一个精心制作的GET调用导致拒绝服务。
CVE-2020-36067 MPS-2021-5981
2022-08-08 18:19
Google Kubernetes API Server 资源管理错误漏洞
循环内过多的平台资源消耗
Google Kubernetes是美国谷歌(Google)公司的一套开源的Docker容器集群管理系统。该系统为容器化的应用提供资源调度、部署运行、服务发现和扩容缩容等功能。API server是其中的一个API(应用编程接口)服务器。 Google Kubernetes 1.15.10之前版本、1.16.7之前版本和1.17.3之前版本中的API Server组件存在资源管理错误漏洞。远程攻击者可借助特制请求利用该漏洞造成拒绝服务。
CVE-2019-11254 MPS-2020-44793
2022-08-08 18:19
Kubernetes 安全漏洞
授权机制不正确
Kubernetes是美国Linux基金会的一套开源的Docker容器集群管理系统。该系统为容器化的应用提供资源调度、部署运行、服务发现和扩容缩容等功能。 Kubernetes 存在安全漏洞,攻击者可利用该漏洞可以通过Kubernetes上的LoadBalancer ExternalIP充当中间人,以便在会话中读取或写入数据。
CVE-2020-8554 MPS-2021-0679
2022-08-08 18:19
xz 安全漏洞
不可达退出条件的循环(无限循环)
xz是一个应用软件。用于支持读取和写入xz压缩流。 xz v0.5.8之前版本存在安全漏洞,该漏洞源于readUvarint函数用于读取xz容器格式可能不会终止循环提供恶意输入。
CVE-2021-29482 MPS-2021-5253
2022-08-08 18:19
Tidwall Gjson 安全漏洞
Tidwall Gjson是Tidwall个人开发者的一个基于Go语言的用于与json格式数据进行交互的代码库。 GJSON 1.6.5之前版本存在安全漏洞,该漏洞允许攻击者通过精心制作的JSON导致拒绝服务(远程)。
CVE-2020-36066 MPS-2021-5980
2022-08-08 18:19
miekg Go DNS package 安全特征问题漏洞
使用具有密码学弱点缺陷的PRNG
miekg Go DNS package是一款DNS服务器软件包。 miekg Go DNS package 1.1.25之前版本(用在CoreDNS 1.6.6之前版本和其他产品)中存在安全漏洞,该漏洞源于程序没有正确生成随机数。攻击者可利用该漏洞伪造响应。
CVE-2019-19794 MPS-2019-16292
2022-08-08 18:19
Google Go 安全漏洞
不可达退出条件的循环(无限循环)
Google Go是美国谷歌(Google)公司的一款静态强类型、编译型、并发型,并具有垃圾回收功能的编程语言。 Google Go 1.13.15之前版本和1.14.7之前的14.x版本中存在安全漏洞。攻击者可借助无效的输入利用该漏洞造成无限读取循环。
CVE-2020-16845 MPS-2020-11223
2022-08-08 18:19
jwt-go 安全漏洞
授权机制缺失
jwt-go是个人开发者的一个Go语言的JWT实现。 jwt-go 4.0.0-preview1之前版本存在安全漏洞。攻击者可利用该漏洞在使用[]string{} for m[\"aud\"](规范允许)的情况下绕过预期的访问限制。
CVE-2020-26160 MPS-2020-13786
2022-08-08 18:19
Tidwall Gjson 输入验证错误漏洞
Tidwall Gjson是Tidwall个人开发者的一个基于Go语言的用于与json格式数据进行交互的代码库。 GJSON before 1.6.4 版本存在输入验证错误漏洞,该漏洞源于网络系统或产品未对输入的数据进行正确的验证, 攻击者可通过精心制作的JSON导致拒绝服务。
CVE-2020-35380 MPS-2020-17613
2022-08-08 18:19
没有更多内容
加载失败,请刷新页面
点击加载更多
加载中
下一页
0 评论
1 收藏
分享
OSCHINA
登录后可查看更多优质内容
返回顶部
顶部