Sonic Pi 正在参加 2021 年度 OSC 中国开源项目评选,请投票支持!
Sonic Pi 在 2021 年度 OSC 中国开源项目评选 中已获得 {{ projectVoteCount }} 票,请投票支持!
2021 年度 OSC 中国开源项目评选 正在火热进行中,快来投票支持你喜欢的开源项目!
2021 年度 OSC 中国开源项目评选 >>> 中场回顾
Sonic Pi 获得 2021 年度 OSC 中国开源项目评选「最佳人气项目」 !
授权协议 MIT
操作系统 跨平台
软件类型 开源软件
开源组织
地区 不详
投 递 者 白开水不加糖
适用人群 未知
收录时间 2021-08-20

软件简介

Sonic Pi 是一种基于代码的音乐创作和演奏工具。Sonic Pi 是一种新型的乐器,你可以现场编写代码。

Sonic Pi 的设计旨在在三个核心原则之间找到和谐的平衡:

  • 足够简单,适合你内心深处的10岁小孩
  • 足够快乐,让你在游戏中失去自我
  • 足够强大,可以让你自己表达出来

Sonic Pi 是一个完整的开源编程环境,最初是为了在学校内通过创造新的声音的过程来探索和教授编程概念。除了作为一个引人入胜的教育资源,它已经发展成为一个非常强大的、适合表演的现场编码工具,适合专业艺术家和DJ使用。

虽然教育是一个核心重点,但它现在位于三个核心领域的交叉点:

  • Art -- 提供表达自己的方式,并对音乐和符号提出新的问题
  • Technology -- 探索与编程语言中的有效性、时间和并发性有关的问题
  • Education -- 证明开放的游戏而不是僵硬的结构能提高课堂的积极性和参与度
展开阅读全文

代码

的 Gitee 指数为
超过 的项目

评论

点击加入讨论🔥(2)
暂无内容
发表了博客
{{o.pubDate | formatDate}}

{{formatAllHtml(o.title)}}

{{parseInt(o.replyCount) | bigNumberTransform}}
{{parseInt(o.viewCount) | bigNumberTransform}}
没有更多内容
暂无内容
发表了问答
{{o.pubDate | formatDate}}

{{formatAllHtml(o.title)}}

{{parseInt(o.replyCount) | bigNumberTransform}}
{{parseInt(o.viewCount) | bigNumberTransform}}
没有更多内容
暂无内容
libiberty 安全漏洞
UAF
libiberty是一个GNU程序使用的子程序的集合。 libiberty中存在释放后重用漏洞。远程攻击者可利用该漏洞造成拒绝服务(段错误和崩溃)。
CVE-2016-4487 MPS-2017-2070
2022-08-08 20:28
libiberty 安全漏洞
UAF
libiberty是一个GNU程序使用的子程序的集合。 libiberty中存在释放后重用漏洞。远程攻击者可利用该漏洞造成拒绝服务(段错误和崩溃)。
CVE-2016-4488 MPS-2017-2071
2022-08-08 20:28
libiberty 数字错误漏洞
整数溢出或超界折返
libiberty是一个GNU程序使用的子程序的集合。 libiberty中的‘gnu_special’函数存在整数溢出漏洞。远程攻击者可利用该漏洞造成拒绝服务(段错误和崩溃)。
CVE-2016-4489 MPS-2017-2072
2022-08-08 20:28
libiberty 数字错误漏洞
整数溢出或超界折返
libiberty是一个GNU程序使用的子程序的集合。 libiberty中的cp-demangle.c文件存在整数溢出漏洞。远程攻击者可利用该漏洞造成拒绝服务(段错误和崩溃)。
CVE-2016-4490 MPS-2017-2073
2022-08-08 20:28
libiberty 安全漏洞
内存缓冲区边界内操作的限制不恰当
libiberty是一个GNU程序使用的子程序的集合。 libiberty中的cp-demangle.c文件的‘d_print_comp’函数存在安全漏洞。远程攻击者可利用该漏洞造成拒绝服务(段错误和崩溃)。
CVE-2016-4491 MPS-2017-2074
2022-08-08 20:28
libiberty 安全漏洞
跨界内存读
libiberty是一个GNU程序使用的子程序的集合。 libiberty中的cplus-dem.c文件的‘demangle_template_value_parm’和‘do_hpacc_template_literal’函数存在安全漏洞。远程攻击者可利用该漏洞造成拒绝服务(越边界读取和崩溃)。
CVE-2016-4493 MPS-2017-2076
2022-08-08 20:28
GNU Libiberty 安全漏洞
输入验证不恰当
GNU libiberty是一个GNU程序使用的子程序的集合。 GNU Libiberty中的demangler存在安全漏洞。远程攻击者可利用该漏洞造成拒绝服务(无限循环、栈溢出和崩溃)。
CVE-2016-6131 MPS-2017-1331
2022-08-08 20:28
libiberty 数字错误漏洞
libiberty是一个GNU程序使用的子程序的集合。 libiberty中的cplus-dem.c文件的‘string_appends’函数存在整数溢出漏洞。远程攻击者可利用该漏洞执行任意代码。
CVE-2016-2226 MPS-2017-2066
2022-08-08 20:28
没有更多内容
加载失败,请刷新页面
点击加载更多
加载中
下一页
2 评论
21 收藏
分享
OSCHINA
登录后可查看更多优质内容
返回顶部
顶部