RubyGems 正在参加 2020 年度 OSC 中国开源项目评选,请投票支持!
RubyGems 在 2020 年度 OSC 中国开源项目评选 中已获得 {{ projectVoteCount }} 票,请投票支持!
投票让它出道
已投票
RubyGems 获得 2020 年度 OSC 中国开源项目评选「最佳人气项目」 !
RubyGems 获得 2020 年度 OSC 中国开源项目评选「最佳人气项目」「最积极运营项目」 !
RubyGems 获得 2020 年度 OSC 中国开源项目评选「最积极运营项目」 !

软件简介

RubyGems是一个方便而强大的Ruby程序包管理器( package manager),类似RedHat的RPM.它将一个Ruby应用程序打包到一个gem里,作为一个安装单元。 特点: 能远程安装包 包之间依赖关系的管理 简单可靠的卸载(uninstallation) 查询机制,能查询本地和远程服务器的包信息 能保持一个包的不同版本 基于Web的查看接口,能查看你安装的gem的信息。

展开阅读全文

评论 (0)

加载中
更多评论
发表了资讯
2011/12/25 00:00

淘宝提供了RubyGems的国内镜像站点

由于Rubygems官方网站被Wall了,导致Ruby程序员在线安装软件gem包的时候无法顺利进行,往往需要借助VPN才能成功安装,所以带来了很大的不便。 最近淘宝网提供了Rubygems的国内镜像站:http://ruby.taobao.org/ 从淘宝的国内镜像网站在线下载和安装Gem包速度变得飞快! 强烈推荐大家使用此镜像站点: 例如要安装Rails,可...

18
24
发表了资讯
2011/06/28 00:00

RubyGems 最新版本 1.8.5

RubyGems是一个方便而强大的Ruby程序包管理器( package manager),类似RedHat的RPM.它将一个Ruby应用程序打包到一个gem里,作为一个安装单元。 特点: 能远程安装包 包之间依赖关系的管理 简单可靠的卸载(uninstallation) 查询机制,能查询本地和远程服务器的包信息 能保持一个包的不同版本 基于Web的查看接口,能查...

0
0
发表了资讯
2011/05/20 00:00

RubyGems 1.8.3 发布

RubyGems是一个方便而强大的Ruby程序包管理器( package manager),类似RedHat的RPM.它将一个Ruby应用程序打包到一个gem里,作为一个安装单元。 特点: 能远程安装包 包之间依赖关系的管理 简单可靠的卸载(uninstallation) 查询机制,能查询本地和远程服务器的包信息 能保持一个包的不同版本 基于Web的查看接口,能查...

0
1
发表了资讯
2010/12/20 00:00

RubyGems模组数即将超过CPAN

根据modulecounts.com收集的数据,RubyGems的模组总数达到18,894,每天增加27个,逼近CPAN,CPAN模组数共有18,928个,每天增加8个。预计RubyGems模组数将在本周内超过CPAN。RubyGems是Ruby语言的包管理器,CPAN是Perl语言的综合典藏网络。

4
0
发表了资讯
2009/07/22 00:00

Ruby包管理器 RubyGems 1.3.5 发布

RubyGems是一个方便而强大的Ruby程序包管理器( package manager),类似RedHat的RPM.它将一个Ruby应用程序打包到一个gem里,作为一个安装单元。 特点: 能远程安装包 包之间依赖关系的管理 简单可靠的卸载(uninstallation) 查询机制,能查询本地和远程服务器的包信息 能保持一个包的不同版本 基于Web的查看接口,能查...

0
0
发表了资讯
2009/05/06 00:00

RubyGems 1.3.3 版本发布

RubyGems是一个方便而强大的Ruby程序包管理器( package manager),类似RedHat的RPM.它将一个Ruby应用程序打包到一个gem里,作为一个安装单元。 特点: 能远程安装包 包之间依赖关系的管理 简单可靠的卸载(uninstallation) 查询机制,能查询本地和远程服务器的包信息 能保持一个包的不同版本 基于Web的查看接口,能查...

0
0
没有更多内容
加载失败,请刷新页面
点击加载更多
加载中
下一页
发表了博客
2018/09/28 16:13

RubyGems系列之RubyGems初识

转载请标明来源:https://www.cnblogs.com/zhanggui/p/9719291.html 一. 基础理解 RubyGems简称gems,它是一个用于对Ruby组件进行打包的Ruby打包系统。使用它可以方便地下载安装Ruby的软件包到用户的系统。一个软件包叫做 一个gem,它包含了一个打包的Ruby Application或者一个library。 二. RubyGems安装 首先在这里下载...

0
0
发表了博客
2015/04/30 14:52

RubyGems 镜像

为什么有这个? 由于国内网络原因(你懂的),导致 rubygems.org 存放在 Amazon S3 上面的资源文件间歇性连接失败。所以你会与遇到 gem install rack 或 bundle install的时候半天没有响应,具体可以用 gem install rails -V 来查看执行过程。 这是一个完整 rubygems.org 镜像,你可以用此代替官方版本,同步频率目前为1...

0
1
发表于AI & 大数据专区
2014/10/15 21:47

淘宝RubyGems 镜像

$ gem sources --remove https://rubygems.org/ $ gem sources -a https://ruby.taobao.org/ $ gem sources -l *** CURRENT SOURCES *** https://ruby.taobao.org # 请确保只有 ruby.taobao.org $ gem install rails...

0
4
发表了博客
2019/12/19 17:42

/usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such fil...

报错信息: /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- redis (LoadError) from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require' from ./redis-trib.rb:25:in `<main>' 问题描述:   今天在搭建redis集群时,在Linux Centos 7中,...

0
0
发表了博客
2020/05/20 13:50

如果gem因权限错误而失败,如何安装gem或更新RubyGems

问题: I'm trying to install a gem using gem install mygem or update RubyGems using gem update --system , and it fails with this error: 我正在尝试使用gem install mygem或使用gem update --system更新R......

0
0
发表于软件架构专区
2014/02/27 14:30

Python-pip, RubyGems, node-npm使用国内镜像加速下载

Python PyPI (pip) 编辑~/.pip/pip.conf: nano ~/.pip/pip.conf 添加 [global] index-url = http://pypi.douban.com/simple 豆瓣源 Node NPM 编辑 ~/.npmrc nano ~/.npmrc 添加 registry = http://registry.cnpmjs.org 参考来源 Ruby Gem $ gem sources --remove https://rubygems.org/ $ gem sources -a http://ruby.t...

0
5
发表了博客
2019/01/02 14:12

Rvm 进行gem安装时必须输入密码Your user account isn't allowed to install to the system RubyGems 解决方案

今天开发过程中,从master拉下代码后重启项目,想用控制台时,却发现需要密码??并且三次密码确认后还是疯狂报错。 当时第一想到是rvm版本不一致,随即则检查了版本跟gem生成,当确认rvm版本无误时,且强制使用sudo安装却需要一条条执行gem install ***安装gem包时,就令我抓狂了。 警告提示如下: Your user account i...

0
0
发表于大前端专区
2016/10/26 11:05

RubyGems使用RubyChina镜像

RubyGems使用RubyChina镜像,也就是原淘宝镜像

0
0
发表于大前端专区
2016/06/24 23:37

Ruby: Warning: You're using Rubygems 2.0.14

Ruby: Warning: You're using Rubygems 2.0.14 with Spring. Upgrade to at least Rubygems 2.1.0

0
0
发表于DevOps专区
2015/05/03 18:35

关于Gitlab的搭建中RubyGems的七七八八问题

如果你搭建过Gitlab,你一定不会对RubyGem陌生。RubyGems就是哪些通过“gem install”命令安装的第三方插件。 搭建gitlab的步骤我这里不写了,建议需要搭建的帅哥美女们最好去官方github上面看,不要偷懒用baidu去搜索,然后照着做,我肯定你98.75%是不能完成的,里面估计会出现千奇百怪的问题。 官方安装文档地址如下:...

0
0
没有更多内容
加载失败,请刷新页面
点击加载更多
加载中
下一页
发表了问答
2015/08/19 13:51

cloud foundry

各位大哥,有没有一个稍微详细一点的clouf foundry安装文档和openstack的安装文档以及部署要求的资料,急需用,老大说下周在干不完我就不用来了,这是邮箱 1940233131@qq.com ,哪位兄弟要是有的求分享一个,感激不尽啊!!!

1
0
发表了问答
2015/01/16 10:35

bundle install时出错,对Gemfile.lock没有写权限

报错信息: There was an error while trying to write to Gemfile.lock. It is likely that you need to allow write permissions for the file at path: /var/www/html/redmine/Gemfile.lock 如图: 我在/var/www/html/redmine/目录下,并未发现Gemfile.lock这个文件,只有Gemfile这个文件。 试了好久,都不知道怎么解...

4
0
发表了问答
2012/11/14 20:46

rvm,gems,rubygems,bundle,gemfile,git,rake,怎么这么多概念,都是干什么用的?

本文系转载 原文:http://yinghuayuan8866.blog.163.com/blog/static/2245702720122909571/ 作者:寒秋雪狼——生活很美 RVM(Ruby Version Manager): is a command-line tool which allows you to easily install, manage, and work with multiple ruby environments from interpreters to sets of gems. 用于帮你安装...

1
2
发表了问答
2011/04/21 21:25

ruby gem更新报错

这是什么原因呢?

1
0
发表了问答
2011/12/01 10:19

Sencha Touch 自定义主题

Sencha Touch 自定义主题: 可参考以下文章: 1 http://www.vinylfox.com/custom-styling-a-sencha-touch-app/ 2 http://www.sencha.com/blog/an-introduction-to-theming-sencha-touch 步骤: 1 首先安装ruby(Windows 需要 Ruby and RubyGems )。 a 首先安装Ruby, 然后配置环境变量 b gem install sass gem install c...

1
2
没有更多内容
加载失败,请刷新页面
点击加载更多
加载中
下一页
0 评论
17 收藏
分享
OSCHINA
登录后可查看更多优质内容
返回顶部
顶部