postcss-bem-linter

MIT
JavaScript
跨平台
2015-08-06
sikkx

postcss-bem-linter 是一个用于 postcss 的 BEM linter 工具。

有了这个插件,你可以通过对照一组 BEM 风格的约定,来检查样式表的有效性;可以使用预设模式(目前是 SUIT 和 BEM),或插入你自己的;如果发现CSS不遵循规定的约定,该插件将有提示警告,


加载中

评论(0)

暂无评论

暂无资讯

暂无问答

vue cli 3.0快速创建项目【内容仅供参考】

本地安装vue-cli 前置条件 更新npm到最新版本 命令行运行: npm install -g npm npm就自动为我们更新到最新版本 淘宝npm镜像使用方法 npm config set registry https://registry.npm.taobao....

01/10 09:07
1
0
postcss替换sass-loader

实际需求: 已经使用了postcss autoprefixer ,而且sass-loader又依赖于node-sass,而且node-sass又是一堆坑(比如centos升级node6->node8后的安装权限问题),所以想简单使用Postcss 处理s...

2018/07/17 11:10
65
0
EasyUI的Vue版本

背景 最近Easyui释放出了vue版本,尝试一波。 vue cli3 cli的全称是command-line interface,即命令行界面,简而意之vue cli就是vue的命令行界面版本。这里假设你已经安装好了npm(全称 Node...

2018/09/13 14:49
1K
3
webpack结合less开启css modules,实现组件之间的 less,css互不干扰

开启less的modules,关闭css的modules { test: /\.less$/, use: [ require.resolve('style-loader'), { loader: require.resolve(......

2018/08/07 10:17
236
0
Vue CLI 3 自适应解决方案 postcss-px2rem和amfe-flexible

安装postcss-px2rem cnpm i postcss-px2rem -S 配置postcss-px2rem //.postcssrc.js module.exports = { plugins: { autoprefixer: {}, 'postcss-px2rem': { remUnit: 37.5 } } } 安装......

2018/09/04 09:35
665
0
webpack CSS LESS

官网 https://webpack.docschina.org/loaders/postcss-loader/ css 打包 分离 安装 npm install --save-dev extract-text-webpack-plugin 引入 const ExtractTextPlugin = require('extract...

2018/09/14 09:42
6
0

没有更多内容

加载失败,请刷新页面

返回顶部
顶部