Poke 正在参加 2021 年度 OSC 中国开源项目评选,请投票支持!
Poke 在 2021 年度 OSC 中国开源项目评选 中已获得 {{ projectVoteCount }} 票,请投票支持!
2021 年度 OSC 中国开源项目评选 正在火热进行中,快来投票支持你喜欢的开源项目!
2021 年度 OSC 中国开源项目评选 >>> 中场回顾
Poke 获得 2021 年度 OSC 中国开源项目评选「最佳人气项目」 !
授权协议 未知
开发语言 JavaScript TypeScript
操作系统 跨平台
软件类型 开源软件
所属分类 游戏/娱乐休闲游戏
开源组织
地区 国产
适用人群 未知
收录时间 2019-02-15

软件简介

Poke 一款比较流行的的斗地主游戏主。主要功能如下:

  • 实现了最经典的斗地主玩法,叫地主抢地主等功能。
  • 支持随机匹配模式,主动创建房间邀请微信好友模式两种。
  • 接入Matchvs独立的排行榜系统。

分为客户端和服务端两个部分,client 是使用 Egret 实现的,server 是使用 matchvs gameServer nodejs版实现。项目目录结构如下:

┌-client Egret实现的客户端代码
├-gs-server Matchvs gameServer nodejs 实现的服务端代码
├-matchvs Matchvs客户端SDK
├-wxshare 封装的微信小游戏接口
└-README

Poker 排行榜实现方法如下:

 

展开阅读全文

代码

的 Gitee 指数为
超过 的项目

评论

点击加入讨论🔥(5)
暂无内容
发表了博客
{{o.pubDate | formatDate}}

{{formatAllHtml(o.title)}}

{{parseInt(o.replyCount) | bigNumberTransform}}
{{parseInt(o.viewCount) | bigNumberTransform}}
没有更多内容
暂无内容
发表了问答
{{o.pubDate | formatDate}}

{{formatAllHtml(o.title)}}

{{parseInt(o.replyCount) | bigNumberTransform}}
{{parseInt(o.viewCount) | bigNumberTransform}}
没有更多内容
暂无内容
minimist 输入验证错误漏洞
原型污染
minimist是一款命令行参数解析工具。 minimist 1.2.2之前版本存在输入验证错误漏洞。攻击者可借助‘constructor’和‘__proto__’ payload利用该漏洞添加或修改Object.prototype的属性。
CVE-2020-7598 MPS-2020-3516
2022-08-08 20:54
Nathan Rajlich node-http-proxy-agent 安全漏洞
初始化不恰当
Nathan Rajlich node-http-proxy-agent是 (Nathan Rajlich)开源的一个应用程序。提供了一种http.Agent连接到指定的HTTP或HTTPS代理服务器的实现,并且可以与内置http模块一起使用。 http-proxy-agent prior to version 2.1.0 存在安全漏洞,该漏洞源于攻击者可利用该漏洞在设置中提交类型化输入到auth参数,从而导致未初始化的内存泄漏,从而暴露数据。
CVE-2019-10196 MPS-2021-2813
2022-08-08 20:54
Axios 拒绝服务 漏洞
拒绝服务
Axios 是一个基于promise 网络请求库。 漏洞版本的axios 容易受到低效正则表达式复杂性的影响,从而引发拒绝服务 (ReDoS) 的攻击。
CVE-2021-3749 MPS-2021-30688
2022-08-08 20:54
log4js-node 安全漏洞
缺省权限不正确
Log4js-Node是一种 Log4js 到 Node.js 的端口。 log4js-node 存在安全漏洞,攻击者可利用该漏洞获取敏感信息。
CVE-2022-21704 MPS-2021-37062
2022-08-08 20:54
Nodemailer 注入漏洞
注入
Nodemailer是Nodemailer团队的一个使用可提供发送邮件功能的 JS 代码库。 Nodemailer 中存在注入漏洞,该漏洞源于系统未对HTTP Header做安全检查。攻击者可通过包含换行符或回车符的恶意数据引发目标系统产品异常行为。以下产品及版本受到影响:nodemailer 6.6.1 之前版本。
CVE-2021-23400 MPS-2021-9219
2022-08-08 20:54
ip 存在通过发送数据的信息暴露漏洞
通过发送数据的信息暴露
ip 是 node.js 的 IP 地址实用程序。由于节点使用不安全,受影响的软件包版本容易受到未初始化内存暴露的影响。
MPS-2022-12945
2022-08-08 20:54
Eran Hammer cryptiles 安全漏洞
信息熵不充分
Eran Hammer cryptiles是一款通用加密工具。 Eran Hammer cryptiles 4.1.1之前版本中的randomDigits()方法存在安全漏洞。攻击者可利用该漏洞暴力破解随机数。
CVE-2018-1000620 MPS-2018-9401
2022-08-08 20:54
npm bl 缓冲区错误漏洞
跨界内存读
npm bl 4.x系列中4.0.3之前版本,3.x系列中3.0.1之前版本,2.x系列中2.2.1之前版本存在安全漏洞,攻击者可以通过恶意输入导致越界读。
CVE-2020-8244 MPS-2020-12199
2022-08-08 20:54
Moment.js 路径遍历漏洞
路径遍历
Moment.js 是一个 JavaScript 日期库。用于解析、验证、操作和格式化日期。 Moment.js 的 npm 版本中处理目录遍历序列时对于输入验证不严格导致可以构造特制的 HTTP 请求读取系统上的任意文件。 攻击者可利用该漏洞访问系统敏感文件。
CVE-2022-24785 MPS-2022-3752
2022-08-08 20:54
needle 存在Authorization请求头泄露漏洞
信息暴露
needle 是 一款流式传输的HTTP客户端 needle 没有对重定向后的请求头做过滤处理,会把第一次请求的 Authorization 请求头也传递到重定向后的服务,导致 Authorization 请求头泄露。 攻击者可利用该漏洞被动窃取用户的 Authorization 数据。
MPS-2022-7866
2022-08-08 20:54
lodash 命令注入漏洞
代码注入
lodash是一个提供模块化、性能和附加功能的现代 JavaScript 实用程序库。 4.17.21 之前的 Lodash 版本容易通过模板函数进行命令注入。
CVE-2021-23337 MPS-2021-2638
2022-08-08 20:54
lodash 存在拒绝服务漏洞
拒绝服务
lodash 是一个现代 JavaScript 实用程序库,提供模块化、性能和附加功能。此软件包的受影响版本容易通过 setWith 和 set 函数受到原型污染。
MPS-2022-13842
2022-08-08 20:54
https-proxy-agent 安全漏洞
跨界内存读
https-proxy-agent是一个HTTP或HTTPS代理的实现。 https-proxy-agent 2.1.1之前版本中存在安全漏洞,该漏洞源于程序没有进行正确的过滤。攻击者可通过向‘auth’参数提交输入(例如:JSON)利用该漏洞造成拒绝服务或造成内存泄露。
CVE-2018-3739 MPS-2018-7304
2022-08-08 20:54
lodash 资源管理错误漏洞
不加限制或调节的资源分配
lodash是一款开源的JavaScript实用程序库。 lodash 4.7.11之前版本中的Date handler存在资源管理错误漏洞。该漏洞源于网络系统或产品对系统资源(如内存、磁盘空间、文件等)的管理不当。
CVE-2019-1010266 MPS-2019-8123
2022-08-08 20:54
is-my-json-valid 存在代码注入漏洞
代码注入
is-my-json-valid 是一个 JSONSchema / 有序验证器,它使用代码生成非常快。此软件包的受影响版本容易通过 formatName 函数执行任意代码。
MPS-2022-13796
2022-08-08 20:54
follow-redirects project信息暴露漏洞
信息暴露
Exposure of Sensitive Information to an Unauthorized Actor in NPM follow-redirects prior to 1.14.8.
CVE-2022-0536 MPS-2022-3636
2022-08-08 20:54
lodash输入验证错误漏洞
原型污染
lodash是一款开源的JavaScript实用程序库。 lodash 4.17.15及之前版本中存在输入验证错误漏洞。远程攻击者可借助'merge'、'mergeWith'和'defaultsDeep'函数利用该漏洞在系统上执行任意代码。
CVE-2020-8203 MPS-2020-15679
2022-08-08 20:54
Npm Node-tar 后置链接漏洞
node-tar是一款用于文件压缩/解压缩的软件包。 Npm Node-tar 中存在后置链接漏洞,该漏洞源于产品未对特殊字符做有效验证。攻击者可通过该漏洞在其他路径创建恶意文件。
CVE-2021-37701 MPS-2021-28486
2022-08-08 20:54
jsonpointer 存在拒绝服务漏洞
拒绝服务
jsonpointer 是一个简单的 JSON 寻址。此软件包的受影响版本容易通过 set 函数受到原型污染。
MPS-2022-13815
2022-08-08 20:54
Nodemailer 注入漏洞
注入
Nodemailer是Nodemailer团队的一个使用可提供发送邮件功能的 JS 代码库。 nodemailer 6.4.16之前版本存在注入漏洞,该漏洞源于使用精心设计的收件人电子邮件地址可能会在sendmail传输中导致任意命令标志注入以发送邮件。
CVE-2020-7769 MPS-2020-15702
2022-08-08 20:54
没有更多内容
加载失败,请刷新页面
点击加载更多
加载中
下一页
5 评论
17 收藏
分享
OSCHINA
登录后可查看更多优质内容
返回顶部
顶部