新概念PHP包管理器 PHP Composer

MIT
PHP
跨平台
2013-05-15
hfcorriez

几乎每种语言都有包管理器。Java有Maven,Python有easy_install和pip,Ruby有gem,Nodejs有npm。说到PHP当然也有PEAR,但我一直认为PEAR是设计最烂的一个包管理器:依赖处理不到位、配置复杂、命令行难用,有时候还会报错。一直期待有个新的包管理器,甚至想自己写一个(可能不太现实,但想写的心早有了)。

但发现了Composer后,发现他已经可以很好的解决PHP包管理的问题,而且有越来越多的开源软件都有在支持Composer管理。

定义依赖关系

在你的应用程序根目录创建一个文件composer.json,就可以开始写依赖关系了。写法非常简单:

{
    "require": {
        "vendor/package": "1.3.2",
        "vendor/package2": "1.*",
        "vendor/package3": ">=2.0.3"
    }
}

安装Composer

如果你是Linux开发一个命令行就搞定了

curl -s http://getcomposer.org/installer | php

安装依赖包

依然是执行一条命令即可

php composer.phar install

自动加载依赖

如果你使用的库采用了PSR-0标准(为了方便加载而定义一种命名和路径的映射规范),那么只需要使用Composer提供的自动加载即可处理所有依赖。

require 'vendor/autoload.php';
加载中

评论(0)

暂无评论

Composer 中国全量镜像开源了,一起让 PHP 社区更繁荣

先上链接:https://github.com/zencodex/composer-mirror ZComposer 镜像诞生于 2017 年 3 月份,至今已不间断稳定运行 2 年多了。如何保证Composer 镜像的稳定性,是面临的最大难题,所以简...

05/29 11:45

没有更多内容

加载失败,请刷新页面

没有更多内容

1
回答
composer.json怎么用呢?

看了文档不是很理解 求具体使用!

2015/01/07 09:57
1
回答
win7 安装composer.exe提示错误

Connection Error [ERR_CONNECTION]: Unable to connect to getcomposer.org Reque...

2015/07/13 13:58
2
回答
php运行composer内存不足
大王叫我来卖萌 的回答 2014/12/14 09:25
最佳答案
更新composer到最新版,禁用php gc
2
回答
PHP composer安装的问题
帖子列表 的回答 2014/12/06 14:54
最佳答案
中国镜像和packegist被封锁的原因 删除:C:\Users\chimin\AppData\Roaming\Composer\confing.json或者改为 { "config": {} } 即可
3
回答
composer.phar安装不成功怎么办?
leo108 的回答 2014/08/28 10:01
最佳答案
有种可能是内存超限被kill了

没有更多内容

加载失败,请刷新页面

没有更多内容

安装composer

Mac 安装composer 使用 curl 指令下载: curl -sS https://getcomposer.org/installer | php 或是沒有安裝 curl ,也可以用 php 指令下载: php -r "readfile('https://getcomposer.org/inst...

2015/10/23 15:27
127
0
Composer 安装(一)

## 一、简介 Composer 是 PHP 用来管理依赖(dependency)关系的工具。你可以在自己的项目中声明所依赖的外部工具库(libraries),Composer 会帮你安装这些依赖的库文件。 ## 二、为什么要使...

2016/08/06 08:34
43
0
Composer -- PHP依赖管理的新时代

Composer -- PHP依赖管理的新时代

2016/05/31 14:12
54
0
Composer的安装及切换国内资源

Composer是PHP中用来管理依赖(dependency)关系的工具。你可以在自己的项目中声明所依赖的外部工具库(libraries),Composer会帮你安装这些依赖的库文件。Composer需要PHP 5.3.2+才能运行。...

2017/06/20 22:50
116
0
Composer安装(Xampp和lnmp环境)及常用命令

**1.下载安装Xampp** https://sourceforge.net/projects/xampp/files/XAMPP%20Windows/5.6.23/xampp-win32-5.6.23-0-VC11.7z/download **2.安装composer** Xampp安装目录为D:\xampp,将D:\xa...

2016/08/11 19:14
46
0
Composer : php依赖管理工具

原始时代 我记得在当时用php的时候还没有composer,只有个pear,但是不好用呀,还不如直接在互联网上到处复制代码了,更快更不容易出错,当时也没有github这么好的社区工具了 总结如下 代码混...

2016/10/11 23:48
5
0
composer的安装以及laravel项目的生成

## composer 安装laravel composer 是PHP的依赖管理工具,需要PHP版本高于5.3且支持openssl。 安装非常简单,执行下列命令 ``` curl -sS https://getcomposer.org/installer | php ``` 执行结...

2016/12/16 15:44
109
0
apt-get命令安装的Composer,捆绑安装的/usr/bin/php与/usr/local/php/bin/php版本冲突

今天发现/usr/bin/php与/usr/local/php/bin/php版本不一样,之前明明还好好的…… 后面发现是 apt-get install composer默认安装了一个php到/usr/bin/php把之前的PHP版本覆盖掉了…… # php ...

07/07 15:28
13
0

没有更多内容

加载失败,请刷新页面

返回顶部
顶部