nestjs 正在参加 2021 年度 OSC 中国开源项目评选,请投票支持!
nestjs 在 2021 年度 OSC 中国开源项目评选 中已获得 {{ projectVoteCount }} 票,请投票支持!
2021 年度 OSC 中国开源项目评选 正在火热进行中,快来投票支持你喜欢的开源项目!
2021 年度 OSC 中国开源项目评选 >>> 中场回顾
nestjs 获得 2021 年度 OSC 中国开源项目评选「最佳人气项目」 !
授权协议 MIT License
开发语言 Java
操作系统 跨平台
软件类型 开源软件
所属分类 大数据数据查询
开源组织
地区 不详
投 递 者 首席测试
适用人群 未知
收录时间 2021-11-23

软件简介

A collection of Badass modules and utilities to help you level up your NestJS application.

Build Status

Package Description Version Changelog
@golevelup/nestjs-common Common types, mixins version changelog
@golevelup/nestjs-discovery DiscoveryModule for finding providers, controllers and method handlers from your NestJS app that have certain metadata version changelog
@golevelup/nestjs-rabbitmq A NestJS native module for RabbitMQ that supports both RPC and Publish/Subscribe messaging patterns version changelog
@golevelup/nestjs-modules A Dynamic Module helper. Useful for configuring once and importing anywhere else version changelog
@golevelup/nestjs-hasura Super charged Hasura Event Handlers and other utilities for seamlessly integrating Hasura with NestJS version changelog
@golevelup/nestjs-graphql-request Dependency Injection for GraphQLClient. Make type safe requests to third party GQL APIs version changelog
@golevelup/nestjs-webhooks Middlewares and helpers for processing webhooks version changelog
@golevelup/nestjs-stripe Stripe client and webhook processing version changelog

Contribute

Contributions welcome! Read the contribution guidelines first.

License

MIT License

展开阅读全文

代码

评论

点击引领话题📣
暂无内容
发表了博客
{{o.pubDate | formatDate}}

{{formatAllHtml(o.title)}}

{{parseInt(o.replyCount) | bigNumberTransform}}
{{parseInt(o.viewCount) | bigNumberTransform}}
没有更多内容
暂无内容
发表了问答
{{o.pubDate | formatDate}}

{{formatAllHtml(o.title)}}

{{parseInt(o.replyCount) | bigNumberTransform}}
{{parseInt(o.viewCount) | bigNumberTransform}}
没有更多内容
暂无内容
merge 存在拒绝服务漏洞
拒绝服务
merge 是一个库,允许您将多个对象合并为一个,可以选择创建一个新的克隆对象。类似于 jQuery.extend 但更灵活。在 Node.js 和浏览器中工作。此软件包的受影响版本容易受到原型污染。
MPS-2022-13875
2022-08-08 18:54
property-expr 输入验证错误漏洞
输入验证不恰当
property-expr 2.0.3之前版本中存在原型污染漏洞。目前尚无此漏洞的相关信息,请随时关注CNNVD或厂商公告。
CVE-2020-7707 MPS-2020-11771
2022-08-08 18:54
lodash输入验证错误漏洞
原型污染
lodash是一款开源的JavaScript实用程序库。 lodash 4.17.15及之前版本中存在输入验证错误漏洞。远程攻击者可借助'merge'、'mergeWith'和'defaultsDeep'函数利用该漏洞在系统上执行任意代码。
CVE-2020-8203 MPS-2020-15679
2022-08-08 18:54
minimist 输入验证错误漏洞
原型污染
minimist是一款命令行参数解析工具。 minimist 1.2.2之前版本存在输入验证错误漏洞。攻击者可借助‘constructor’和‘__proto__’ payload利用该漏洞添加或修改Object.prototype的属性。
CVE-2020-7598 MPS-2020-3516
2022-08-08 18:54
yeikos js.merge 安全漏洞
yeikos js.merge是美国Yeikos个人开发者的一个应用软件。提供了合并js工具。 yeikos js.merge 中存在安全漏洞。该漏洞源于所有相关分支的合并都容易受到该代码库的原型影响。以下产品及版本受到影响:yeikos js.merge
CVE-2020-28499 MPS-2021-1900
2022-08-08 18:54
lodash 命令注入漏洞
代码注入
lodash是一个提供模块化、性能和附加功能的现代 JavaScript 实用程序库。 4.17.21 之前的 Lodash 版本容易通过模板函数进行命令注入。
CVE-2021-23337 MPS-2021-2638
2022-08-08 18:54
trim-newlines 安全漏洞
拒绝服务
trim-newlines是一个修改换行符的npm包。 trim-newlines 存在安全漏洞,该漏洞源于应用于Node.js在3.0.1与4.0.1版本及之前版本中.end()方法存在相关问题。
CVE-2021-33623 MPS-2021-7398
2022-08-08 18:54
nodejs 资源管理错误漏洞
拒绝服务
nodejs是是一个基于ChromeV8引擎的JavaScript运行环境通过对Chromev8引擎进行了封装以及使用事件驱动和非阻塞IO的应用让Javascript开发高性能的后台应用成为了可能。 nodejs-glob-parent 存在安全漏洞,该漏洞源于正则表达式拒绝服务。
CVE-2020-28469 MPS-2021-7827
2022-08-08 18:54
shelljs 安全漏洞
特权管理不恰当
shelljs是基于Node.js API 的 Unix shell 命令的可移植(Windows/Linux/OS X)实现。 shelljs存在安全漏洞,该漏洞源于不适当的权限管理,攻击者可利用该漏洞进行越权访问。
CVE-2022-0144 MPS-2022-0508
2022-08-08 18:54
lodash 存在拒绝服务漏洞
拒绝服务
lodash 是一个现代 JavaScript 实用程序库,提供模块化、性能和附加功能。由于对 CVE-2020-8203 的修复不完整,此软件包的受影响版本容易受到 zipObjectDeep 中的原型污染。
MPS-2022-13841
2022-08-08 18:54
lodash 存在拒绝服务漏洞
拒绝服务
lodash 是一个现代 JavaScript 实用程序库,提供模块化、性能和附加功能。此软件包的受影响版本容易通过 setWith 和 set 函数受到原型污染。
MPS-2022-13842
2022-08-08 18:54
yup 存在原型污染漏洞
原型污染
是的,是一个死简单对象模式验证。此软件包的受影响版本容易通过 .
MPS-2022-14161
2022-08-08 18:54
simple-git-hooks存在未明漏洞
命令注入
simple-git-hooks是一个应用软件。一个简单的git钩子经理小型项目。simple-git-hooks 3.5.0之前版本存在安全漏洞,攻击者利用该漏洞进行命令注入。
CVE-2022-24066 MPS-2022-5073
2022-08-08 18:54
没有更多内容
加载失败,请刷新页面
点击加载更多
加载中
下一页
0 评论
0 收藏
分享
OSCHINA
登录后可查看更多优质内容
返回顶部
顶部