Microm 正在参加 2021 年度 OSC 中国开源项目评选,请投票支持!
Microm 在 2021 年度 OSC 中国开源项目评选 中已获得 {{ projectVoteCount }} 票,请投票支持!
2021 年度 OSC 中国开源项目评选 正在火热进行中,快来投票支持你喜欢的开源项目!
2021 年度 OSC 中国开源项目评选 >>> 中场回顾
Microm 获得 2021 年度 OSC 中国开源项目评选「最佳人气项目」 !
授权协议 MIT
操作系统 Windows
软件类型 开源软件
开源组织
地区 不详
投 递 者 孔小菜
适用人群 未知
收录时间 2015-12-16

软件简介

Microm 是一个漂亮的库,可以用 JavaScript 将浏览器的麦克风转为 MP3,Microm 的目的是让浏览器里的播放和转播变得简单。

示例代码:

var microm = new Microm();var mp3 = null;start();setTimeout(stop, 1500);function start() 
{  microm.startRecording().then(function() {    console.log('recording...')
  }).catch(function() {    console.log('error recording');
  });
}function stop() {  microm.stop().then(function(result) {
    mp3 = result;    console.log(mp3.url, mp3.blob, mp3.buffer);    play();    download();
  });
}function play() {  microm.play();
}function download() {  var fileName = 'cat_voice';  microm.download(fileName);
}

 

展开阅读全文

代码

的 Gitee 指数为
超过 的项目

评论

点击引领话题📣 发布并加入讨论🔥
暂无内容
发表了博客
{{o.pubDate | formatDate}}

{{formatAllHtml(o.title)}}

{{parseInt(o.replyCount) | bigNumberTransform}}
{{parseInt(o.viewCount) | bigNumberTransform}}
没有更多内容
暂无内容
发表了问答
{{o.pubDate | formatDate}}

{{formatAllHtml(o.title)}}

{{parseInt(o.replyCount) | bigNumberTransform}}
{{parseInt(o.viewCount) | bigNumberTransform}}
没有更多内容
暂无内容
tar 存在拒绝服务漏洞
拒绝服务
tar 是用于 Node.js 的全功能 Tar。此软件包的受影响版本容易受到正则表达式拒绝服务 (ReDoS) 的攻击。
MPS-2022-14081
2022-08-08 18:37
extend module 注入漏洞
注入
extend module是一个jQuery的经典extend()方法的端口。 extend 2.0.2之前版本和3.0.0版本至3.0.2版本中存在注入漏洞,该漏洞源于用户输入构造命令、数据结构或记录的操作过程中,网络系统或产品缺乏对用户输入数据的正确验证,未过滤或未正确过滤掉其中的特殊元素,导致系统或产品产生解析或解释方式错误。
CVE-2018-16492 MPS-2019-1232
2022-08-08 18:37
handlebars 安全漏洞
handlebars是一款语义化的Web模板系统。 handlebars 4.7.7版本之前存在安全漏洞,该漏洞源于在选择某些编译选项来编译来自不受信任的源的模板时,handlebars容易受到远程代码执行(Remote Code Execution, RCE)的攻击。
CVE-2021-23369 MPS-2021-4548
2022-08-08 18:37
http-proxy 存在拒绝服务漏洞
拒绝服务
http-proxy 是一个为大众提供 HTTP 代理的库。此软件包的受影响版本容易受到拒绝服务 (DoS) 的攻击。
MPS-2022-13767
2022-08-08 18:37
handlebars 存在MAID漏洞
MAID
handlebars 是 Mustache 模板语言的扩展。此软件包的受影响版本容易受到原型污染。
MPS-2022-13730
2022-08-08 18:37
web framework qs模块输入验证漏洞
输入验证不恰当
web framework是一种用来支持动态网站、网络应用程序和网络服务开发的框架。qs module是开发者在构建Web框架时使用的一个字符串查询解析模块。 web framework中的qs模块存在拒绝服务漏洞。攻击者可利用该漏洞造成拒绝服务(Web框架崩溃)。以下版本受到影响:qs 6.3.2之前的版本,6.2.3之前的版本,6.1.2之前的版本,6.0.4之前的版本。
CVE-2017-1000048 MPS-2017-7711
2022-08-08 18:37
Hoek 访问控制错误漏洞
MAID
Hoek是一个hapi系统的实现。 Hoek 4.2.0之前版本和5.0.3之前的5.0.x版本中存在访问控制错误漏洞。本地攻击者可借助‘merge’和‘applyToDefaults’函数利用该漏洞修改‘Object’的原型。
CVE-2018-3728 MPS-2018-3882
2022-08-08 18:37
Request存在未明漏洞
输入验证不恰当
Request是一款HTTP请求客户端库。 Request 2.2.6版本至2.47.0版本和2.51.0版本至2.67.0版本中存在安全漏洞。攻击者可利用该漏洞泄露本地系统内存。
CVE-2017-16026 MPS-2018-7014
2022-08-08 18:37
lodash 存在拒绝服务漏洞
拒绝服务
lodash 是一个现代 JavaScript 实用程序库,提供模块化、性能和附加功能。由于对 CVE-2020-8203 的修复不完整,此软件包的受影响版本容易受到 zipObjectDeep 中的原型污染。
MPS-2022-13841
2022-08-08 18:37
Hawk 拒绝服务漏洞
资源管理错误
Hawk是一套使用消息认证码(MAC)算法,以提供局部HTTP请求加密验证的HTTP认证方案。 Hawk 3.1.3之前版本和4.1.1之前4.x版本中存在安全漏洞。远程攻击者可借助较长的头部或URI利用该漏洞造成拒绝服务(CPU消耗或部分中断)。
CVE-2016-2515 MPS-2016-1657
2022-08-08 18:37
lodash 资源管理错误漏洞
不加限制或调节的资源分配
lodash是一款开源的JavaScript实用程序库。 lodash 4.7.11之前版本中的Date handler存在资源管理错误漏洞。该漏洞源于网络系统或产品对系统资源(如内存、磁盘空间、文件等)的管理不当。
CVE-2019-1010266 MPS-2019-8123
2022-08-08 18:37
ecstatic 存在跨站重定向漏洞
跨站重定向
ecstatic 是一个简单的静态文件服务器中间件。将它与原始 http 服务器、express/connect 或 CLI 一起使用。此软件包的受影响版本容易受到 Open Redirect 的攻击。
MPS-2022-13640
2022-08-08 18:37
ecstatic node模块安全漏洞
输入验证不恰当
ecstatic node module是一款http协同工作的静态文件服务器中间件。 ecstatic node模块1.4.0之前版本中存在安全漏洞。攻击者可借助If-Modified-Since包头发送输入利用该漏洞造成拒绝服务(崩溃)。
CVE-2015-9242 MPS-2018-6571
2022-08-08 18:37
node-tar 路径遍历漏洞
路径遍历
node-tar是一款用于文件压缩/解压缩的软件包。 npm node-tar 存在路径遍历漏洞,该漏洞源于4.4.18、5.0.10和6.1.9之前的npm包“tar”(又名node-tar)存在任意文件创建覆盖和任意代码执行漏洞。攻击者可利用该漏洞访问受限目录之外的位置。
CVE-2021-37713 MPS-2021-28489
2022-08-08 18:37
Npm Ini 资源管理错误漏洞
拒绝服务
Npm Ini是美国Npm公司的一个基于Javascript的用于解析和序列化Ini格式文件的代码库。 Npm ini before 1.3.6 存在资源管理错误漏洞,该漏洞允许攻击者可利用该漏洞向应用程序提交恶意的INI文件,该应用程序将用INI解析该文件。这可以根据上下文进一步加以利用。
CVE-2020-7788 MPS-2020-17544
2022-08-08 18:37
lodash 存在拒绝服务漏洞
拒绝服务
lodash 是一个现代 JavaScript 实用程序库,提供模块化、性能和附加功能。此软件包的受影响版本容易通过 setWith 和 set 函数受到原型污染。
MPS-2022-13842
2022-08-08 18:37
ecstatic npm package拒绝服务漏洞
输入验证不恰当
ecstatic npm package是一款静态文件服务器中间件。 ecstatic npm package 2.0.0之前的版本中的lib/ecstatic.js文件存在拒绝服务漏洞。远程攻击者可通过传递恶意制作的字符串利用该漏洞造成拒绝服务(过载和崩溃)。
CVE-2016-10703 MPS-2017-14080
2022-08-08 18:37
node-tar 后置链接漏洞
在文件访问前对链接解析不恰当(链接跟随)
node-tar是一款用于文件压缩/解压缩的软件包。 node-tar 4.4.2之前版本中存在后置链接漏洞。该漏洞源于网络系统或产品未正确过滤表示非预期资源的链接或者快捷方式的文件名。攻击者可利用该漏洞访问非法的文件路径。
CVE-2018-20834 MPS-2019-4705
2022-08-08 18:37
fstream 后置链接漏洞
在文件访问前对链接解析不恰当(链接跟随)
fstream是一个用于读取和写入文件的库。 fstream 1.0.12之前版本中的‘fstream.DirWriter()’函数存在后置链接漏洞。该漏洞源于网络系统或产品未正确过滤表示非预期资源的链接或者快捷方式的文件名。攻击者可利用该漏洞访问非法的文件路径。
CVE-2019-13173 MPS-2019-7423
2022-08-08 18:37
extend module 输入验证错误漏洞
输入验证不恰当
extend module是一个jQuery的经典extend()方法的端口。 deep-extend node模块0.5.0及之前版本中的‘utilities’函数存在输入验证错误漏洞。攻击者可利用该漏洞造成服务器崩溃或返回500。
CVE-2018-3750 MPS-2018-8705
2022-08-08 18:37
没有更多内容
加载失败,请刷新页面
点击加载更多
加载中
下一页
0 评论
4 收藏
分享
OSCHINA
登录后可查看更多优质内容
返回顶部
顶部