mediasoup 正在参加 2021 年度 OSC 中国开源项目评选,请投票支持!
mediasoup 在 2021 年度 OSC 中国开源项目评选 中已获得 {{ projectVoteCount }} 票,请投票支持!
2021 年度 OSC 中国开源项目评选 正在火热进行中,快来投票支持你喜欢的开源项目!
2021 年度 OSC 中国开源项目评选 >>> 中场回顾
mediasoup 获得 2021 年度 OSC 中国开源项目评选「最佳人气项目」 !
授权协议 ISC
开发语言 Perl 查看源码 »
操作系统 跨平台
软件类型 开源软件
开源组织
地区 不详
投 递 者 Alias_Travis
适用人群 未知
收录时间 2021-08-19

软件简介

mediasoup 是一个 WebRTC 视频会议工具。

设计目标:

  • 成为一个 SFU;
  • 同时支持 WebRTC 和普通 RTP 的输入和输出;
  • 在服务器端是一个 Node.js 模块/Rust crate;
  • 在客户端是一个很小的 JavaScript 和 C++ 库;
  • 极简主义:只处理媒体层;
  • 不要求任何信令协议;
  • 是超低级别的 API;
  • 支持所有现有的 WebRTC 端点;
  • 能够与知名的多媒体库/工具集成;

特性:

  • ECMAScript 6/Idiomatic Rust 低级别 API;
  • 多流:通过一个 ICE+DTLS 传输的多个音频/视频流;
  • IPv6;
  • 通过 UDP 和 TCP 的 ICE / DTLS / RTP / RTCP;
  • 支持同步广播和 SVC;
  • 发送方和接收方带宽估计与空间/时间层分配算法;
  • 数据信息交换
  • 功能极其强大
展开阅读全文

代码

的 Gitee 指数为
超过 的项目

评论

点击引领话题📣
暂无内容
发表了博客
{{o.pubDate | formatDate}}

{{formatAllHtml(o.title)}}

{{parseInt(o.replyCount) | bigNumberTransform}}
{{parseInt(o.viewCount) | bigNumberTransform}}
没有更多内容
暂无内容
发表了问答
{{o.pubDate | formatDate}}

{{formatAllHtml(o.title)}}

{{parseInt(o.replyCount) | bigNumberTransform}}
{{parseInt(o.viewCount) | bigNumberTransform}}
没有更多内容
暂无内容
nodejs 资源管理错误漏洞
拒绝服务
nodejs是是一个基于ChromeV8引擎的JavaScript运行环境通过对Chromev8引擎进行了封装以及使用事件驱动和非阻塞IO的应用让Javascript开发高性能的后台应用成为了可能。 nodejs-glob-parent 存在安全漏洞,该漏洞源于正则表达式拒绝服务。
CVE-2020-28469 MPS-2021-7827
2022-08-08 19:04
Qt 安全漏洞
Qt是挪威Qt公司的一个跨平台的C++应用程序开发框架。广泛用于开发GUI程序,这种情况下又被称为部件工具箱。也可用于开发非GUI程序,例如控制台工具和服务器。 Qt 在Linux 和 UNIX平台上的5.9.x 至 5.15.8版本和6.2.4之前版本存在安全漏洞,该漏洞源于当在路径中找不到时,QProcess可以从当前工作目录执行二进制文件。。
CVE-2022-25255 MPS-2022-4316
2022-08-08 19:04
Qt路径遍历漏洞
路径遍历
Qt是挪威Qt公司的一个跨平台的C++应用程序开发框架。广泛用于开发GUI程序,这种情况下又被称为部件工具箱。也可用于开发非GUI程序,例如控制台工具和服务器。Qt 5.15.8之前版本和6.X到6.2.3版本存在安全漏洞,该漏洞源于软件缺少对于目录的限制,可以从一个意想不到的工作目录加载系统库文件。目前没有详细的漏洞细节提供。
CVE-2022-25634 MPS-2022-4762
2022-08-08 19:04
Async 安全漏洞
原型污染
Async是英国Caolan McMahon个人开发者的一个实用模块。用于使用异步 JavaScript。 Async 3.2.1 及之前版本存在安全漏洞,该漏洞源于 mapValues() 方法。攻击者可通过 mapValues() 方法获取权限。
CVE-2021-43138 MPS-2021-34434
2022-08-08 19:04
trim-newlines 安全漏洞
拒绝服务
trim-newlines是一个修改换行符的npm包。 trim-newlines 存在安全漏洞,该漏洞源于应用于Node.js在3.0.1与4.0.1版本及之前版本中.end()方法存在相关问题。
CVE-2021-33623 MPS-2021-7398
2022-08-08 19:04
没有更多内容
加载失败,请刷新页面
点击加载更多
加载中
下一页
0 评论
3 收藏
分享
OSCHINA
登录后可查看更多优质内容
返回顶部
顶部