IdentityServer4 正在参加 2021 年度 OSC 中国开源项目评选,请投票支持!
IdentityServer4 在 2021 年度 OSC 中国开源项目评选 中已获得 {{ projectVoteCount }} 票,请投票支持!
2021 年度 OSC 中国开源项目评选 正在火热进行中,快来投票支持你喜欢的开源项目!
2021 年度 OSC 中国开源项目评选 >>> 中场回顾
IdentityServer4 获得 2021 年度 OSC 中国开源项目评选「最佳人气项目」 !
授权协议 Apache
开发语言 C# 查看源码 »
操作系统 跨平台
软件类型 开源软件
开源组织
地区 不详
投 递 者 红薯
适用人群 未知
收录时间 2020-02-03

软件简介

IdentityServer4 .Net平台下的OAuth2组件,github上的关注度不低于DotNetOpenAuth。

概述:

IdentityServer4 是一个基于 .NET/Katana 的框架,它可实现单点登录和访问 modern web 服务器,且其 APIs 可以使用类似于 OpenID Connect 和 OAuth2 协议。它像 mobile, web, SPAs 和桌面应用程序一样可支持广泛的客户端,同时它支持新的集成和存在的架构。

展开阅读全文

代码

的 Gitee 指数为
超过 的项目

评论

点击引领话题📣
暂无内容
发表了博客
{{o.pubDate | formatDate}}

{{formatAllHtml(o.title)}}

{{parseInt(o.replyCount) | bigNumberTransform}}
{{parseInt(o.viewCount) | bigNumberTransform}}
没有更多内容
暂无内容
发表了问答
{{o.pubDate | formatDate}}

{{formatAllHtml(o.title)}}

{{parseInt(o.replyCount) | bigNumberTransform}}
{{parseInt(o.viewCount) | bigNumberTransform}}
没有更多内容
暂无内容
kind-of注入漏洞
将资源暴露给错误范围
kind-of是一款JavaScript类型检查软件包。 kind-of v6.0.2版本中的index.js文件的‘ctorName’函数存在注入漏洞,攻击者可利用该漏洞覆盖内部属性,操纵类型检查的结果。
CVE-2019-20149 MPS-2019-17164
2022-08-08 19:05
Async 安全漏洞
原型污染
Async是英国Caolan McMahon个人开发者的一个实用模块。用于使用异步 JavaScript。 Async 3.2.1 及之前版本存在安全漏洞,该漏洞源于 mapValues() 方法。攻击者可通过 mapValues() 方法获取权限。
CVE-2021-43138 MPS-2021-34434
2022-08-08 19:05
minimatch 存在拒绝服务漏洞
拒绝服务
minimatch 是一个最小匹配实用程序。此软件包的受影响版本容易通过复杂和非法的正则表达式受到正则表达式拒绝服务 (ReDoS) 的攻击。
MPS-2022-13882
2022-08-08 19:05
uglify-js 存在ReDoS漏洞
ReDoS
uglify-js 是一个 JavaScript 解析器、压缩器、压缩器和美化工具包。此软件包的受影响版本容易通过 string_template 和 decode_template 函数受到正则表达式拒绝服务 (ReDoS) 的攻击。
MPS-2022-14112
2022-08-08 19:05
Joyent Node.js UglifyJS安全绕过漏洞
7PK - 安全功能
Joyent Node.js是美一套建立在Google V8 JavaScript引擎之上的网络应用平台。 Joyent Node.js UglifyJS存在安全漏洞,由于程序未能正确处理Non-Boolean对比,允许远程攻击者可利用特制的Javascript文件改变功能。
CVE-2015-8857 MPS-2017-0614
2022-08-08 19:05
Minimatch 安全漏洞
输入验证不恰当
Minimatch是一个通过将glob表达式转换为JavaScript RegExp对象来工作的匹配库。 Minimatch 3.0.1及之前的版本中的‘pattern’参数存在安全漏洞。攻击者可利用该漏洞造成拒绝服务。
CVE-2016-10540 MPS-2018-6725
2022-08-08 19:05
clean-css 存在拒绝服务漏洞
clean-css 是适用于 Node.js 平台和任何现代浏览器的快速高效的 CSS 优化器。此软件包的受影响版本容易受到正则表达式拒绝服务 (ReDoS) 的攻击。
MPS-2022-12865
2022-08-08 19:05
minimist 输入验证错误漏洞
原型污染
minimist是一款命令行参数解析工具。 minimist 1.2.2之前版本存在输入验证错误漏洞。攻击者可借助‘constructor’和‘__proto__’ payload利用该漏洞添加或修改Object.prototype的属性。
CVE-2020-7598 MPS-2020-3516
2022-08-08 19:05
trim-newlines 安全漏洞
拒绝服务
trim-newlines是一个修改换行符的npm包。 trim-newlines 存在安全漏洞,该漏洞源于应用于Node.js在3.0.1与4.0.1版本及之前版本中.end()方法存在相关问题。
CVE-2021-33623 MPS-2021-7398
2022-08-08 19:05
没有更多内容
加载失败,请刷新页面
点击加载更多
加载中
下一页
0 评论
6 收藏
分享
OSCHINA
登录后可查看更多优质内容
返回顶部
顶部