graphql-compose-elasticsearch 正在参加 2021 年度 OSC 中国开源项目评选,请投票支持!
graphql-compose-elasticsearch 在 2021 年度 OSC 中国开源项目评选 中已获得 {{ projectVoteCount }} 票,请投票支持!
2021 年度 OSC 中国开源项目评选 正在火热进行中,快来投票支持你喜欢的开源项目!
2021 年度 OSC 中国开源项目评选 >>> 中场回顾
graphql-compose-elasticsearch 获得 2021 年度 OSC 中国开源项目评选「最佳人气项目」 !
授权协议 AGPL-3.0 License
开发语言 Java
操作系统 跨平台
软件类型 开源软件
所属分类 大数据数据查询
开源组织
地区 不详
投 递 者 首席测试
适用人群 未知
收录时间 2021-11-23

软件简介

Graphql (Apollo Server) with ElasticSearch

Graphql App using Node with typescript, KOA framework. Elasticsearch for dataStore. Middlewares JWT, CORS, Winston Logger.

Installation

  • npm install install dependencies.

Useful commands

  • npm run watch: start server in watch mode.
  • npm start: start built server.
  • npm run build: build typescript files.

Manage Graphql Playground

展开阅读全文

代码

评论

点击引领话题📣 发布并加入讨论🔥
暂无内容
发表了博客
{{o.pubDate | formatDate}}

{{formatAllHtml(o.title)}}

{{parseInt(o.replyCount) | bigNumberTransform}}
{{parseInt(o.viewCount) | bigNumberTransform}}
没有更多内容
暂无内容
发表了问答
{{o.pubDate | formatDate}}

{{formatAllHtml(o.title)}}

{{parseInt(o.replyCount) | bigNumberTransform}}
{{parseInt(o.viewCount) | bigNumberTransform}}
没有更多内容
暂无内容
npm dot-prop 安全漏洞
原型污染
4.2.1 之前的 dot-prop npm 包版本和 5.1.1 之前的 5.x 版本中的原型污染漏洞允许攻击者向 JavaScript 语言构造(例如对象)添加任意属性。
CVE-2020-8116 MPS-2020-1734
2022-08-08 20:43
Undefsafe存在未明漏洞
注入
Undefsafe是一款支持设置值的函数。 Undefsafe2.0.3之前版本中存在安全漏洞。攻击者可利用该漏洞借助‘a’函数添加或修改Object.prototype属性。
CVE-2019-10795 MPS-2020-2617
2022-08-08 20:43
minimist 输入验证错误漏洞
原型污染
minimist是一款命令行参数解析工具。 minimist 1.2.2之前版本存在输入验证错误漏洞。攻击者可借助‘constructor’和‘__proto__’ payload利用该漏洞添加或修改Object.prototype的属性。
CVE-2020-7598 MPS-2020-3516
2022-08-08 20:43
GraphQL Playground 跨站脚本漏洞
XSS
GraphQL Playground是德国Prisma实验室的一款基于GraphiQL的图形化、交互式、浏览器内的GraphQL IDE(集成开发环境)。 GraphQL Playground 存在跨站脚本漏洞,该漏洞源于程序容易受到破坏的HTTP模式自省响应或带有恶意GraphQL类型名称的模式道具值的攻击,从而暴露动态XSS攻击面,允许在操作中注入代码自动完成。
CVE-2021-41249 MPS-2021-32018
2022-08-08 20:43
Markdown-It 安全漏洞
拒绝服务
Markdown-It是一个 Markdown 解析器。 Markdown-It存在安全漏洞,该漏洞源于Markdown—它是一个Markdown解析器。在1.3.2版本之前,长度大于5万个字符的特殊模式会显著降低解析器的速度。用户应该升级到12.3.2版本以接收补丁。除了升级之外,没有已知的变通办法。
CVE-2022-21670 MPS-2021-37028
2022-08-08 20:43
apollo-server-core 存在信息暴露漏洞
信息暴露
apollo-server-core 是 Apollo 社区 GraphQL Server 的核心模块。此软件包的受影响版本容易受到信息泄露的影响。
MPS-2022-13550
2022-08-08 20:43
lodash 存在拒绝服务漏洞
拒绝服务
lodash 是一个现代 JavaScript 实用程序库,提供模块化、性能和附加功能。此软件包的受影响版本容易通过 setWith 和 set 函数受到原型污染。
MPS-2022-13842
2022-08-08 20:43
Axios 输入验证错误漏洞
输入验证不恰当
Axios是一款基于Promise(异步编程的一种解决方案)的HTTP客户端。 Axios 0.18.0及之前版本中存在安全漏洞。攻击者可利用该漏洞造成拒绝服务(应用程序崩溃)。
CVE-2019-10742 MPS-2019-4913
2022-08-08 20:43
lodash 存在拒绝服务漏洞
拒绝服务
lodash 是一个现代 JavaScript 实用程序库,提供模块化、性能和附加功能。由于对 CVE-2020-8203 的修复不完整,此软件包的受影响版本容易受到 zipObjectDeep 中的原型污染。
MPS-2022-13841
2022-08-08 20:43
Medialize URI.js 安全漏洞
跨站重定向
Medialize URI.js是Medialize团队的一款基于Javascript的可用于高效拼接URL的代码库。 medialize/uri.js存在安全漏洞,目前暂无该漏洞信息,请随时关注CNNVD或厂商公告。
CVE-2022-1233 MPS-2022-7848
2022-08-08 20:43
kind-of注入漏洞
将资源暴露给错误范围
kind-of是一款JavaScript类型检查软件包。 kind-of v6.0.2版本中的index.js文件的‘ctorName’函数存在注入漏洞,攻击者可利用该漏洞覆盖内部属性,操纵类型检查的结果。
CVE-2019-20149 MPS-2019-17164
2022-08-08 20:43
Medialize URI.js 输入验证错误漏洞
跨站重定向
Medialize URI.js是Medialize团队的一款基于Javascript的可用于高效拼接URL的代码库。 Medialize URI.js 存在输入验证错误漏洞,该漏洞源于 new URI 未能正确解析 https:/// ,该漏洞导致系统用户被定位到别的站点。
CVE-2021-3647 MPS-2021-10674
2022-08-08 20:43
lodash 命令注入漏洞
代码注入
lodash是一个提供模块化、性能和附加功能的现代 JavaScript 实用程序库。 4.17.21 之前的 Lodash 版本容易通过模板函数进行命令注入。
CVE-2021-23337 MPS-2021-2638
2022-08-08 20:43
Axios 拒绝服务 漏洞
拒绝服务
Axios 是一个基于promise 网络请求库。 漏洞版本的axios 容易受到低效正则表达式复杂性的影响,从而引发拒绝服务 (ReDoS) 的攻击。
CVE-2021-3749 MPS-2021-30688
2022-08-08 20:43
helmet-csp 存在配置漏洞
配置缺陷
头盔 csp 是一种内容安全策略,有助于防止将不需要的内容注入您的网页。此软件包的受影响版本容易受到影响应用程序内容安全策略 (CSP) 的配置覆盖的影响。
MPS-2022-13752
2022-08-08 20:43
npm node-fetch 安全漏洞
不加限制或调节的资源分配
node-fetch 2.6.1和3.0.0-beta版本中存在安全漏洞。该漏洞源于内容大小超过限制时,将永远不会抛出FetchError。
CVE-2020-15168 MPS-2020-12719
2022-08-08 20:43
Axios 代码问题漏洞
SSRF
Axios是一款基于Promise(异步编程的一种解决方案)的HTTP客户端。 Axios NPM package 0.21.0版本存在安全漏洞,攻击者可利用该漏洞能够通过提供一个URL绕过代理,该URL通过重定向响应一个受限制的主机或IP地址。
CVE-2020-28168 MPS-2020-16365
2022-08-08 20:43
object-path 安全漏洞
使用不兼容类型访问资源(类型混淆)
object-path是个人开发者的一个可以通过路径访问数据结构中变量的 Npm 库。 object-path 0.11.6之前版本存在安全漏洞,该漏洞源于当path参数中使用的路径组件是阵列时会导致类型混淆漏洞。
CVE-2021-23434 MPS-2021-18322
2022-08-08 20:43
object-path 安全漏洞
原型污染
对象路径容易受到对象原型属性的不当控制修改(“原型污染”)的影响
CVE-2021-3805 MPS-2021-32075
2022-08-08 20:43
markdown-it 存在拒绝服务漏洞
拒绝服务
markdown-it 是一个现代的可插拔 Markdown 解析器。此软件包的受影响版本容易受到正则表达式拒绝服务 (ReDoS) 的攻击。
MPS-2022-13854
2022-08-08 20:43
没有更多内容
加载失败,请刷新页面
点击加载更多
加载中
下一页
0 评论
0 收藏
分享
OSCHINA
登录后可查看更多优质内容
返回顶部
顶部