lodash 存在拒绝服务漏洞
拒绝服务
lodash 是一个现代 JavaScript 实用程序库,提供模块化、性能和附加功能。由于对 CVE-2020-8203 的修复不完整,此软件包的受影响版本容易受到 zipObjectDeep 中的原型污染。
MPS-2022-13841
2022-08-08 18:17
Immer 安全漏洞
使用不兼容类型访问资源(类型混淆)
Immer是Immer社区的一个基于Javascript的状态管理库。。 immer 9.0.6之前版本存在安全漏洞,该漏洞源于当path参数中使用的用户提供的密钥是数组时,可能导致绕过CVE-2020-28477。
CVE-2021-23436 MPS-2021-19475
2022-08-08 18:17
url-parse 安全漏洞
Arnout Kazemier url-parse是美国Arnout Kazemiere(Arnout Kazemier)个人开发者的一个应用软件。提供url解析。 url-parse before 1.5.0 版本存在安全漏洞,该漏洞源于错误处理了反斜杠的某些用法,例如http: /,并将URI解释为相对路径。
CVE-2021-27515 MPS-2021-2265
2022-08-08 18:17
Prism 安全漏洞
Prism是美国Prism个人开发者的一个应用软件。是一种轻量级的,可扩展的语法突出显示工具。 Prismjs 中存在安全漏洞。该漏洞源于应用易受通过prism asciidoc、prism rest、prism tap和prism eiffel组件的正则表达式错误引发的拒绝服务(ReDoS)攻击。以下产品及版本受到影响:prismjs 1.23.0 之前版本。
CVE-2021-23341 MPS-2021-2025
2022-08-08 18:17
Async 安全漏洞
原型污染
Async是英国Caolan McMahon个人开发者的一个实用模块。用于使用异步 JavaScript。 Async 3.2.1 及之前版本存在安全漏洞,该漏洞源于 mapValues() 方法。攻击者可通过 mapValues() 方法获取权限。
CVE-2021-43138 MPS-2021-34434
2022-08-08 18:17
Color-String 安全漏洞
不加限制或调节的资源分配
Color-String是开源的一个库,用于解析和生成 CSS 颜色字符串。 Color-String 1.5.5及之前版本存在安全漏洞,该漏洞源于当应用程序检查一个精心制作的数据时,就会出现正则表达式拒绝服务(ReDOS)。
CVE-2021-29060 MPS-2021-8683
2022-08-08 18:17
NPM url-parse 安全漏洞
通过用户控制密钥绕过授权机制
Url-Parse是一个跨 Node.js 和浏览器环境无缝工作的小型 Url 解析器。 NPM url-parse 存在安全漏洞,该漏洞源于在1.5.6之前的NPM url-parse中,通过用户控制的密钥绕过授权。
CVE-2022-0512 MPS-2022-3327
2022-08-08 18:17
URL -parse 输入验证错误漏洞
跨站重定向
Arnout Kazemier url-parse是美国Arnout Kazemiere(Arnout Kazemier)个人开发者的一个应用软件。提供url解析。 URL -parse 存在输入验证错误漏洞,该漏洞源于URL -parse容易被URL重定向到不可信站点
CVE-2021-3664 MPS-2021-11194
2022-08-08 18:17
prism 安全漏洞
拒绝服务
Prism是美国Prism个人开发者的一个应用软件。是一种轻量级的,可扩展的语法突出显示工具。 prism存在安全漏洞,该漏洞源于prism容易受到低效正则表达式复杂性的影响。
CVE-2021-3801 MPS-2021-31844
2022-08-08 18:17
lodash输入验证错误漏洞
原型污染
lodash是一款开源的JavaScript实用程序库。 lodash 4.17.15及之前版本中存在输入验证错误漏洞。远程攻击者可借助'merge'、'mergeWith'和'defaultsDeep'函数利用该漏洞在系统上执行任意代码。
CVE-2020-8203 MPS-2020-15679
2022-08-08 18:17
Highlightjs 安全漏洞
MAID
Highlight.js 是一个用 JavaScript 编写的语法高亮器。 Highlight.js 9.18.2 和 10.1.2 之前的版本容易受到原型污染。可以制作恶意 HTML 代码块,在突出显示期间导致基础对象原型的原型污染。如果您允许用户通过解析 Markdown 代码块(或类似代码块)将自定义 HTML 代码块插入您的页面/应用程序,并且不过滤用户可以提供的语言名称,您可能会受到攻击。污染应该只是无害的数据,但这可能会导致不期望这些属性存在的应用程序出现问题,并可能导致奇怪的行为或应用程序崩溃,即潜在的 DOS 向量。如果您的网站或应用程序不呈现用户提供的数据,它应该不受影响。版本 9.18.2 和 10.1.2 及更高版本包括针对此漏洞的修复。如果您使用的是版本 7 或 8,我们鼓励您升级到较新的版本。
CVE-2020-26237 MPS-2020-16772
2022-08-08 18:17
minimist 输入验证错误漏洞
原型污染
minimist是一款命令行参数解析工具。 minimist 1.2.2之前版本存在输入验证错误漏洞。攻击者可借助‘constructor’和‘__proto__’ payload利用该漏洞添加或修改Object.prototype的属性。
CVE-2020-7598 MPS-2020-3516
2022-08-08 18:17
react-dev-utils 操作系统命令注入漏洞
命令注入
Helper create-react-app是 (Helper)开源的一个应用程序。用于隐藏在弹出时不应给用户带来负担的代码。 react-dev-utils prior to v11.0.4 存在操作系统命令注入漏洞,该漏洞源于当使用用户提供的值手动调用这个getProcessForPort函数时,才有可能出现命令注入。
CVE-2021-24033 MPS-2021-2739
2022-08-08 18:17
Npm Node-tar 后置链接漏洞
node-tar是一款用于文件压缩/解压缩的软件包。 Npm Node-tar 中存在后置链接漏洞,该漏洞源于产品未对特殊字符做有效验证。攻击者可通过该漏洞在其他路径创建恶意文件。
CVE-2021-37712 MPS-2021-28488
2022-08-08 18:17
Sindre Sorhus IS-SVG 安全漏洞
不加限制或调节的资源分配
Sindre Sorhus is-svg是 (Sindre Sorhus)开源的一个应用软件。提供检查字符串或缓冲区是否为SVG功能。 IS-SVG 存在安全漏洞,该漏洞源于当应用程序检查一个精心制作的无效SVG字符串时,就会出现正则表达式拒绝服务(ReDOS)。
CVE-2021-29059 MPS-2021-8684
2022-08-08 18:17
kind-of注入漏洞
将资源暴露给错误范围
kind-of是一款JavaScript类型检查软件包。 kind-of v6.0.2版本中的index.js文件的‘ctorName’函数存在注入漏洞,攻击者可利用该漏洞覆盖内部属性,操纵类型检查的结果。
CVE-2019-20149 MPS-2019-17164
2022-08-08 18:17
Prism跨站脚本漏洞
XSS
Prism是美国Prism个人开发者的一个应用软件。是一种轻量级的,可扩展的语法突出显示工具。 Prism存在跨站脚本漏洞。攻击者可利用漏洞在Safari和Internet Explorer中执行任意代码。
CVE-2020-15138 MPS-2020-11250
2022-08-08 18:17
lodash 存在拒绝服务漏洞
拒绝服务
lodash 是一个现代 JavaScript 实用程序库,提供模块化、性能和附加功能。此软件包的受影响版本容易通过 setWith 和 set 函数受到原型污染。
MPS-2022-13842
2022-08-08 18:17
Unshiftio Url-parse 访问控制错误漏洞
Url-Parse是一个跨 Node.js 和浏览器环境无缝工作的小型 Url 解析器。 Unshiftio Url-parse 中存在访问控制错误漏洞,该漏洞源于产品对用户控制的密钥缺少有效的保护机制。攻击者可通过该漏洞绕过授权。以下产品及版本受到影响:Unshiftio Url-parse 1.5.9 之前版本。
CVE-2022-0691 MPS-2022-4474
2022-08-08 18:17
io.netty:netty-handler 存在证书验证不恰当漏洞
证书验证不恰当
io.netty:netty-handler 是一个提供异步事件驱动的网络应用程序框架和工具的库,用于快速开发可维护的高性能和高可扩展性协议服务器和客户端。换句话说,Netty 是一个 NIO 客户端服务器框架,可以快速轻松地开发协议服务器和客户端等网络应用程序。它极大地简化和流线了网络编程,例如 TCP 和 UDP 套接字服务器。此软件包的受影响版本容易受到不正确的证书验证的影响。在 Netty 4.1.x 中默认禁用证书主机名验证,这使得它可能容易受到中间人攻击。
MPS-2022-12067
2022-08-08 18:17
没有更多内容
加载失败,请刷新页面
点击加载更多
加载中
下一页