Elm 正在参加 2021 年度 OSC 中国开源项目评选,请投票支持!
Elm 在 2021 年度 OSC 中国开源项目评选 中已获得 {{ projectVoteCount }} 票,请投票支持!
2021 年度 OSC 中国开源项目评选 正在火热进行中,快来投票支持你喜欢的开源项目!
2021 年度 OSC 中国开源项目评选 >>> 中场回顾
Elm 获得 2021 年度 OSC 中国开源项目评选「最佳人气项目」 !
授权协议 BSD-3
开发语言 Haskell 查看源码 »
操作系统 跨平台
软件类型 开源软件
开源组织
地区 不详
投 递 者 bear256
适用人群 未知
收录时间 2014-03-12

软件简介

Elm是一种函数式语言,可编译为HTML、CSS和JavaScript。

Elm为函数式反应编程而设计,便于创建高可交互应用。

展开阅读全文

代码

的 Gitee 指数为
超过 的项目

评论 (1)

加载中
Elm#饿了么、百度外卖、美团外卖、外卖系统、网上订餐#网站订餐是一个不可缺少的市场,其市场会越来越大,如何做一家网站订餐系统,其程序是比不可少。经过长时间的测试开发(elem.ml)可以帮您打造本地商业门户,机遇不可错过。网上订餐系统_网络订餐系统_外卖网站建设.订餐网,外卖网源码,带积分商城,商家系统,等等
2015/01/20 10:53
回复
举报
更多评论
发表了资讯
2016/11/15 07:59

Elm 0.18 发布,函数式反应编程语言

Elm 0.18 发布了,主要更新如下: Bad Recursion — 清除突变导致的混乱 Type Annotations — 在添加类型注释时改进提示 Missing Arguments — 当忘记参数时提示 Record Precision — 使大小记录的提示非常精细 Preserve Names — 显示 Html msg 而不是 VirtualDom.Node a 更多内容请查看完整<发行日志> Elm是一种函数式语言,可编译为HTML、CSS和JavaScript。 Elm为函数式反应编程而设计,便于创建高可交互应用。...

12
11
发表了资讯
2015/11/20 00:00

Elm 0.16 发布,函数式反应编程语言

Elm 0.16 发布,该版本更快更友好,主要更新如下: produces dramatically better error messages catches incomplete pattern matches introduces tail-call optimization removes redundant syntax to improve the “code texture” of Elm 详细内容请看:发行说明。 Elm是一种函数式语言,可编译为HTML、CSS和JavaScript。 Elm为函数式反应编程而设计,便于创建高可交互应用。...

5
9
发表了资讯
2015/07/05 00:00

Elm 0.15.1 发布,函数式反应编程语言

Elm 0.15.1 发布,此版本改进了编译错误信息;改善了用户体验,详细改进请看发行说明。 Elm是一种函数式语言,可编译为HTML、CSS和JavaScript。 Elm为函数式反应编程而设计,便于创建高可交互应用。

1
8
发表了资讯
2015/04/26 00:00

Elm 0.15 发布,函数式反应编程语言

Elm 0.15 发布,此版本主要是引入了 Tasks,定义复杂的异步操作,类似 C# 的 tasks 和 JavaScript 的 promises。 因为引入了 tasks,新增了一些包: elm-http — 使用高级别 API 从服务器获取 JSON 和字符串 elm-history — 从 Elm 简单导航浏览历史 elm-router — 基于 URL 动态生成页面 elm-storage — 本地存储 此外,此版本还包括了 Motivation 优化;更快的文本渲染;新增“No Runtime Exceptions”;导入语法;引入 Mail...

1
16
发表了资讯
2015/01/26 00:00

Elm 0.14.1 发布,函数式反应编程语言

Elm 0.14.1 发布,现已提供安装, 改进内容包括: Html values can go through main elm-reactor is better in a couple ways swapping works again (had some problems in 0.14) watches in the sidebar can scroll if you have a bunch (thanks to Joe) traces look a bit nicer than before & more solid implementation minor bug fixes in elm-package for automatically bumping versions elm-make no longer has weird c...

1
14
发表了资讯
2014/12/11 00:00

Elm 0.14 发布,函数式反应式编程语言

Elm 0.14 发布,此版本包括两个非常重要的方面,主要是为了快速优美的开始 Elm 项目开发: 简化语言和核心库(类型,JSON,Signals,随机数生成,错误处理) 新的包管理器和构建工具(Elm-package,Elm-make) 更多内容请看发行说明。 Elm是一种函数式语言,可编译为HTML、CSS和JavaScript。 Elm为函数式反应编程而设计,便于创建高可交互应用。

3
17
没有更多内容
加载失败,请刷新页面
点击加载更多
加载中
下一页
发表了博客
2019/07/10 14:46

elm_flask 项目日志

后台管理项目日志 项目初始化阶段 仓库使用 注册码云平台 创建工程仓库 创建自己的开发分支 clone/push/pull的操作 新建开发分支 能够在远程分支进行pull和push 项目搭建 搭建项目基本框架目录结构 测试首页是否显示 工厂函数的设计 插件的注册顺序及循环引用如何解决 # 工厂函数,注册顺序通过函数来保证 from flask import Flask from apps.model.user_model import User from flask_session import Session def register_b...

0
0
发表了博客
2018/08/28 11:54

SpaceVim 语言模块 elm

原文连接: https://spacevim.org/cn/layers/lang/elm/ <!-- vim-markdown-toc GFM --> 模块简介 功能特性 依赖安装及启用模块 依赖安装 启用模块 快捷键 语言专属快捷键 交互式编程 <!-- vim-markdown-toc --> 模块简介 这一模块为 SpaceVim 提供了 elm 开发支持,包括代码补全、语法检查、以及代码格式化等特性。 功能特性 代码补全 语法高亮、对齐 单元测试 语法检查 文档查询 同时,SpaceVim 还为 elm 开发提供了交互式编程...

0
0
发表了博客
2016/08/07 13:23

几种语言原生开发环境构建之--Elm语言

### elm安装 ``` $ npm install elm -g $ elm $ elm-repl #repl命令行 $ elm-reactor #浏览器在线调试 $ elm-package #包管理 $ elm-make --help 编译 ``` ### 项目构建 - 初始化 ``` $ mkdir src && mkdir src/Test #源码目录,源代码文件都已大写开头 $ elm-package install  #初始化以及安装依赖 ``` - 配置文件elm-package.json ```json { "version": "1.0.0", "summary": "helpful summary of your project, less than...

0
1
发表了博客
2018/02/20 23:06

使用 RxJS 实现一个简易的仿 Elm 架构应用

使用 RxJS 实现一个简易的仿 Elm 架构应用 标签(空格分隔): 前端 什么是 Elm 架构 Elm 架构是一种使用 Elm 语言编写 Web 前端应用的简单架构,在代码模块化、代码重用以及测试方面都有较好的优势。使用 Elm 架构,可以非常轻松的构建复杂的 Web 应用,无论是面对重构还是添加新功能,它都能使项目保持良好的健康状态。 Elm 架构的应用通常由三部分组成——模型、更新、视图。这三者之间使用 Message 来相互通信。 模型 模型通...

0
0
2018/11/13 17:55

一篇文章读懂 React and redux 前端开发 -DvaJS, a lightweight and elm-style framework.

DvaJS: React and redux based, lightweight and elm-style framework. https://dvajs.com/ 实例项目源码:https://github.com/AK-47-D/react-redux-demo 快速上手 #安装 dva-cli 通过 npm 安装 dva-cli 并确保版本是 0.9.1 或以上。 $ npm install dva-cli -g $ dva -v dva-cli version 0.9.1 #创建新应用 安装完 dva-cli 之后,就可以在命令行里访问到 dva 命令(不能访问?)。现在,你可以通过 dva new 创建新应用。 $ ...

0
0
发表了博客
2018/04/30 21:39

关于运行“基于极限学习机ELM的人脸识别程序”代码犯下的一些错误

代码来源 基于极限学习机ELM的人脸识别程序 感谢文章主的分享 我的环境是 win10 anaconda Command line client (version 1.6.5)(conda 4.3.30) tensorflow-gpu 1.1.0 python 3.6.2 1. 直接运行代码块,提示“未知引用 import hpelm" 这是因为我的Python环境没有安装hpelm导致的,运行代码pip install hpelm。第一次安装没有成功,查询发现可能是pip版本问题,升级了pip版本,运行pip3 install hpelm,安装成功,两次使用的安装命...

0
0
没有更多内容
加载失败,请刷新页面
点击加载更多
加载中
下一页
暂无内容
1 评论
42 收藏
分享
OSCHINA
登录后可查看更多优质内容
返回顶部
顶部