dnd kit 正在参加 2021 年度 OSC 中国开源项目评选,请投票支持!
dnd kit 在 2021 年度 OSC 中国开源项目评选 中已获得 {{ projectVoteCount }} 票,请投票支持!
2021 年度 OSC 中国开源项目评选 正在火热进行中,快来投票支持你喜欢的开源项目!
2021 年度 OSC 中国开源项目评选 >>> 中场回顾
dnd kit 获得 2021 年度 OSC 中国开源项目评选「最佳人气项目」 !
授权协议 MIT
开发语言 TypeScript HTML/CSS
操作系统 跨平台
软件类型 开源软件
开源组织
地区 不详
投 递 者 白开水不加糖
适用人群 未知
收录时间 2021-12-06

软件简介

dnd kit 是一个用于 React 的现代、轻量级、高性能、可访问和可扩展的拖放工具包,目前处于 beta 阶段。

  • 为 React 构建:公开诸如useDraggableuseDroppable之类的 hooks,并且不需要你重新构建应用程序或创建额外的包装器 DOM 节点。
  • 功能丰富:可定制的碰撞检测算法、多个激活器、可拖动覆盖、拖动手柄、自动滚动、约束等等。
  • 支持广泛的用例:列表、网格、多个容器、嵌套上下文、可变大小的项目、虚拟化列表、2D 游戏等。
  • 零依赖和模块化:库的核心重约 10kb,没有外部依赖。它围绕内置的 React 状态管理和上下文构建,从而使库保持精简。
  • 内置支持多种输入法:指针、鼠标、触摸和键盘传感器。
  • 完全可定制和可扩展:定制每个细节:动画、过渡、行为、样式。构建你自己的传感器、碰撞检测算法、自定义键绑定等等。
  • 辅助功能:键盘支持、合理的默认咏叹调属性、可定制的屏幕阅读器说明和内置实时区域。
  • 性能:它的构建考虑了性能,以支持丝般流畅的动画。
  • 预设:需要构建一个可排序的界面?Check out @dnd-kit/sortable,这是建立在@dnd-kit/core上面的 thin layer。未来会有更多预设。
展开阅读全文

代码

的 Gitee 指数为
超过 的项目

评论

点击引领话题📣 发布并加入讨论🔥
暂无内容
发表了博客
{{o.pubDate | formatDate}}

{{formatAllHtml(o.title)}}

{{parseInt(o.replyCount) | bigNumberTransform}}
{{parseInt(o.viewCount) | bigNumberTransform}}
没有更多内容
暂无内容
发表了问答
{{o.pubDate | formatDate}}

{{formatAllHtml(o.title)}}

{{parseInt(o.replyCount) | bigNumberTransform}}
{{parseInt(o.viewCount) | bigNumberTransform}}
没有更多内容
暂无内容
nodejs 资源管理错误漏洞
拒绝服务
nodejs是是一个基于ChromeV8引擎的JavaScript运行环境通过对Chromev8引擎进行了封装以及使用事件驱动和非阻塞IO的应用让Javascript开发高性能的后台应用成为了可能。 nodejs-glob-parent 存在安全漏洞,该漏洞源于正则表达式拒绝服务。
CVE-2020-28469 MPS-2021-7827
2022-08-08 19:04
Moment.js 正则拒绝服务漏洞
拒绝服务
Moment.js 是一个 JavaScript 日期库。用于解析、验证、操作和格式化日期。 Moment.js 在处理嵌套 rfc2822 注释内容时正则表达式执行时间不断的指数增大,导致服务不可用。 攻击者可利用该漏洞使目标服务停止响应甚至崩溃。
CVE-2022-31129 MPS-2022-11159
2022-08-08 19:04
marked 存在拒绝服务漏洞
拒绝服务
标记是一个低级编译器,用于解析降价而不需要长时间缓存或阻塞。此软件包的受影响版本容易受到正则表达式拒绝服务 (ReDoS) 的攻击。
MPS-2022-13861
2022-08-08 19:04
marked 存在拒绝服务漏洞
拒绝服务
标记是一个低级编译器,用于解析降价而不需要长时间缓存或阻塞。此软件包的受影响版本容易受到正则表达式拒绝服务 (ReDoS) 的攻击。
MPS-2022-13863
2022-08-08 19:04
marked 存在ReDoS漏洞
ReDoS
标记是一个低级编译器,用于解析降价而不需要长时间缓存或阻塞。此软件包的受影响版本容易受到正则表达式拒绝服务 (ReDoS) 的攻击。
MPS-2022-13864
2022-08-08 19:04
npm node-fetch 安全漏洞
不加限制或调节的资源分配
node-fetch 2.6.1和3.0.0-beta版本中存在安全漏洞。该漏洞源于内容大小超过限制时,将永远不会抛出FetchError。
CVE-2020-15168 MPS-2020-12719
2022-08-08 19:04
Axios 拒绝服务 漏洞
拒绝服务
Axios 是一个基于promise 网络请求库。 漏洞版本的axios 容易受到低效正则表达式复杂性的影响,从而引发拒绝服务 (ReDoS) 的攻击。
CVE-2021-3749 MPS-2021-30688
2022-08-08 19:04
trim-newlines 安全漏洞
拒绝服务
trim-newlines是一个修改换行符的npm包。 trim-newlines 存在安全漏洞,该漏洞源于应用于Node.js在3.0.1与4.0.1版本及之前版本中.end()方法存在相关问题。
CVE-2021-33623 MPS-2021-7398
2022-08-08 19:04
Moment.js 路径遍历漏洞
路径遍历
Moment.js 是一个 JavaScript 日期库。用于解析、验证、操作和格式化日期。 Moment.js 的 npm 版本中处理目录遍历序列时对于输入验证不严格导致可以构造特制的 HTTP 请求读取系统上的任意文件。 攻击者可利用该漏洞访问系统敏感文件。
CVE-2022-24785 MPS-2022-3752
2022-08-08 19:04
parse-url 信息泄露漏洞
信息暴露
parse-url是Ionică Bizău个人开发者的一个支持 git url 的高级 url 解析器。 parse-url 7.0.0之前版本存在信息泄露漏洞,该漏洞源于会将用户cookie 和其他授权标头一起转发,攻击者利用该漏洞可以获取用户信息。
CVE-2022-0722 MPS-2022-4780
2022-08-08 19:04
Prism 安全漏洞
Prism是美国Prism个人开发者的一个应用软件。是一种轻量级的,可扩展的语法突出显示工具。 Prismjs 中存在安全漏洞。该漏洞源于应用易受通过prism asciidoc、prism rest、prism tap和prism eiffel组件的正则表达式错误引发的拒绝服务(ReDoS)攻击。以下产品及版本受到影响:prismjs 1.23.0 之前版本。
CVE-2021-23341 MPS-2021-2025
2022-08-08 19:04
polished 存在拒绝服务漏洞
拒绝服务
Polish 是一个用于在 Javascript 中编写样式的轻量级工具集。此软件包的受影响版本在解析 fontFace 或颜色函数中未经处理的颜色输入时容易受到正则表达式拒绝服务 (ReDoS) 的攻击。
MPS-2022-13975
2022-08-08 19:04
follow-redirects project信息暴露漏洞
信息暴露
Exposure of Sensitive Information to an Unauthorized Actor in NPM follow-redirects prior to 1.14.8.
CVE-2022-0536 MPS-2022-3636
2022-08-08 19:04
Components trim 安全漏洞
拒绝服务
Components trim是Components团队的一个用于去除字符串两端空格的 Npm 代码库。 Service trim 所有版本存在安全漏洞,该漏洞源于容易受到通过trim()的正则表达式拒绝服务的攻击。
CVE-2020-7753 MPS-2020-14926
2022-08-08 19:04
Highlightjs 安全漏洞
MAID
Highlight.js 是一个用 JavaScript 编写的语法高亮器。 Highlight.js 9.18.2 和 10.1.2 之前的版本容易受到原型污染。可以制作恶意 HTML 代码块,在突出显示期间导致基础对象原型的原型污染。如果您允许用户通过解析 Markdown 代码块(或类似代码块)将自定义 HTML 代码块插入您的页面/应用程序,并且不过滤用户可以提供的语言名称,您可能会受到攻击。污染应该只是无害的数据,但这可能会导致不期望这些属性存在的应用程序出现问题,并可能导致奇怪的行为或应用程序崩溃,即潜在的 DOS 向量。如果您的网站或应用程序不呈现用户提供的数据,它应该不受影响。版本 9.18.2 和 10.1.2 及更高版本包括针对此漏洞的修复。如果您使用的是版本 7 或 8,我们鼓励您升级到较新的版本。
CVE-2020-26237 MPS-2020-16772
2022-08-08 19:04
Npm Ini 资源管理错误漏洞
拒绝服务
Npm Ini是美国Npm公司的一个基于Javascript的用于解析和序列化Ini格式文件的代码库。 Npm ini before 1.3.6 存在资源管理错误漏洞,该漏洞允许攻击者可利用该漏洞向应用程序提交恶意的INI文件,该应用程序将用INI解析该文件。这可以根据上下文进一步加以利用。
CVE-2020-7788 MPS-2020-17544
2022-08-08 19:04
prism 安全漏洞
拒绝服务
Prism是美国Prism个人开发者的一个应用软件。是一种轻量级的,可扩展的语法突出显示工具。 prism存在安全漏洞,该漏洞源于prism容易受到低效正则表达式复杂性的影响。
CVE-2021-3801 MPS-2021-31844
2022-08-08 19:04
Async 安全漏洞
原型污染
Async是英国Caolan McMahon个人开发者的一个实用模块。用于使用异步 JavaScript。 Async 3.2.1 及之前版本存在安全漏洞,该漏洞源于 mapValues() 方法。攻击者可通过 mapValues() 方法获取权限。
CVE-2021-43138 MPS-2021-34434
2022-08-08 19:04
Prism 资源管理错误漏洞
拒绝服务
Prism是美国Prism个人开发者的一个应用软件。是一种轻量级的,可扩展的语法突出显示工具。 Prism 1.24.0之前版本存在安全漏洞,该漏洞源于当Prism用于突出显示不受信任的文本时,攻击者可利用该漏洞精心制作一个字符串,需要非常非常长的时间来显示。
CVE-2021-32723 MPS-2021-9058
2022-08-08 19:04
Follow Redirects 安全漏洞
侵犯隐私
Follow Redirects是一个自动遵循 Http(s) 重定向的 Node.js 模块。 Follow Redirects 存在安全漏洞,该漏洞源于follow-redirects容易暴露私人个人信息给未经授权的参与者。
CVE-2022-0155 MPS-2022-0815
2022-08-08 19:04
没有更多内容
加载失败,请刷新页面
点击加载更多
加载中
下一页
0 评论
0 收藏
分享
OSCHINA
登录后可查看更多优质内容
返回顶部
顶部