CodeFever 正在参加 2021 年度 OSC 中国开源项目评选,请投票支持!
CodeFever 在 2021 年度 OSC 中国开源项目评选 中已获得 {{ projectVoteCount }} 票,请投票支持!
2021 年度 OSC 中国开源项目评选 正在火热进行中,快来投票支持你喜欢的开源项目!
2021 年度 OSC 中国开源项目评选 >>> 中场回顾
CodeFever 获得 2021 年度 OSC 中国开源项目评选「最佳人气项目」 !
授权协议 MIT
操作系统 跨平台
软件类型 开源软件
所属分类 开发工具Git开源工具
开源组织
地区 国产
投 递 者
适用人群 未知
收录时间 2022-03-31

软件简介

CodeFever 是完全免费开源的 Git 代码托管服务 (A Self-hosted Git Services),支持一行命令安装到自己服务器。

功能特性

  • 永久免费: 永久免费提供给大家使用,您无需担心付费
  • 完整开源: 毫无保留的完整开源,无任何编译或加密代码
  • 轻量安装: 极简设计风格,排除重度冗余的多余功能
  • 性能高效: 速度极快,对服务器资源要求极低,1核CPU/1G内存即可运行
  • 无限仓库: 没有任何仓库数量、使用数量的限制
  • 代码对比: 支持提交代码的不同版本支持高亮显示对比
  • 分支管理: 完整支持 Git 原生分支和 Tag,帮助更清晰的管理代码
  • 合并请求(Merge Request): 支持多人协作,让代码版本控制更顺畅
  • 分支保护: 分支保护功能让代码提交安全可控,代码 Review 更容易清晰
  • 多人协作: 支持多人团队协作,并可以设置每个成员的角色和权限
  • Webhook: 支持Webhook功能,可轻松和其他系统进行集成
  • 管理后台: 支持超级管理员后台,可以让团队leader管理所有项目和用户信息
  • 中英双语: 原生支持中文和英文两种语言
展开阅读全文

代码

的 Gitee 指数为
超过 的项目

评论

点击引领话题📣 发布并加入讨论🔥
暂无内容
发表了博客
{{o.pubDate | formatDate}}

{{formatAllHtml(o.title)}}

{{parseInt(o.replyCount) | bigNumberTransform}}
{{parseInt(o.viewCount) | bigNumberTransform}}
没有更多内容
暂无内容
发表了问答
{{o.pubDate | formatDate}}

{{formatAllHtml(o.title)}}

{{parseInt(o.replyCount) | bigNumberTransform}}
{{parseInt(o.viewCount) | bigNumberTransform}}
没有更多内容
暂无内容
PSR-7 Message Implementation 输入验证错误漏洞
输入验证不恰当
PSR-7 Message Implementation是一个完整的 PSR-7 消息实现。 PSR-7 Message Implementation 1.8.3 版本及之前版本和从 2.0.0 版本到 2.1.0 版本 psr7 存在输入验证错误漏洞。攻击者可以增加新的一行字符,并在其中传入不受信任的值。
CVE-2022-24775 MPS-2022-3742
2022-08-08 18:58
Guzzle 信息泄露漏洞
信息暴露
Guzzle是guzzlehttp个人开发者的一个 PHP HTTP 客户端,可以轻松发送 HTTP 请求并轻松与 Web 服务集成。 Guzzle 7.0.0版本至7.4.3版本,以及6.5.6之前的版本存在信息泄露漏洞,该漏洞允许恶意服务器为不相关的域设置cookie,攻击者可以利用该漏洞从Guzzle 客户端登录到他们的帐户,并从其帐户的安全日志中检索私有 API 请求。
CVE-2022-29248 MPS-2022-8649
2022-08-08 18:58
Guzzle 信息泄露漏洞
信息暴露
Guzzle是guzzlehttp个人开发者的一个 PHP HTTP 客户端,可以轻松发送 HTTP 请求并轻松与 Web 服务集成。 Guzzle 6.5.6及之前版本、7.0.0 到 7.4.3 版本中存在信息泄露漏洞,该漏洞源于Cookie请求的标头是敏感信息,在向服务器发出请求时,该服务器会重定向到另一个主机来响应,Cookie标头也会被转发。
CVE-2022-31042 MPS-2022-11072
2022-08-08 18:58
Guzzle 信息泄露漏洞
授权机制不正确
Guzzle是guzzlehttp个人开发者的一个 PHP HTTP 客户端,可以轻松发送 HTTP 请求并轻松与 Web 服务集成。 Guzzle 6.5.6及之前版本、7.0.0 到 7.4.3 版本中存在信息泄露漏洞,该漏洞源于请求的标头是敏感信息,在向服务器发出请求时,该服务器会重定向到另一个主机来响应,Authorization标头也会被转发。
CVE-2022-31043 MPS-2022-11073
2022-08-08 18:58
Guzzle 安全漏洞
信息暴露
Guzzle是guzzlehttp个人开发者的一个 PHP HTTP 客户端,可以轻松发送 HTTP 请求并轻松与 Web 服务集成。 Guzzle 存在安全漏洞,该漏洞源于CURLOPT_HTTPAUTH选项存在问题。攻击者利用漏洞可以绕过数据访问限制,读取敏感数据。
CVE-2022-31090 MPS-2022-11120
2022-08-08 18:58
Guzzle 安全漏洞
信息暴露
Guzzle是guzzlehttp个人开发者的一个 PHP HTTP 客户端,可以轻松发送 HTTP 请求并轻松与 Web 服务集成。 Guzzle存在安全漏洞。攻击者利用该漏洞通过 Authorization / Cookie Headers 绕过对 Guzzle 数据的访问限制,以便读取敏感信息。
CVE-2022-31091 MPS-2022-11121
2022-08-08 18:58
没有更多内容
加载失败,请刷新页面
点击加载更多
加载中
下一页
0 评论
17 收藏
分享
OSCHINA
登录后可查看更多优质内容
返回顶部
顶部