Bundler 正在参加 2021 年度 OSC 中国开源项目评选,请投票支持!
Bundler 在 2021 年度 OSC 中国开源项目评选 中已获得 {{ projectVoteCount }} 票,请投票支持!
2021 年度 OSC 中国开源项目评选 正在火热进行中,快来投票支持你喜欢的开源项目!
2021 年度 OSC 中国开源项目评选 >>> 中场回顾
Bundler 获得 2021 年度 OSC 中国开源项目评选「最佳人气项目」 !
授权协议 MIT
开发语言 Ruby
操作系统 跨平台
软件类型 开源软件
开源组织
地区 不详
投 递 者 刘安
适用人群 未知
收录时间 2014-05-27

软件简介

Bundler使用Ruby语言写的,通过跟踪和安装运行Ruby项目所需要的确切的gem和版本,为Ruby项目提供了完整的可运行环境。

Bundler跳出了复杂的环境依赖,并且确保下载你在development, staging, and productionBundler这三个阶段所需要的gem源。开始一个项目的工作只需要一个简单的命令:bundle install

Bundler是一种有用的工具,它能使你更方便地跟踪某个应用程序所依赖的gem(以及这些gem的版本)。它通过安装应用程序的Gemfile中的所有gem来做到这一点。

Bundler安装:gem install bundler

 

展开阅读全文

代码

评论

点击加入讨论🔥(1)
发表于软件架构专区
2019/01/04 07:53

Bundler 2.0 发布,RubyGems 依赖关系管理工具

Bundler 2.0 发布了,Bundler 是一种 Ruby 环境工具,它通过跟踪和安装所需的确切 RubyGems 和版本,为 Ruby 项目提供一致的环境。RubyGems(简称 gems)类似于 Linux 下的 atp-get,是一个用于对 Ruby 组件进行打包的系统。 此版本主要带来了一些小的变化,同时删除了一些生命周期已经结束的 Ruby 和 RubyGems 版本的官方支持: 不再支持版本小于 2.3 的 Ruby。 不再支持版本小于 3.0.0 的 RubyGems,RubyGems 3.0 中引入的 Ru...

0
2
没有更多内容
加载失败,请刷新页面
点击加载更多
加载中
下一页
发表了博客
{{o.pubDate | formatDate}}

{{formatAllHtml(o.title)}}

{{parseInt(o.replyCount) | bigNumberTransform}}
{{parseInt(o.viewCount) | bigNumberTransform}}
没有更多内容
暂无内容
发表了问答
{{o.pubDate | formatDate}}

{{formatAllHtml(o.title)}}

{{parseInt(o.replyCount) | bigNumberTransform}}
{{parseInt(o.viewCount) | bigNumberTransform}}
没有更多内容
暂无内容
1 评论
1 收藏
分享
OSCHINA
登录后可查看更多优质内容
返回顶部
顶部
返回顶部
顶部