AI Explainability 360 正在参加 2021 年度 OSC 中国开源项目评选,请投票支持!
AI Explainability 360 在 2021 年度 OSC 中国开源项目评选 中已获得 {{ projectVoteCount }} 票,请投票支持!
2021 年度 OSC 中国开源项目评选 正在火热进行中,快来投票支持你喜欢的开源项目!
2021 年度 OSC 中国开源项目评选 >>> 中场回顾
AI Explainability 360 获得 2021 年度 OSC 中国开源项目评选「最佳人气项目」 !
授权协议 Apache 2.0
开发语言 Python
操作系统 跨平台
软件类型 开源软件
开源组织
地区 不详
投 递 者 罗奇奇
适用人群 未知
收录时间 2022-06-17

软件简介

AI Explainability 360 是一个开源工具包,内含机器学习八种前沿的可解释性方法和两个维度评价矩阵。可以帮助用户更好地理解机器学习模型在整个 AI 应用程序生命周期中使用各种技术预测标签的方式。

八种可解释性算法

两个维度评价矩阵

展开阅读全文

代码

的 Gitee 指数为
超过 的项目

评论

点击引领话题📣
暂无内容
发表了博客
{{o.pubDate | formatDate}}

{{formatAllHtml(o.title)}}

{{parseInt(o.replyCount) | bigNumberTransform}}
{{parseInt(o.viewCount) | bigNumberTransform}}
没有更多内容
暂无内容
发表了问答
{{o.pubDate | formatDate}}

{{formatAllHtml(o.title)}}

{{parseInt(o.replyCount) | bigNumberTransform}}
{{parseInt(o.viewCount) | bigNumberTransform}}
没有更多内容
暂无内容
Google TensorFlow代码问题漏洞
Google TensorFlow是美国谷歌(Google)公司的一套用于机器学习的端到端开源平台。Google TensorFlow存在代码问题漏洞,该漏洞源于当通过原始API恢复张量时,如果未提供张量名称,TensorFlow可能会被诱骗去引用空指针。攻击者可利用该漏洞通过提供一些张量名称来读取堆分配数据边界之外的内存。
CVE-2021-37639 MPS-2021-17250
2022-08-08 18:39
Google TensorFlow 数字错误漏洞
除零错误
Google TensorFlow是美国谷歌(Google)公司的一套用于机器学习的端到端开源平台。 Google TensorFlow 中存在数字错误漏洞,该漏洞源于产品的 tf.raw_ops.UnravelIndex 未对除数做有效限制,攻击者可通过除0导致拒绝服务。以下产品及版本收到影响:TensorFlow 2.5.1、TensorFlow 2.4.3 和 TensorFlow 2.3.4。
CVE-2021-37668 MPS-2021-17299
2022-08-08 18:39
Google TensorFlow 代码问题漏洞
反序列化
Google TensorFlow是美国谷歌(Google)公司的一套用于机器学习的端到端开源平台。 TensorFlow 中存在代码问题漏洞,该漏洞源于产品从YAML格式反序列化到Keras模型时未对输入数据做有效验证,攻击者可通过该漏洞导致代码执行。以下产品及版本收到影响:TensorFlow 2.5.1、TensorFlow 2.4.3 和 TensorFlow 2.3.4。
CVE-2021-37678 MPS-2021-17306
2022-08-08 18:39
Google TensorFlow 缓冲区错误漏洞
跨界内存读
Google TensorFlow是美国谷歌(Google)公司的一套用于机器学习的端到端开源平台。 Google TensorFlow 存在缓冲区错误漏洞,该漏洞源于在受影响的版本中,QuantizeV2的形状推断代码可能触发堆分配数组边界外的读取。如果 axis 小于 -1 ,那么这将导致一个堆OOB读取。
CVE-2021-41211 MPS-2021-31980
2022-08-08 18:39
Google TensorFlow资源管理错误漏洞
UAF
Google TensorFlow是美国谷歌(Google)公司的一套用于机器学习的端到端开源平台。 TensorFlow存在资源管理错误漏洞,该漏洞源于在受影响的版本中,当运行形状函数时,一些函数会 ShapeAndType结构体的形式产生额外的输出信息。
CVE-2021-37690 MPS-2021-17317
2022-08-08 18:39
Google TensorFlow堆分配数组越界读取漏洞
跨界内存读
Google TensorFlow是一个端到端开源机器学习平台。                                                TensorFlow 2.7.0之前版本中`SparseCountSparseOutput`的形状推断函数存在堆分配数组越界读取漏洞。目前没有详细的漏洞细节提供。
CVE-2021-41210 MPS-2021-31979
2022-08-08 18:39
Google TensorFlow堆分配数组越界读取漏洞
跨界内存读
Google TensorFlow是一个端到端开源机器学习平台。                                                TensorFlow 2.7.0之前版本中`QuantizeAndDequantizeV*`运算的形状推断函数存在堆分配数组越界读取漏洞。目前没有详细的漏洞细节提供。
CVE-2021-41205 MPS-2021-31974
2022-08-08 18:39
Google TensorFlow 代码问题漏洞
对因果或异常条件的不恰当检查
Google TensorFlow是美国谷歌(Google)公司的一套用于机器学习的端到端开源平台。 TensorFlow 2.4.2,2.3.3,2.2.3,2.1.4存在代码问题漏洞,攻击者可利用该漏洞可以通过利用来自实现CHECK失败来导致拒绝服务。
CVE-2021-29531 MPS-2021-6443
2022-08-08 18:39
tensorflow 存在跨界内存读漏洞
跨界内存读
tensorflow 是一个机器学习框架。此软件包的受影响版本容易受到越界读取的影响。
MPS-2022-15171
2022-08-08 18:39
Google TensorFlow 数字错误漏洞
除零错误
Google TensorFlow是美国谷歌(Google)公司的一套用于机器学习的端到端开源平台。 TensorFlow 2.4.2,2.3.3,2.2.3,2.1.4存在安全漏洞,该漏洞源于DepthwiseConvTFLite操作符的实现容易出现被除零错误。
CVE-2021-29602 MPS-2021-6380
2022-08-08 18:39
Google TensorFlow 缓冲区错误漏洞
跨界内存读
Google TensorFlow是美国谷歌(Google)公司的一套用于机器学习的端到端开源平台。 TensorFlow 2.4.2,2.3.3,2.2.3,2.1.4存在缓冲区错误漏洞,攻击者可利用该漏洞可以通过访问tf.raw_ops.QuantizedBatchNormWithGlobalNormalization中边界以外的数据来导致段错误和拒绝服务。
CVE-2021-29547 MPS-2021-6430
2022-08-08 18:39
Google TensorFlow缓冲区溢出漏洞
跨界内存读
Google TensorFlow是美国谷歌(Google)公司的一套用于机器学习的端到端开源平台。 Tensorflow 2.4.0之前版本存在安全漏洞,攻击者可利用该漏洞可以将一个无效的axis值传递给tf.quantization。数字转换和dequantize。这将导致在c++内核实现中访问一个超出输入张量秩的维度。但是dim size只执行DCHECK来验证参数,然后使用它来访问数组中相应的元素。因为在正常的构建中,DCHECK 类宏是无操作的,这会导致segfault和访问数组边界之外。
CVE-2020-15265 MPS-2020-15184
2022-08-08 18:39
Google TensorFlow 数字错误漏洞
除零错误
Google TensorFlow是美国谷歌(Google)公司的一套用于机器学习的端到端开源平台。 Google TensorFlow 2.4.2,2.3.3,2.2.3,2.1.4存在数字错误漏洞,该漏洞源于DepthToSpace TFLite操作符的实现容易出现被零除的错误。
CVE-2021-29595 MPS-2021-6383
2022-08-08 18:39
Google TensorFlow 代码问题漏洞
对因果或异常条件的不恰当检查
Google TensorFlow是美国谷歌(Google)公司的一套用于机器学习的端到端开源平台。 TensorFlow 2.4.2,2.3.3,2.2.3,2.1.4存在安全漏洞,攻击者可利用该漏洞可以通过利用来自实现CHECK失败来导致拒绝服务。
CVE-2021-29544 MPS-2021-6427
2022-08-08 18:39
Google Tensorflow输入验证错误漏洞
整数溢出或超界折返
Google TensorFlow是美国谷歌(Google)公司的一套用于机器学习的端到端开源平台。Google TensorFlow存在输入验证错误漏洞,攻击者可利用该漏洞创建一个包含足够多元素的张量的操作,造成整数溢出。
CVE-2022-23575 MPS-2022-2002
2022-08-08 18:39
Google TensorFlow缓冲区溢出漏洞
跨界内存写
Google TensorFlow是美国谷歌(Google)公司的一套用于机器学习的端到端开源平台。 Tensorflow SparseFillEmptyRowsGrad 1.15.4之前版本, 2.0.3版本, 2.1.2版本, 2.2.1版本,2.3.1版本中存在安全漏洞,该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞造成缓存区溢出问题。
CVE-2020-15195 MPS-2020-13682
2022-08-08 18:39
google tensorflow-2.7.0整数溢出或超界折返漏洞
整数溢出或超界折返
Tensorflow is an Open Source Machine Learning Framework. The implementation of shape inference for `Dequantize` is vulnerable to an integer overflow weakness. The `axis` argument can be `-1` (the default value for the optional argument) or any other positive value at most the number of dimensions of the input. Unfortunately, the upper bound is not checked, and, since the code computes `axis + 1`, an attacker can trigger an integer overflow. The fix will be included in TensorFlow 2.8.0. We will also cherrypick this commit on TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, as these are also affected and still in supported range.
CVE-2022-21727 MPS-2021-37085
2022-08-08 18:39
Google TensorFlow缓冲区溢出漏洞
跨界内存读
Google TensorFlow是美国谷歌(Google)公司的一套用于机器学习的端到端开源平台。 Google Tensorflow存在缓冲区溢出漏洞,该漏洞源于FractionalAvgPoolGrad的实现未考虑输入张量无效的情况,攻击者可利用该漏洞从堆的边界外读取。
CVE-2022-21730 MPS-2021-37088
2022-08-08 18:39
Google TensorFlow 数字错误漏洞
除零错误
Google TensorFlow是美国谷歌(Google)公司的一套用于机器学习的端到端开源平台。 TensorFlow 2.4.2,2.3.3,2.2.3,2.1.4存在安全漏洞,攻击者可利用该漏洞可以通FPE运行时错误导致拒绝服务。
CVE-2021-29556 MPS-2021-6419
2022-08-08 18:39
Google TensorFlow 数字错误漏洞
除零错误
Google TensorFlow是美国谷歌(Google)公司的一套用于机器学习的端到端开源平台。 TensorFlow 2.4.2,2.3.3,2.2.3,2.1.4 存在数字错误漏洞,攻击者可利用该漏洞可以通过tf.raw_ops.SparseMatMul中的FPE运行时错误导致拒绝服务。
CVE-2021-29557 MPS-2021-6420
2022-08-08 18:39
没有更多内容
加载失败,请刷新页面
点击加载更多
加载中
下一页
0 评论
0 收藏
分享
OSCHINA
登录后可查看更多优质内容
返回顶部
顶部