开源中国

我们不支持 IE 10 及以下版本浏览器

It appears you’re using an unsupported browser

为了获得更好的浏览体验,我们强烈建议您使用较新版本的 Chrome、 Firefox、 Safari 等,或者升级到最新版本的IE浏览器。 如果您使用的是 IE 11 或以上版本,请关闭“兼容性视图”。
UMI Admin首页、文档和下载 - 基于 Laravel 的后台管理系统, - 开源中国社区
Float_left Icon_close
全部项目分类
我要评价
MIT
PHP HTML/CSS
跨平台
taoyu65
分享
收藏
8 人收藏
收录时间:2017-07-29
UMI Admin 详细介绍
不同于其他后台管理, UMI Admin 可用于快速搭建后台 对于中小型后台甚至不用写任何代码, 如果有帮助 请关注,并给予星星 谢谢

Umi 是由laravel 5.3开发的全面的后台管理系统, 包括以下特性:

详细请阅读 https://github.com/taoyu65/UMIAdmin/blob/master/readme.md

  • BREAD 系统 (编辑, 读取, 添加, 删除, 查看) 要求laravel 5.3

  • RBAC 权限系统 (基于角色权限开发) 包含2部分, 一部分是 数据库中的数据表的操作权限, 增删改等, 另一部分是管理界面权限操作, 整个权限系统基于数据层面和URL界面的操作与分配

  • 数据表的全面操作 增删改, 搜索, 以及自定义这些操作

  • 表之间关系的设定与操作, 比如可以自定义关联删除,关联更新, 或定义删除某表之前检查是否在其他表存在外键因而不能删除表等, 例如删除一个购物车,里面的物品所在的物品表的数据将一并删除等

  • 自定义显示数据格式, 可以设定任何字段用以什么方式现在在界面.例如一个外键可以显示其ID 或者 显示所对应表字段的名称.

安装

  1. 安装composer 和 laravel 5.3 框架. 请自行安装,可以通过不同方式安装. 推荐composer方式

执行命令 composer create-project --prefer-dist laravel/laravel blog 5.3.*

  1. 安装UMI Admin.

执行命令 composer require ym/umi "v0.1.2.*" 
如果可以正常使用composer 执行上面命令的可以忽略这个段落, 如果不能正常使用composer的小伙伴可以查看 https://github.com/taoyu65/UMIAdmin/wiki/install

  1. 配置数据库连接文件(.env)

DB_HOST=localhost
DB_DATABASE=新建一个空的数据库
DB_USERNAME=用户名
DB_PASSWORD=密码

  1. 添加服务提供者.添加下面2行代码到 根目录/config/app.php 里面providers数组里面

YM\UmiServiceProvider::class,
YM\umiAuth\umiAuthServiceProvider::class,

  1. 执行下面的命令, 用于安装应用程序

php artisan umi:install (会提示选择安装数据库中数据的语言 1=汉语 2=英语) 输入1然后回车. 附:如果数据库已经安装完毕, 在想更改语言英语或汉语 仅需执行 php artisan umi:install --lang-zh-only(或 --lang-en-only)

  1. 设置系统为中文:

在根目录下config/app.php中 设置 'locale' => 'zh_cn', 即可

  1. 好了. 可以开始了.
    注意:为了保证数据库迁移,数据库结构和一些必要的数据。 请在执行php artisan umi:install之前 保持数据库为空。如果要重新安装请手动清空数据库包括结构。

UMI Admin

选择将代码托管在码云
你还在等什么

可能是中国最大最好的代码托管平台


大家对 UMI Admin 的评论 (全部 0 条评论)
{{repayCom.userName}}
顶部