Yarn 1.9.3 和 1.9.4 发布,JavaScript 包管理器

达尔文
 达尔文
发布于 2018年08月04日
收藏 4

Yarn 1.9.3 和 1.9.4 发布了。Yarn 是 Facebook 推出的 JavaScript 包管理器,旨在提供 npm 之外的另一种选择方案。Yarn 具有极佳的伸缩性,可以支持成千上万个直接或间接的包依赖。

Yarn 的设计初衷是保证稳定性、弹性和高性能。其与 npm 最大的不同在于安装包的方式,Yarn 用到了 lockfiles 和确定性算法。Lockfile 会把安装的包版本进行锁定,保证了 node_modules 目录在不同设备上的安装结果是一致的,同时支持并行操作,大大加快安装进程。此外,Yarn 还声明同时兼容 npm 和 Bower,支持两个仓库混合使用,同时支持包的离线安装(只要你曾经安装过这个包)。

更新内容如下:

1.9.3

  • 修复: perf 回归

  • 修复:修改 PATH 以在其中添加 Node 时出现的问题

  • 修复:混合范围包,yarnrc 配置,yarn 全局/yarn 创建的问题

1.9.4 

没有提供更新内容

下载地址:

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:Yarn 1.9.3 和 1.9.4 发布,JavaScript 包管理器
加载中

最新评论(1

s
smallwhite110
那么问题来了,我是用1.9.3还是1.9.4?
返回顶部
顶部