Yarn 1.9.2 发布,Facebook 开源 JavaScript 包管理器

来源: OSCHINA
编辑: h4cd
2018-07-26

Yarn 1.9.2 发布了,Yarn 是 Facebook 推出的 JavaScript 包管理器,旨在提供 npm 之外的另一种选择方案。Yarn 具有极佳的伸缩性,可以支持成千上万个直接或间接的包依赖。Yarn 的设计初衷是保证稳定性、弹性和高性能。其与 npm 最大的不同在于安装包的方式,Yarn 用到了 lockfiles 和确定性算法。Lockfile 会把安装的包版本进行锁定,保证了 node_modules 目录在不同设备上的安装结果是一致的,同时支持并行操作,大大加快安装进程。此外,Yarn 还声明同时兼容 npm 和 Bower,支持两个仓库混合使用,同时支持包的离线安装(只要你曾经安装过这个包)。

此次更新修复了 Windows  yarn pack 一个小 bug。

发布公告

下载地址:

展开阅读全文
1 收藏
分享
加载中
最新评论 (4)
上上周,我组raid1来备份旧数据,手动操作复制备份,其中有个node_modules文件夹,备份过程被提醒该文件目录深度太深了,然后手动删除也失败....最后用文件粉碎机强制删掉才解决....
2018-07-27 17:42
0
回复
举报
还没有发布为正式版..
2018-07-26 15:52
0
回复
举报

引用来自“Andyfoo”的评论

谁来开发一个单文件数据库包管理,把node_modules 目录放到单文件数据库中,特别讨厌大量小文件
模块不同版本相互依赖,还有模块层次太深这类问题.我感觉到npm8 才会有所改善,,也就是说明年下半年; 目前是不大可能的
2018-07-26 08:53
0
回复
举报
谁来开发一个单文件数据库包管理,把node_modules 目录放到单文件数据库中,特别讨厌大量小文件
2018-07-26 08:38
0
回复
举报
更多评论
4 评论
1 收藏
分享
返回顶部
顶部