Eureka 2.0 开源工作宣告停止,继续使用风险自负 - 开源中国社区
Float_left Icon_close
Eureka 2.0 开源工作宣告停止,继续使用风险自负
h4cd 2018年06月29日

Eureka 2.0 开源工作宣告停止,继续使用风险自负

h4cd h4cd 发布于2018年06月29日 收藏 19

近日,知名服务注册与服务发现工具 Eureka 的 GitHub Wiki 上显示其 2.0 版本的开源工作已经停止。


这意味着如果开发者继续使用作为 2.x 分支上现有工作 repo 一部分发布的代码库和工件,则将自负风险,对此,专家建议开发者尽快将相关业务迁移到 Consul/ZooKeeper/Etcd 等工具上。

目前还未见 Netflix 官方对此作出进一步说明,开源中国将持续关注。

Eureka 是一种基于 REST 的服务,主要用于 AWS 云中定位服务,以实现中间层服务器的负载均衡和失效转移。

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:Eureka 2.0 开源工作宣告停止,继续使用风险自负
分享
评论(31)
精彩评论
15
我觉得不用太担心,只要Spring Cloud还在维护到时真不能用了Spring团队会弄一个新的出来,看看Zuul2的开源就知道了.
zuul 2.0 千呼万唤始出来,然而Spring Cloud官方已经不打算集成,自己弄了Spring Cloud Gateway,原因很简单,等了那么久总是跳票,自己搞了一个出来
https://github.com/spring-cloud/spring-cloud-netflix/issues/2951
4
T T 我还写了一波 eureka 源码解析。

期待 spring 出新的解决方案。http://www.iocoder.cn/categories/Eureka/?oschina
3
早该停用了,一直在用Consul。见:https://gitee.com/osworks/MyClouds
2

引用来自“Hebaceous”的评论

别危言耸听了,人家只是2.0不开发了,就像netty的5.0直接放弃,而且springcloud用的eureka是1.x啊
为什么不是人家2.0开发的好,准备商业化闭源呢?纯猜。
2

引用来自“NormanCjj”的评论

刚准备把springcloud1.X升级到2,看到这个就没动力了
spring cloud 2.0还是依赖eureka 1.9.2啊,并未依赖Eureka 2,即使闭源了,也可以还zookeeper/Consul,都给你封装好了,不要方
最新评论
0
哔哩哔哩开源了基于eureka逻辑和Go写的服务注册发现系统,可以了解一下
地址:https://github.com/Bilibili/discovery
0

引用来自“首席的哥队长”的评论

我觉得不用太担心,只要Spring Cloud还在维护到时真不能用了Spring团队会弄一个新的出来,看看Zuul2的开源就知道了.
zuul 2.0 千呼万唤始出来,然而Spring Cloud官方已经不打算集成,自己弄了Spring Cloud Gateway,原因很简单,等了那么久总是跳票,自己搞了一个出来
https://github.com/spring-cloud/spring-cloud-netflix/issues/2951
google Istio 绝对是微服务的未来。
0
再用consul
0
看了一下GitHub ,2.x的分支三年前就没更新了,作者一直在更新1.x版本,spring 一直用的是1.x版本
0
Consul 是最叼的
0

引用来自“首席的哥队长”的评论

我觉得不用太担心,只要Spring Cloud还在维护到时真不能用了Spring团队会弄一个新的出来,看看Zuul2的开源就知道了.
zuul 2.0 千呼万唤始出来,然而Spring Cloud官方已经不打算集成,自己弄了Spring Cloud Gateway,原因很简单,等了那么久总是跳票,自己搞了一个出来
https://github.com/spring-cloud/spring-cloud-netflix/issues/2951
给力!spring cloud gateway 写的还是蛮不错的呢
4
T T 我还写了一波 eureka 源码解析。

期待 spring 出新的解决方案。http://www.iocoder.cn/categories/Eureka/?oschina
0

引用来自“NormanCjj”的评论

刚准备把springcloud1.X升级到2,看到这个就没动力了

引用来自“Big_BoBo”的评论

spring cloud 2.0还是依赖eureka 1.9.2啊,并未依赖Eureka 2,即使闭源了,也可以还zookeeper/Consul,都给你封装好了,不要方
目前Consul、zookeeper、etcd、eureka中,貌似只有eureka是保证ap的,还真不能简单的直接替换
2

引用来自“Hebaceous”的评论

别危言耸听了,人家只是2.0不开发了,就像netty的5.0直接放弃,而且springcloud用的eureka是1.x啊
为什么不是人家2.0开发的好,准备商业化闭源呢?纯猜。
0
还不你死.
1
别危言耸听了,人家只是2.0不开发了,就像netty的5.0直接放弃,而且springcloud用的eureka是1.x啊
15
我觉得不用太担心,只要Spring Cloud还在维护到时真不能用了Spring团队会弄一个新的出来,看看Zuul2的开源就知道了.
zuul 2.0 千呼万唤始出来,然而Spring Cloud官方已经不打算集成,自己弄了Spring Cloud Gateway,原因很简单,等了那么久总是跳票,自己搞了一个出来
https://github.com/spring-cloud/spring-cloud-netflix/issues/2951
0
只是2.x不维护了,没说1.x不维护了,可以继续使用1.x
2

引用来自“NormanCjj”的评论

刚准备把springcloud1.X升级到2,看到这个就没动力了
spring cloud 2.0还是依赖eureka 1.9.2啊,并未依赖Eureka 2,即使闭源了,也可以还zookeeper/Consul,都给你封装好了,不要方
1
刚准备把springcloud1.X升级到2,看到这个就没动力了
0

引用来自“唐代de豆腐”的评论

后面springcloud 也闭源我就笑了。
哈哈 自己不写框架,就不行了
0
spring cloud怎么办???
0
eureka那么好用,干嘛要欺负它
0
后面springcloud 也闭源我就笑了。
0
用开源本身就是后果自负。大不了自己拿着源码改
顶部