JRuby 9.1.17.0 发布,改进对 Java 9/10 的兼容性

王练
 王练
发布于 2018年04月24日
收藏 3

JRuby 9.1.17.0 已发布,JRuby 是面向 Ruby、基于 Java 虚拟机(JVM)的一种解释程序,它结合了 Ruby 语言的简易性和功能强大的 JVM 的执行机制,包括与 Java 库全面集成。Rails 彻底加快及简化了 Web 应用的开发,不过它让人觉得不够成熟,特别是在高端企业级功能方面。另一方面,Java 平台及其虚拟机、库和应用服务器的速度、稳定性和功能方面却一直在提升,现在已被公认为是开发高端服务器应用的领先平台。不过如果 Java 平台不与 Ruby 等新兴语言联系在一 起,就有可能落后于流行趋势。

JRuby 9.1.x 是目前 JRuby 的主要版本,它与 Ruby 2.3.x 兼容,并与 C Ruby 保持同步,该版本值得关注的更新:

  • Windows installer works with Java 9

  • 改进对 Java 9/10 的兼容性

  • 修复了 31 个 issues

有关更多细节,可查阅发行说明:

下载地址:

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:JRuby 9.1.17.0 发布,改进对 Java 9/10 的兼容性
加载中

最新评论(4

你们都是技术宅
你们都是技术宅

引用来自“kardashian”的评论

如果 Java 平台不与 Ruby 等新兴语言联系在一 起,就有可能落后于流行趋势
jvm平台还不够开放吗?scala、kotlin,groovy三驾马车风头正盛,感觉其他平台完全没法比啊
科技范麒麟才子
科技范麒麟才子
这玩意 还活着呢
找bug
找bug

引用来自“kardashian”的评论

如果 Java 平台不与 Ruby 等新兴语言联系在一 起,就有可能落后于流行趋势
kotlin:你不联系老子,老子联系你。kotlin可以100%的和java互调。
kardashian
kardashian
如果 Java 平台不与 Ruby 等新兴语言联系在一 起,就有可能落后于流行趋势
返回顶部
顶部