HikariCP 3.0.0 正式发布,高性能 JDBC 连接池组件

淡漠悠然
 淡漠悠然
发布于 2018年04月03日
收藏 14

HikariCP 3.0.0 已发布,HikariCP 是一个高性能的 JDBC 连接池组件。该版本移除了先前已弃用的大量方法,其他更新包括:

  • pull 1110 add currently configured maxConnections and minConnections to pool metrics.

  • pull 1100 remove hard-coded percentiles for Micrometer metrics.

  • pull 1108 maintain a strong reference to PoolStats for Micrometer gauges to prevent premature garbage collection.

  • pull 1098 update to Micrometer 1.0.0.

完整内容请查看更新日志

下载地址:

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:HikariCP 3.0.0 正式发布,高性能 JDBC 连接池组件
加载中

最新评论(6

MagicTok
MagicTok

引用来自“开源中国首席最强王者”的评论

spring默认用哪个?

引用来自“hulk0505”的评论

tomcat的
2.0已默认使用hikariCP
h
hulk0505

引用来自“开源中国首席最强王者”的评论

spring默认用哪个?
tomcat的
Lukewxl
Lukewxl
Java 8/9 maven artifact:

<dependency>
<groupId>com.zaxxer</groupId>
<artifactId>HikariCP</artifactId>
<version>3.0.0</version>
</dependency>
Java 7 maven artifact (maintenance mode):

<dependency>
<groupId>com.zaxxer</groupId>
<artifactId>HikariCP-java7</artifactId>
<version>2.4.13</version>
</dependency>
Java 6 maven artifact (maintenance mode):

<dependency>
<groupId>com.zaxxer</groupId>
<artifactId>HikariCP-java6</artifactId>
<version>2.3.13</version>
</dependency>
Waising
Waising

引用来自“费振龙”的评论

能不能不区分jdk版本,恶心啊
新的不用带jdk版本啊 ,旧的可能是重写了代码不支持低版本了吧。
费振龙
费振龙
能不能不区分jdk版本,恶心啊
开源中国首席罗纳尔多
开源中国首席罗纳尔多
spring默认用哪个?
返回顶部
顶部