Apache Ant 1.9.11 和 1.10.3 发布,初步支持 JUnit5

王练
 王练
发布于 2018年03月29日
收藏 1

Apache Ant 1.9.11 和 1.10.3 已发布,Apache Ant 是一个将软件编译、测试、部署等步骤联系在一起加以自动化的一个工具,大多用于Java环境中的软件开发。

Apache Ant 团队目前拥有两条开发线,1.9.x 版本在运行时需要 Java5 以上,而 1.10.x 则要求 Java8 以上。官方建议使用 1.10.3 ,除非你在构建过程中被要求使用 Java8 之前的 Java 版本。这两个版本都是 bug 修复版本。出于几个原因,1.10.3 版本非常重要,之前的 1.10.2 版本无意中引入了一系列导致 Ant 任务出现问题的更改,现在均已恢复或修复。

Ant 1.10.3 以 junitlauncher 任务的形式引入了对 JUnit5 的初始支持。Ant 中的 “junitlauncher” 引入了一种让构建指定要为测试启动选择哪些类的方法。此任务的目标是启动测试执行并让 JUnit 5 框架识别并运行测试。 Ant 1.10.3 中提供的当前实现是此任务的最小实现,计划在后续得到用户反馈时完善更多功能。

具体更新细节请查阅发行说明

下载地址:

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:Apache Ant 1.9.11 和 1.10.3 发布,初步支持 JUnit5
加载中

最新评论(2

沧海_Sea
沧海_Sea
看到ant管理的项目就头大
开源中国首席罗纳尔多
开源中国首席罗纳尔多
idea自带的怎么升级?
返回顶部
顶部