Intellij IDEA 2018.1 正式发布,支持 JDK 10 - 开源中国社区
Float_left Icon_close
Intellij IDEA 2018.1 正式发布,支持 JDK 10
薛柯基 2018年03月28日

Intellij IDEA 2018.1 正式发布,支持 JDK 10

薛柯基 薛柯基 发布于2018年03月28日 收藏 14

Intellij IDEA 2018.1 正式版已发布:

亮点包括:

1. 支持JUnit 5的@Tag注解

2. 允许在debug模式下不修改代码的情况下抛出异常或打印断点的堆栈信息

3. 高亮折叠代码中的错误信息

4. 支持在替换面板预览替换后的结果

5. 合并Android Studio 3.0的特性

6. Spring Boot启动后,左侧边栏添加一个新的图标,便于通过新的REST client模拟HTTP请求

7. 新的文档UI

8. 支持最新的TS 2.7

9. Project Language Level 支持JDK 10

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:Intellij IDEA 2018.1 正式发布,支持 JDK 10
分享
评论(71)
精彩评论
12
rest那个真方便
5
输入法bug 什么时候修复
4
安装 NSIS Error 是什么鬼?
3
难道官方的安装包被篡改了?又没有安装成功的,发一个副本
3
输入法光标不跟随, 自己搞个JRE放进去替换一下就好了
最新评论
0

引用来自“二灯大师”的评论

输入法bug 什么时候修复
输入法没有问题啊,是JDK的问题,你安装JDK1.8.131以上版本就行了
0

引用来自“Xanthuim”的评论

事实上使用社区版就够用了,旗舰版只不过加了一些插件而已,这些插件基本上都没用。再说了,我们构建项目不都是用maven或者gradle吗?插件不需要啊。
这些插件能提高开发效率
0
事实上使用社区版就够用了,旗舰版只不过加了一些插件而已,这些插件基本上都没用。再说了,我们构建项目不都是用maven或者gradle吗?插件不需要啊。
0

引用来自“二灯大师”的评论

输入法bug 什么时候修复
jdk1.8就可以了,那个是jdk的问题
0
REST的功能没找到啊
0

引用来自“RememBerBe”的评论

难道官方的安装包被篡改了?又没有安装成功的,发一个副本
全局代理 再下载
0

引用来自“小99”的评论

rest那个真方便
怎么整,装了没看见
0

引用来自“小99”的评论

rest那个真方便
添加了spring-boot-starter-actuator,为何一直没有调试图标出来呢?
0

引用来自“长沙大东家”的评论

能破解吗?

引用来自“MartinBock”的评论

http://idea.java.sx/ 不客气

引用来自“长沙大东家”的评论

回复@MartinBock : 你发的打不开了,http://idea.lanyus.com/这个吧。

引用来自“MartinBock”的评论

回复@长沙大东家 : 你没懂我的意思啊,这个是激活时候你填的server=,=

引用来自“长沙大东家”的评论

回复@MartinBock : server填 127.0.0.1
回复@长沙大东家 : License server
0

引用来自“长沙大东家”的评论

能破解吗?

引用来自“MartinBock”的评论

http://idea.java.sx/ 不客气

引用来自“长沙大东家”的评论

回复@MartinBock : 你发的打不开了,http://idea.lanyus.com/这个吧。

引用来自“MartinBock”的评论

回复@长沙大东家 : 你没懂我的意思啊,这个是激活时候你填的server=,=
回复@MartinBock : server填 127.0.0.1
0

引用来自“长沙大东家”的评论

能破解吗?

引用来自“MartinBock”的评论

http://idea.java.sx/ 不客气

引用来自“长沙大东家”的评论

回复@MartinBock : 你发的打不开了,http://idea.lanyus.com/这个吧。
回复@长沙大东家 : 你没懂我的意思啊,这个是激活时候你填的server=,=
1
全新安装完成后,老提示我切换jdk,我点switch,切换不过来。麻烦问下,2018用那个版本的jdk性能最好?1.9?10?
Please consider switching to the bundled Java runtime that is better suited for the IDE (your current Java runtime is 1.8.0_152-b16 by Oracle Corporation).
    Switch Don't Show Again
0
springboot 跑不起来了
0
升级了 rest那个特性我这里没有
0
启动封面变丑了
0

引用来自“长沙大东家”的评论

能破解吗?

引用来自“MartinBock”的评论

http://idea.java.sx/ 不客气
回复@MartinBock : 你发的打不开了,http://idea.lanyus.com/这个吧。
0

引用来自“你说的我就不懂”的评论

输入法光标不跟随, 自己搞个JRE放进去替换一下就好了

引用来自“沧海_Sea”的评论

我替换了还是不行 jre版本有什么限制没
我用的是win10自带输入法,不知道是不是输入法的问题
0
gradle import https://github.com/gradle/gradle/pull/4759
3
难道官方的安装包被篡改了?又没有安装成功的,发一个副本
2
NSIS Error有解决办法了吗
顶部