Sequelize 5.0.0 beta 不再支持 Node 6 以下版本

王练
 王练
发布于 2018年03月25日
收藏 0

Sequelize 5.0.0 beta 已发布,更新内容如下:

  • 移除 Model.attributes ,使用 Model.rawAttributes 替换。#5320

  • paranoid 模式下将把 deletedAt 的所有行为视为删除。 #8496

  • 要求 Node 6 及以上版本。 #9015

更多详情可查阅更新日志

Sequelize.js 提供对 MySQLMariaDBSQLite 和 PostgreSQL 数据库的简单访问,通过映射数据库条目到对象,或者对象到数据库条目。简而言之,就是 ORM(Object-Relational-Mapper)。Sequelize.js 完全是使用 JavaScript 编写,适用于 Node.js 的环境。

源码地址:

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:Sequelize 5.0.0 beta 不再支持 Node 6 以下版本
加载中

最新评论(1

开源中国红薯批发商
开源中国红薯批发商
刚用上v4版本
返回顶部
顶部