Mybatis 通用 Mapper 3.5.3 发布

2018年03月07日

Mybatis 通用 Mapper 3.5.3 已发布。MyBatis 通用 Mapper 极其方便的使用 MyBatis 单表的增删改查,支持单表操作,不支持通用的多表联合查询。通用 Mapper 可以极大的方便开发人员。可以随意的按照自己的需要选择通用方法,还可以很方便的开发自己的通用方法。

最近几个月一直在忙着通用 Mapper 4.0 版本的开发,好多邮件和 issue 都没时间回复。4.0 马上就要发布了,但是 3.5.2 还存在一个关键的 bug,为了让 3.5.x 系列可用,这次先发布 3.5.3 版本。

3.5.3 更新内容:

  • 解决 MapperHelper.setConfig 方法中没有处理 mappers 的 BUG,主要影响 starter 中的使用。

<dependency>
    <groupId>tk.mybatis</groupId>
    <artifactId>mapper</artifactId>
    <version>3.5.3</version>
</dependency>

同时 mapper-spring-boot-starter 更新到了 1.2.4:

  • 解决 mappers 参数不起作用的 bug。

  • 通用 Mapper 升级到 3.5.3 版本。

  • Spring Boot 升级到 2.0.0-RELEASE 版本。

  • 解决 Spring Boot 兼容性问题 (Binder 现在如果都不匹配就抛出异常了)。

<dependency>
    <groupId>tk.mybatis</groupId>
    <artifactId>mapper-spring-boot-starter</artifactId>
    <version>1.2.4</version>
</dependency>

示例项目 MyBatis-Spring-Boot 也都更新到了最新版本,项目地址:

https://github.com/abel533/MyBatis-Spring-Boot

4.0.0-beta 和 starter 的 2.0.0-beta 版本都已经发布,点击 4.0.0-beta 测试版反馈 参与。

来源:http://mp.weixin.qq.com/s/9sffQ2VofPBZPfW4zPWKnw

展开阅读全文
20 收藏
分享
加载中
精彩评论
改用mybatisPlus了
2018-03-07 15:54
1
举报
最新评论 (4)

引用来自“某二阶堂”的评论

Mapper 3.5.2要求jdk是什么版本? gradle 已经从中央仓库下载包到本地,Ide里面也能查找到这个包,
用gradle task编译的时候提示ClassNotFoundException:tk.mybatis.mapper.generator.MapperPlugin
jdk 1.6
2018-03-13 13:51
0
回复
举报
Mapper 3.5.2要求jdk是什么版本? gradle 已经从中央仓库下载包到本地,Ide里面也能查找到这个包,
用gradle task编译的时候提示ClassNotFoundException:tk.mybatis.mapper.generator.MapperPlugin
2018-03-11 17:07
0
回复
举报
改用mybatisPlus了
2018-03-07 15:54
1
回复
举报
很好很强大,一直在使用。💪
2018-03-07 09:26
0
回复
举报
更多评论
4 评论
20 收藏
分享
返回顶部
顶部