Google Guice 4.2 发布,支持 Java 9 和 JPMS - 开源中国社区
Google Guice 4.2 发布,支持 Java 9 和 JPMS
王练 2018年03月02日

Google Guice 4.2 发布,支持 Java 9 和 JPMS

王练 王练 发布于2018年03月02日 收藏 5

【腾讯云】如何快速搭建微信小程序?>>>  

Guice 4.2 已发布了,Guice 是 Google 开发的一个基于 Java 6 以上的轻量级依赖注入框架,目标是使开发和调试更容易,更快速。

主要更新内容:

  • 支持 Java 9 和 JPMS 

  • Multibindings(多重绑定)现在位于 Guice 的核心工件中。Multibindings 工件是空的,以防止在升级过程中造成混淆,并将在后续版本中删除。

  • 通过改变报告错误的方式提高 guice provisioning 约 20% 的性能。Guice 在 provisioning 期间将不再报告多个错误。

  • 改进绑定缺失的错误提醒。

  • 各种优化。

  • 新增 CheckedProviders 类。

  • 调整  Singletons(单例模式)的工作方式,不再依赖 ThreadLocals 和 WeakReferences 。

  • 新增 MapBinderBinding.getEntries(Iterable)

  • 弃用 ProvisionListener.ProvisionInvocation.getDependencyChain()

完整更新内容可查阅发行说明

Maven

Guice:

<dependency>
  <groupId>com.google.inject</groupId>
  <artifactId>guice</artifactId>
  <version>4.2.0</version>
</dependency>

Guice (No AOP):

<dependency>
  <groupId>com.google.inject</groupId>
  <artifactId>guice</artifactId>
  <version>4.2.0</version>
  <classifier>no_aop</classifier>
</dependency>

下载地址:

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:Google Guice 4.2 发布,支持 Java 9 和 JPMS
分享
评论(2)
最新评论
0
还活着啊... 2014年用过...后来都是spring
0
Great
顶部