WordPress 4.9.3 Beta 版发布,移除 JSHint - 开源中国社区
Float_left Icon_close
WordPress 4.9.3 Beta 版发布,移除 JSHint
达尔文 2018年02月01日

WordPress 4.9.3 Beta 版发布,移除 JSHint

达尔文 达尔文 发布于2018年02月01日 收藏 0

WordPress 开发团队刚刚发布了 WordPress 4.9.3 Beta 版本。在这一版本中,WordPress 开发团队从核心代码中移除了 JSHint.js :也就是说,取消了代码编辑器中的语法高亮和错误提示功能。

WordPress 4.9 版本中,开发者新增加了一项非常实用功能,即在后台的主题和插件编辑器中,增加了语法高亮和错误提示功能。对于开发者来说,这是一项非常实用的功能,如下图:


这个语法高亮和错误代码功能,是基于 JSHint.js 这个 JavaScript 脚本文件实现的。有细心的 WordPress 社区用户发现,JSHint 的使用许可中,包含了这样一句话:Do Not use for Evil,即不要用于作恶。这与 WordPress 遵从的 GPL 协议不相兼容。因此,WordPress 开发者决定将此文件从 WordPress 中删除,以避免给用户带来麻烦。

是否作恶也是一个主观问题,在使用许可中加入这样恶意评判的语句是很不合适的。比如像我这样长在红旗下,给红旗唱赞歌的人,在戴有色眼镜的人看来,可能也是作恶呢。

此外,WordPress 4.9.3 Beta 还修改了其他十多处代码。WordPress 4.9.3 正式版预计将于下周二左右发布。

来源:WordPress 中文网

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:WordPress 4.9.3 Beta 版发布,移除 JSHint
分享
评论(6)
精彩评论
1
JSHint 的使用许可中,包含了这样一句话:Do Not use for Evil,即不要用于作恶。这与 WordPress 遵从的 GPL 协议不相兼容。
最新评论
还把wp看作博客的人,我只能说他们很无知
1
JSHint 的使用许可中,包含了这样一句话:Do Not use for Evil,即不要用于作恶。这与 WordPress 遵从的 GPL 协议不相兼容。
0
更喜欢国产第一博客系统zblog
0
要不是你们都在说wp,我真的不会去鸟它
0
要不是上一任phper留下wp, 我真的不会去鸟它
0
要不是公司用了wp做官网,我连看他一眼都嫌弃。
顶部