Spring Security 5.0.1, 4.2.4, 4.1.5 安全补丁版本 - 开源中国社区
Spring Security 5.0.1, 4.2.4, 4.1.5 安全补丁版本
B超 2018年01月30日

Spring Security 5.0.1, 4.2.4, 4.1.5 安全补丁版本

B超 B超 发布于2018年01月30日 收藏 3

【腾讯云】如何快速搭建微信小程序?>>>  

Spring Security 5.0.1, 4.2.4 和 4.1.5 版本主要修复问题CVE-2017-8030: Security bypass with static resources , 通过在访问静态资源的URL路径编码添加特殊编码的字符可绕开Spring Security的安全限制。

目前受该问题影响的程序包括:

  • Spring Security

    • 4.1.0 - 4.1.4

    • 4.2.0 - 4.2.3

    • 5.0.0

  • Spring Framework

    • 5.0.0 - 5.0.2

    • 4.3.0 - 4.3.13

强烈建议受影响的用户按如下建议升级依赖包版本解决该问题:

  • Spring Security

    • 5.0.x  -> 5.0.1

    • 4.2.x  -> 4.2.4

    • 4.1.x  -> 4.1.5

  • Spring Framework

    • 5.0.x  ->  5.0.3

    • 4.3.x  ->  4.3.14

来自:https://spring.io/blog/2018/01/30/cve-2017-8030-spring-security-5-0-1-4-2-4-4-1-5-released

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:Spring Security 5.0.1, 4.2.4, 4.1.5 安全补丁版本
分享
评论(0)
最新评论
顶部