Spring Framework 5.0.3 和 4.3.14,开始支持 JDK 10

王练
 王练
发布于 2018年01月24日
收藏 10

Spring Framework 5.0.3 及 4.3.14 版本作为两主要分支版本的维护改进版本已正式发布,5.0.3 版本是下周即将发布的 Spring Boot 2.0 RC1 的基础,4.3.14 版本将在同一时间被 Boot 1.5.10 封装使用。

Spring Framework 5.0.3 新增了对 Kotlin 1.2.20、Reactor Core 3.1.3 和 JUnit 5.0.3 的支持,并且已经在最新的 JDK 10 早期构建版本中成功地进行了测试。它还包含了针对 WebFlux API 中最近的一些修复和改进,并正在为从 5.0.x 迁至 5.1 分支做准备。

5.0.3 和 4.3.14 都包含最近发布的 CGLIB 3.2.6 的嵌入式变种版本。4.3.14 也升级到 ASM 6.0 ,完全支持 Java 9 。不过需注意的是,开发团队强烈建议在 JDK 9+上的新项目使用 Spring Framework 5.x,4.3.x 仅为现有的应用提供了一个平滑的升级路径。

5.0.3 详细更新内容:Release Notes

4.3.14 详细更新内容:Release Notes

下载地址:

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:Spring Framework 5.0.3 和 4.3.14,开始支持 JDK 10
加载中

精彩评论

开源中国顶顶顶
开源中国顶顶顶
5.0.2的拦截器 handlerinterceptoradapte
4.3.14HandlerInterceptor
handlerinterceptoradapte一次请求居然会执行两次 但是HandlerInterceptor只会执行一次, 这是为什么, 所以现在还是用的4.x系列
他们叫我保罗
他们叫我保罗
是多了知道异步吗?
hantsy
hantsy

引用来自“lewis007”的评论

没有10,只有短命的9,18.3和长寿的18.9
后面的 Java 会按大约6个月的周期发布,但命名依然是 10, 11 ,不会是 18.3,18.9 等。而10, 11 在很大程度完全兼容9,是9 的加强版本,按老式的命名可能对应可能是 9.1, 9.2. 而大规模的语法修改,改进等,真正意义上大版本升级,则会在后面12 或者更后的版本中进行。

infoq 上有相关的Oracle官方文章说明。https://www.infoq.com/news/2017/11/new-version-scheme-java

最新评论(13

他们叫我保罗
他们叫我保罗
是多了知道异步吗?
开源中国顶顶顶
开源中国顶顶顶
5.0.2的拦截器 handlerinterceptoradapte
4.3.14HandlerInterceptor
handlerinterceptoradapte一次请求居然会执行两次 但是HandlerInterceptor只会执行一次, 这是为什么, 所以现在还是用的4.x系列
hantsy
hantsy

引用来自“MrXionGe”的评论

老哥!JDK10的毛还没看到呢,难道是你们几个私下先玩了么??
话说应该是18.3和18.9才对。
http://jdk.java.net/10/
hantsy
hantsy

引用来自“lewis007”的评论

没有10,只有短命的9,18.3和长寿的18.9
后面的 Java 会按大约6个月的周期发布,但命名依然是 10, 11 ,不会是 18.3,18.9 等。而10, 11 在很大程度完全兼容9,是9 的加强版本,按老式的命名可能对应可能是 9.1, 9.2. 而大规模的语法修改,改进等,真正意义上大版本升级,则会在后面12 或者更后的版本中进行。

infoq 上有相关的Oracle官方文章说明。https://www.infoq.com/news/2017/11/new-version-scheme-java
东方可爱
东方可爱
公司还在用7....
hantsy
hantsy
4.3.14 也升级到 ASM 6.0
f
freezingsky
9还没用上,10你都跟上了!!
翻滚吧牛baobao
jdk6挺好
MrXionGe
MrXionGe
老哥!JDK10的毛还没看到呢,难道是你们几个私下先玩了么??
话说应该是18.3和18.9才对。
xiaolei123
xiaolei123
10?我都没见过啊
返回顶部
顶部