安全预警:MySQL 被发现影响重大的安全漏洞

桔子
 桔子
发布于 2018年01月22日
收藏 10

Oracle官方近日发布安全公告,公告修复MySQL服务25个安全漏洞,在这些安全漏洞中,影响较大的CVE-2018-2696漏洞可以在无需认证的条件下,远程利用导致拒绝服务攻击。本次安全公告披露的安全漏洞数量较多,建议用户关注。 

漏洞编号: CVE-2018-2696,CVE-2018-2591,CVE-2018-2562

漏洞描述: 

CVE-2018-2562  MySQL分区未指定的漏洞

漏洞源于Oracle MySQL服务器分区组件。影响5.5.58及之前版本,5.6.38及之前的版本,5.7.19及之前的版本。该漏洞允许低权限通过多种协议对服务器进行拒绝式攻击,也可以无需授权更新、插入、删除数据库中的可以访问的数据。

MariaDB分支版本也受该漏洞影响。

CVE-2018-2591  MySQL分区未指定的漏洞

漏洞源于Oracle MySQL服务器分区组件。影响5.6.38及之前的版本,5.7.19及之前的版本。该漏洞允许低权限通过多种协议对服务器进行拒绝式攻击。

MariaDB分支版本不受该漏洞影响。

CVE-2018-2696  MySQL: sha256_password 认证长密码拒绝式攻击

该漏洞源于MySQL sha256_password认证插件,该插件没有对认证密码的长度进行限制,而直接传给my_crypt_genhash()用SHA256对密码加密求哈希值。该计算过程需要大量的CPU计算,如果传递一个很长的密码时候,会导致CPU耗尽。而且该公式MySQL的实现中使用alloca()进行内存分配,无法对内存栈溢出保护,可能导致内存泄露、进程崩溃,从而可能实现代码执行。

MySQL <= 5.6.38 和MySQL <= 5.7.20 受影响。MariaDB分支版本不受该漏洞影响。

更多信息参考 :http://www.oracle.com/technetwork/security-advisory/cpujan2018-3236628.html

漏洞利用条件和方式: 

通过PoC直接远程利用。 

PoC状态: 

未公开 

漏洞影响范围: 

具体受影响范围参见漏洞描述部分。

漏洞检测: 

检查是否使用了受影响版本范围内的MySQL服务。 

漏洞修复建议(或缓解措施): 

1.目前Oracle官方已经发布最新版本,建议自建MySQL服务用户及时手工下载更新: 

2.建议选择MySQL开源分支MariaDB,该分支完全兼容MySQL并提供更多功能和更好的性能。

参考信息: 

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:安全预警:MySQL 被发现影响重大的安全漏洞
加载中

最新评论(9

D
Dandjinh

引用来自“Dandjinh”的评论

oracle建议选择mariadb?

引用来自“桔子”的评论

这是笔者自己写的,跟mariadb无关
我就说嘛
小黄鸭的思想
小黄鸭的思想

引用来自“桔子”的评论

操,oschina的审稿是不是傻呀,又将老子标题给改了

这是我自己写的,不是oracle发布的,好不?
确实不是Oracle 发布的, 资讯审稿不严谨啊!!!!!
@红薯 @红薯 @红薯
65535
65535

引用来自“Dandjinh”的评论

oracle建议选择mariadb?

引用来自“桔子”的评论

这是笔者自己写的,跟mariadb无关
哈哈哈 osc的标题小编
小黄鸭的思想
小黄鸭的思想

引用来自“桔子”的评论

操,oschina的审稿是不是傻呀,又将老子标题给改了

这是我自己写的,不是oracle发布的,好不?
是真的有这些安全漏洞吧 ?
桔子
桔子

引用来自“OSCFaker”的评论

请问mysql怎么升级呀?手动卸载旧的安装新的吗?
备份数据库,升级,然后导入新数据库
桔子
桔子

引用来自“Dandjinh”的评论

oracle建议选择mariadb?
这是笔者自己写的,跟mariadb无关
开源中国首席罗纳尔多
开源中国首席罗纳尔多
请问mysql怎么升级呀?手动卸载旧的安装新的吗?
D
Dandjinh
oracle建议选择mariadb?
linapex
linapex
擦,赶紧升级
返回顶部
顶部