Yarn 1.4.0 发布,Facebook 推出的 JavaScript 包管理器

来源: OSCHINA
编辑: 局长
2018-01-16

Facebook 推出的 JavaScript 包管理器 Yarn 发布了 1.4.0 版本,该版本的主要更新是对 bug 进行修复,此外还新增了一些功能特性。

部分更新内容如下:

  • 当新版本未在"yarn publish"上提供时,显示当前版本号

  • 从 homebrew npm 使用 node-gyp

  • 修复认证条件和注册表的逻辑

详细更新说明和下载地址请查看 GitHub 发布主页

Yarn 是 Facebook 推出的 JavaScript 包管理器,旨在提供 npm 之外的另一种选择方案。Yarn 具有极佳的伸缩性,可以支持成千上万个直接或间接的包依赖。Yarn 的设计初衷是保证稳定性、弹性和高性能。

那么 Yarn 和 npm 有什么不同呢?两者最大的不同在于安装包的方式,Yarn 用到了 lockfiles 和确定性算法。Lockfile 会把安装的包版本进行锁定,保证了 node_modules 目录在不同设备上的安装结果是一致的,同时支持并行操作,大大加快安装进程。此外,Yarn 还声明同时兼容 npm 和 Bower,支持两个仓库混合使用,同时支持包的离线安装(只要你曾经安装过这个包)。

Yarn 1.0 的发布时间是 2017 年 9 月,可点此查看更新内容。

展开阅读全文
5 收藏
分享
加载中
最新评论 (4)

引用来自“y654136828”的评论

yarn 有的 npm 其实都有
但npm从yarn学到一些东西,比如lockfile,并且使用上,yarn更简洁!
2018-01-17 09:01
0
回复
举报
yarn 有的 npm 其实都有
2018-01-17 08:43
0
回复
举报
比cnpm好用,强烈推荐
2018-01-16 18:02
0
回复
举报
Just a Release Candidate version.
2018-01-16 13:20
0
回复
举报
更多评论
4 评论
5 收藏
分享
返回顶部
顶部