强推 Android 8.0 ?Google Play 将迎来重大调整 - 开源中国社区
强推 Android 8.0 ?Google Play 将迎来重大调整
王练 2017年12月21日

强推 Android 8.0 ?Google Play 将迎来重大调整

王练 王练 发布于2017年12月21日 收藏 2

【腾讯云】如何快速搭建微信小程序?>>>  

Android 的产品经理 Edward Cunningham 近日在开发者博客上发文宣布,为了更好地实现安全和性能,以确保用户有正面的积极性去发现和安装他们喜欢的应用和游戏,针对 Android 开发者,Google 会在 2018 年做一些重要变更,包括:

  • 从 2018 年下半年起,Google Play 将要求新应用和应用更新跟上最新的 Android API 级别,以确保所有的应用都是构建在最新的优化了安全性和性能的 API 上。从 2018 年 8 月起,所有向 Google Play 提交的新应用都必须使用 API level 26 (Android 8.0)  及以上版本开发;2018 年 11 月起,所有 Google Play 的现有应用更新同样必须使用 API level 26 及以上版本。

  • 从 2019 年 8 月起,Google Play 将要求使用本地库的新应用和现有应用更新除了提供 32 位版本外,还必须提供 64 位版本。

  • 从 2018 年初起,Google Play 将开始在每个 APK 的顶部添加少量的安全元数据(metadata),以进一步验证应用的合规性。

此外,Google 对 targetSdkVersion 的要求还会持续更新。从 2019 年起,在每个 Android 版本发布后的一年内,新的应用和现有应用更新都将需要针对相应的 API 级别。

当然,如果是没有收到更新的现有应用则不受此影响。也就是说,只要你不更新,一切照旧。

Edward Cunningham 表示,此举是为了减少 Android 应用生态系统中的碎片化,确保应用的安全性和性能,同时为开发人员提供相对充裕的时间,以便提前进行规划。

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:强推 Android 8.0 ?Google Play 将迎来重大调整
分享
评论(17)
精彩评论
12

引用来自“大美bot”的评论

搞不定用户,来搞开发者。。。。
不搞定开发者,怎么搞定用户?
8
本意上还是积极向上的,就是手段有点粗鲁。不过第一次都会让人感觉粗鲁,习惯了就好了。:flushed:做开发的就应该1保持与时俱进的心态,写的代码又老又臭,自己都觉得恶心,不是吗?
2
谷歌修正了史前应用太多的bug。
2

引用来自“大美bot”的评论

搞不定用户,来搞开发者。。。。
能靠搞定用户解决碎片化?
2
搞不定用户,来搞开发者。。。。
最新评论
0
想起了我写代码的策略,“拒绝支持 Python 2,全面基于 Python 3.4+”,“ES 5 及格,ES 6 良好”:joy:
0
同时为开发人员提供相对充裕的时间----tm的说的我都信了.
2
谷歌修正了史前应用太多的bug。
0

引用来自“app-developer”的评论

fuck,权限申请的API,难用无比!调用跟结果回调分离,在此处调用得跑去别处处理,特别不爽!

引用来自“Gox”的评论

申请权限是异步的吧?
异步是可以放一起的。举个例子:
void doasync(final XXListener l){
new Thread(new Runnable(){ run(){ l.finish();} }).start();
}
2

引用来自“大美bot”的评论

搞不定用户,来搞开发者。。。。
能靠搞定用户解决碎片化?
0

引用来自“app-developer”的评论

fuck,权限申请的API,难用无比!调用跟结果回调分离,在此处调用得跑去别处处理,特别不爽!
申请权限是异步的吧?
0
fuck,权限申请的API,难用无比!调用跟结果回调分离,在此处调用得跑去别处处理,特别不爽!
0
早就该出个政策,至少要用新版本的sdk开发和编译嘛。
0

引用来自“开源中国首席卡牌中单”的评论

怎么我chrome一直显示32位?我装的是64

引用来自“Fenying”的评论

要卸掉重装
回复@Fenying : 已经卸载了还是这样
0

引用来自“睡不醒了睡”的评论

targetSDK=22 minSDK= 14 这tm头都要改大了
偷懒的做法
0

引用来自“开源中国首席卡牌中单”的评论

怎么我chrome一直显示32位?我装的是64
要卸掉重装
0
targetSDK=22 minSDK= 14 这tm头都要改大了
0
早该如此了,应该所有 App 强制只提供 64位,只能使用最新 SDK、NDK,targetsdk - minsdk >= 2。
12

引用来自“大美bot”的评论

搞不定用户,来搞开发者。。。。
不搞定开发者,怎么搞定用户?
8
本意上还是积极向上的,就是手段有点粗鲁。不过第一次都会让人感觉粗鲁,习惯了就好了。:flushed:做开发的就应该1保持与时俱进的心态,写的代码又老又臭,自己都觉得恶心,不是吗?
0
怎么我chrome一直显示32位?我装的是64
2
搞不定用户,来搞开发者。。。。
顶部