PHPUnit 6.5.3 发布,PHP 单元测试框架

来源: 投稿
作者: 王练
2017-12-07 07:25:20

PHPUnit 6.5.3 已发布,这是一个修复版本,修复了修正了配置 forceCoversAnnotation =“true” 时 PHPT 测试的问题。

PHPUnit 是一个面向程序员的 PHP 测试框架。是 xUnit 单元测试框架体系结构的一员。

PHPUnit 6.2 系列需要 PHP 7 及以上,强烈推荐使用最新版本的 PHP。

PHPUnit 需要使用 dom 和 json 扩展,它们通常是默认启用的。

PHPUnit 还需要 pcrereflectionspl 扩展。这些标准扩展默认启用,并且除非修改 PHP 的构建系统和 C 源代码,否则无法禁用它们。

代码覆盖率分析报告功能需要 Xdebug(2.5.0以上)与 tokenizer 扩展。生成 XML 格式的报告需要有 xmlwriter 扩展。

下载地址:

展开阅读全文
4 收藏
分享
0 评论
4 收藏
分享
返回顶部
顶部
返回顶部
顶部