Node v8.9.2 和 v6.12.1 长期支持版发布

来源: 投稿
作者: 王练
2017-12-06

Node.js 同时发布了  v8.9.2 (LTS) 和 v6.12.1(LTS),主要更新如下:

v8.9.2 (LTS)

  • console:

    • avoid adding infinite error listeners (Matteo Collina) #16770

  • http2:

    • improve errors thrown in header validation (Joyee Cheung) #16718

完整更新内容

v6.12.1(LTS)

  • build:

    • fix npm install with --shared (Ben Noordhuis) #16438

  • build:

    • building with python 3 is now supported (Emily Marigold Klassen) #16058

  • src:

    • v8 options can be specified with either '_' or '-' in NODE_OPTIONS (Sam Roberts) #14093

完整更新内容

下载地址:

展开阅读全文
2 收藏
分享
加载中
精彩评论
构建脚本终于支持 Python 3 了……
2017-12-06 17:28
1
举报

引用来自“MrXionGe”的评论

很快LTS就要9版本了

引用来自“gucheen”的评论

单数都是 stable,双数才是 LTS
发布动作快也不是坏事, 想要的feature都有了, 无脑乱喷
2017-12-06 13:03
1
举报
最新评论 (13)
av

引用来自“av”的评论

早就用 9.x 了,坐等 10.x 出

引用来自“爱开源的小学生”的评论

nodejs怎么在线升级?

引用来自“av”的评论

先装 nvm,然后用它管理 node,我系统里都七八个 node 版本了,一键切换的。

引用来自“爱开源的小学生”的评论

回复@av : nvm是什么来的?
你搜下就知道了。。就是 node 版本管理工具,可以随时切换 node 版本,在一个系统里共存。
2017-12-07 10:44
0
回复
举报
还是劳劳试试的用6.x吧,有好多应用不支持8.x
2017-12-07 09:05
0
回复
举报
貌似12.7号还要发布个安全修复版
2017-12-06 20:52
0
回复
举报

引用来自“av”的评论

早就用 9.x 了,坐等 10.x 出

引用来自“爱开源的小学生”的评论

nodejs怎么在线升级?

引用来自“av”的评论

先装 nvm,然后用它管理 node,我系统里都七八个 node 版本了,一键切换的。
回复@av : nvm是什么来的?
2017-12-06 18:26
0
回复
举报
av

引用来自“av”的评论

早就用 9.x 了,坐等 10.x 出

引用来自“爱开源的小学生”的评论

nodejs怎么在线升级?
先装 nvm,然后用它管理 node,我系统里都七八个 node 版本了,一键切换的。
2017-12-06 17:57
0
回复
举报
构建脚本终于支持 Python 3 了……
2017-12-06 17:28
1
回复
举报

引用来自“av”的评论

早就用 9.x 了,坐等 10.x 出
nodejs怎么在线升级?
2017-12-06 16:41
0
回复
举报
av
早就用 9.x 了,坐等 10.x 出
2017-12-06 14:45
0
回复
举报

引用来自“MrXionGe”的评论

很快LTS就要9版本了

引用来自“gucheen”的评论

单数都是 stable,双数才是 LTS
发布动作快也不是坏事, 想要的feature都有了, 无脑乱喷
2017-12-06 13:03
1
回复
举报
M_B_D, 我昨天才下载的8.9.1
2017-12-06 12:17
0
回复
举报
更多评论
13 评论
2 收藏
分享
返回顶部
顶部