Apache Log4j 2.10.0 正式发布,包含大量更新

来源: OSCHINA
编辑: 局长
2017-11-24

Apache Log4j 2.10.0 正式发布了,此版本包含新功能引入、错误修正和次要的功能增强。其中一些新功能包括对 Java 9 模块系统的支持、对新的 SLF4j 1.8 绑定机制的支持,简化 Log4j 属性命名方案以及原生支持 Jetty 的记录器。

Log4j API 现在是一个完全兼容的 Java 9 模块,而其他 Log4j jar 包是 Java 9 命名的自动模块。

该版本支持 SLF4J 1.7.x 和 SLF4J 1.8.x。由于 SLF4J 1.7.x 要求实现包含 org.slf4j.impl 包中的类,因此 log4j-sl4j-impl 不能用作 Java 9 模块。在未来的版本中,对 SLF4J 1.7.x 的支持将被移除。

从 Log4j 2.9.0 开始,Log4j API 被修改为使用 java.util.ServiceLoader 来确定 Log4j 的实现,此前的绑定机制仍然受支持。Log4j API jar 包现在是一个多版本的 jar 包,用来提供 Java 9 特定类的实现。

OSGi 规范不支持多版本的 jar 包,所以 OSGi 模块将无法利用这些实现。请注意,有些工具与多版本 jar 包不兼容,可能无法处理 META-INF/versions/9 文件夹中的类文件,这些错误可向工具提供者反馈。

Apache Log4j 2.10.0 的运行环境要求最低是 Java 7,Log4j 2.3 是最后一个支持 Java 6 的版本。

更新内容较多,详情可查看发布主页更新日志

下载地址:https://logging.apache.org/log4j/2.x/download.html

展开阅读全文
23 收藏
分享
加载中
精彩评论
我用logback
2017-11-24 08:31
5
举报
一个核心日志模块 log4j-core-2.10.0.jar 就 1.5MB, 是不是太臃肿了, 拆分出真正的core吧.
2017-11-24 13:37
2
举报
这个会不会是必用产品
2017-11-24 09:28
1
举报
这个目前还是好多人用呀
2017-11-24 09:21
1
举报
最新评论 (7)
一个核心日志模块 log4j-core-2.10.0.jar 就 1.5MB, 是不是太臃肿了, 拆分出真正的core吧.
2017-11-24 13:37
2
回复
举报
哎,我现在还是千年log4j 1.2.x
2017-11-24 12:51
0
回复
举报
貌似springboot2的默认配置还是logback,那就继续logback把…
2017-11-24 10:46
0
回复
举报
这个会不会是必用产品
2017-11-24 09:28
1
回复
举报
这个目前还是好多人用呀
2017-11-24 09:21
1
回复
举报
:bowtie:不错不错~
2017-11-24 08:44
0
回复
举报
我用logback
2017-11-24 08:31
5
回复
举报
更多评论
7 评论
23 收藏
分享
返回顶部
顶部