Spring Boot 2.0.0.M6 发布,初步支持 HTTP/2

来源: 投稿
作者: 淡漠悠然
2017-11-06

Spring Boot 2.0.0.M6 已发布。该版本关闭了 144 个 issue 和 PR,继续向 2.0 GA 迈进。

该里程碑版改进了之前版本中的一些项目,也新增了一些特性,具体如下:

  • 初步支持 HTTP/2:目前在 Tomcat 和 Undertow 上支持 HTTP/2(查看对 Jetty 的支持

  • 改进对基于 WebFlux 的应用程序的支持 —— Spring Boot 现在支持为所有容器进行 TLS 配置,并提供错误页面支持

  • Kotlin 扩展 —— 首个 Kotlin 扩展已经诞生。现在,可以用更符合习惯的方式启动应用程序

package com.example.demo
import org.springframework.boot.autoconfigure.SpringBootApplication
import org.springframework.boot.runApplication
@SpringBootApplication
class DemoApplication
fun main(args: Array<String>) {
    runApplication<DemoApplication>(*args)
}

有关变更的完整列表和升级说明,请参阅 WIKI 上的 Spring Boot 2.0.0.M6 发行说明

使用:https://repo.spring.io/milestone/

源码下载:

来自:https://spring.io/blog/

展开阅读全文
24 收藏
分享
加载中
精彩评论
估计Spring cloud也会同步支持HTTP/2吧
2017-11-08 16:34
1
举报
坐等正式版
2017-11-07 20:43
1
举报
如何查看我当前的HTTP版本呢?
F12查看的话,有的响应头带版本号,有的不带。
2017-11-06 17:30
1
举报
最新评论 (23)
spring 在干嘛呢?支持Kotlin了。。。。
哪天不支持java了怎么办?
2017-11-10 09:11
0
回复
举报

引用来自“MrXionGe”的评论

如何查看我当前的HTTP版本呢?
F12查看的话,有的响应头带版本号,有的不带。

引用来自“maosi”的评论

Chrome上Network中选中Protocol标签就可以都显示吧?
我的是UC,没有这个选项。chrome的话,在虚拟机里,忙 懒得看 呢,,有时间我留意一下咯!
2017-11-09 10:09
0
回复
举报

引用来自“webas”的评论

估计Spring cloud也会同步支持HTTP/2吧
肯定的啊,都是一家人,而且是以SpringBoot为基础的啊
2017-11-09 10:07
0
回复
举报
Swoole很早以前就基于nghttp2库内置实现了对异步HTTP2服务器端和客户端的支持.
configure配置项: --enable-http2
服务器端: 'open_http2_protocol' => true
客户端: swoole_http2_client
2017-11-08 22:17
0
回复
举报
以前spring把配置全都折腾到xml里,说为了维护方便,现在springboot又把xml折腾没了,又是为了什么呀?
2017-11-08 17:51
0
回复
举报
估计Spring cloud也会同步支持HTTP/2吧
2017-11-08 16:34
1
回复
举报

引用来自“MrXionGe”的评论

如何查看我当前的HTTP版本呢?
F12查看的话,有的响应头带版本号,有的不带。
Chrome上Network中选中Protocol标签就可以都显示吧?
2017-11-08 13:41
0
回复
举报
chrome - 开发者模式 - network - 右击勾选protocol 列,请求网页就可以看到协议版本号
2017-11-08 09:52
0
回复
举报

引用来自“MrXionGe”的评论

如何查看我当前的HTTP版本呢?
F12查看的话,有的响应头带版本号,有的不带。
chrome - 开发者模式 - network (右击勾选 protocol 列) 可以看到 http1.1或者 http2
2017-11-08 09:50
0
回复
举报
怎么还初步支持?难道不是完整的
2017-11-08 08:52
0
回复
举报
更多评论
23 评论
24 收藏
分享
返回顶部
顶部