.NET Framework 4.7.1 发布,支持 .NET Standard 2.0

周其
 周其
发布于 2017年10月18日
收藏 5

.NET Framework 4.7.1 发布了,它包含在 Windows 10 Fall Creators 更新中。

.NET Framework 4.7.1 也可在 Windows 7+ 和 Windows Server 2008 R2 + 上使用。在 Visual Studio 2017 15.5 中也将添加对 .NET Framework 4.7.1 的支持。

.NET Framework 4.7.1 包括几个方面的改进:

  • narration, high contrast 和 focus control areas的辅助功能改进

  • .NET Framework 支持 .NET Standard 2.0 和编译器功能

  • 在 ASP.NET 和 System.Messaging 中更安全的 SHA-2 支持

  • 配置构建器

  • ASP.NET 执行步骤功能

  • ASP.NET HttpCookie 解析

  • Visual Tree for WPF 应用程序的功能增强

  • 性能和可靠性改进

支持 Windows 版本

.NET Framework 4.7.1支持以下Windows版本:

  • Windows 10 Fall Creators Update (included in-box)

  • Windows 10 Creators Update

  • Windows 10 Anniversary Update

  • Windows 8.1

  • Windows 7 SP1

.NET Framework 4.7.1支持以下Windows Server版本:

  • Windows Server 2016

  • Windows Server 2012 R2

  • Windows Server 2012

  • Windows Server 2008 R2 SP1

查看更多更新内容

下载地址:

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:.NET Framework 4.7.1 发布,支持 .NET Standard 2.0
加载中

精彩评论

久永
久永

引用来自“山雨欲来”的评论

这玩意1.0 2.0 3.0 4.0 之间没有向下兼容 坑的要死
不懂 .net 的就不要瞎吹啦!
2.0 和 3.0 本来就是一个版本,还不兼容?
kidfruit
kidfruit

引用来自“山雨欲来”的评论

这玩意1.0 2.0 3.0 4.0 之间没有向下兼容 坑的要死

引用来自“kidfruit”的评论

@山雨欲来 你如果是用户,直接装4的最新版一般都够了,很老的软件可能会需要装3.5最新版,其他都不用装。你如果是开发者,说出这种话说明你没入门,先去学习去。

引用来自“山雨欲来”的评论

回复@kidfruit : 我不做微软系开发
@山雨欲来 那你在不了解的情况下靠自己的猜测就开喷了?
陈少鑫
陈少鑫

引用来自“山雨欲来”的评论

这玩意1.0 2.0 3.0 4.0 之间没有向下兼容 坑的要死

引用来自“久永”的评论

不懂 .net 的就不要瞎吹啦!
2.0 和 3.0 本来就是一个版本,还不兼容?
这就叫【微软雅黑】
kidfruit
kidfruit

引用来自“山雨欲来”的评论

这玩意1.0 2.0 3.0 4.0 之间没有向下兼容 坑的要死
@山雨欲来 你如果是用户,直接装4的最新版一般都够了,很老的软件可能会需要装3.5最新版,其他都不用装。你如果是开发者,说出这种话说明你没入门,先去学习去。
山雨欲来
山雨欲来
这玩意1.0 2.0 3.0 4.0 之间没有向下兼容 坑的要死

最新评论(15

久永
久永

引用来自“山雨欲来”的评论

这玩意1.0 2.0 3.0 4.0 之间没有向下兼容 坑的要死

引用来自“kidfruit”的评论

@山雨欲来 你如果是用户,直接装4的最新版一般都够了,很老的软件可能会需要装3.5最新版,其他都不用装。你如果是开发者,说出这种话说明你没入门,先去学习去。

引用来自“山雨欲来”的评论

回复@kidfruit : 我不做微软系开发
所以我一开始就说了,不懂不要瞎吹。
比起一次编译,到处调试的竞争者,.net 兼容性简直不要太好。
kidfruit
kidfruit

引用来自“山雨欲来”的评论

这玩意1.0 2.0 3.0 4.0 之间没有向下兼容 坑的要死

引用来自“kidfruit”的评论

@山雨欲来 你如果是用户,直接装4的最新版一般都够了,很老的软件可能会需要装3.5最新版,其他都不用装。你如果是开发者,说出这种话说明你没入门,先去学习去。

引用来自“山雨欲来”的评论

回复@kidfruit : 我不做微软系开发
@山雨欲来 那你在不了解的情况下靠自己的猜测就开喷了?
山雨欲来
山雨欲来

引用来自“山雨欲来”的评论

这玩意1.0 2.0 3.0 4.0 之间没有向下兼容 坑的要死

引用来自“kidfruit”的评论

@山雨欲来 你如果是用户,直接装4的最新版一般都够了,很老的软件可能会需要装3.5最新版,其他都不用装。你如果是开发者,说出这种话说明你没入门,先去学习去。
回复@kidfruit : 我不做微软系开发
陈少鑫
陈少鑫

引用来自“山雨欲来”的评论

这玩意1.0 2.0 3.0 4.0 之间没有向下兼容 坑的要死

引用来自“久永”的评论

不懂 .net 的就不要瞎吹啦!
2.0 和 3.0 本来就是一个版本,还不兼容?
这就叫【微软雅黑】
kidfruit
kidfruit

引用来自“山雨欲来”的评论

这玩意1.0 2.0 3.0 4.0 之间没有向下兼容 坑的要死
@山雨欲来 你如果是用户,直接装4的最新版一般都够了,很老的软件可能会需要装3.5最新版,其他都不用装。你如果是开发者,说出这种话说明你没入门,先去学习去。
久永
久永

引用来自“山雨欲来”的评论

这玩意1.0 2.0 3.0 4.0 之间没有向下兼容 坑的要死
不懂 .net 的就不要瞎吹啦!
2.0 和 3.0 本来就是一个版本,还不兼容?
山雨欲来
山雨欲来

引用来自“山雨欲来”的评论

这玩意1.0 2.0 3.0 4.0 之间没有向下兼容 坑的要死

引用来自“人生能绕几个圈”的评论

有时候找windows应用依赖也挺烦的
回复@人生能绕几个圈 : 特别是少某个 dll文件
山雨欲来
山雨欲来

引用来自“山雨欲来”的评论

这玩意1.0 2.0 3.0 4.0 之间没有向下兼容 坑的要死

引用来自“Greatim”的评论

没兼容的需求啊,你要运行2.0、3.0只要启用3.0就可以了,又不互相排斥。
回复@Greatim :.net 1.0 2.0 3.0 4.0 全安装了一个
人生能绕几个圈
人生能绕几个圈

引用来自“山雨欲来”的评论

这玩意1.0 2.0 3.0 4.0 之间没有向下兼容 坑的要死
有时候找windows应用依赖也挺烦的
阳光满地
阳光满地
现在搞得比JAVA还乱!各个小版本之间还有区别的!微软再这样玩迟早玩死自己。
返回顶部
顶部