Apache Kudu 1.5.0 发布,Hadoop 数据存储系统

Li_Peng
 Li_Peng
发布于 2017年09月22日
收藏 18

Hadoop数据存储系统Apache Kudu 1.5.0已发布,升级说明:

  1. 从Kudu 1.5.0开始支持Spark2.2,Spark 2.2是Kudu 1.5.0的默认依赖版本。虽然Spark 2.x对Java 7是兼容的,但是结合Kudu使用Spark 2.2需要使用Java 8。 

  2. 从Kudu 1.5.0开始,不建议使用Java 7,在未来版本中可能会删除对Java 7的支持。

  3. 从Kudu 1.5.0开始,不建议使用Spark 1.x(kudu-spark_2.10),在未来版本中可能会删除对Spark 1.x的支持。

  4. kudu-client-tools现在已经支持导出CSV文件和导入Apache Parquet文件。 此功能不稳定,可能会在后续版本中对API和相关功能进行更改。

  5. kudu-spark-tools现在支持导入和导出CSV,Apache Avro和Apache Parquet文件。  此功能不稳定,可能会在后续版本中对API和相关功能进行更改。

更新内容和发布说明较多,详情点此参阅

下载地址:http://kudu.apache.org/releases/

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:Apache Kudu 1.5.0 发布,Hadoop 数据存储系统
加载中

最新评论(1

Feng_Yu
Feng_Yu
这玩意功能倒是挺吸引人的,就是依赖太重了。
返回顶部
顶部