JUnit 5.0.0-RC3 发布,离 GA 更近一步 - 开源中国社区
JUnit 5.0.0-RC3 发布,离 GA 更近一步
B超 2017年08月24日

JUnit 5.0.0-RC3 发布,离 GA 更近一步

B超 B超 发布于2017年08月24日 收藏 11

免费体验IBM Cloud,构建Iot应用 >>>  

与之前的版本不同,JUnit 5 由三个不同的模块组成:

  • JUnit 平台,其主要作用是在 JVM 上启动测试框架。它定义了一个抽象的 TestEngine API 来定义运行在平台上的测试框架,同时还支持通过命令行、Gradle 和 Maven 来运行平台。

  • JUnit Jupiter,包含了 JUnit 5 最新的编程模型和扩展机制。

  • JUnit Vintage,允许在平台上运行 JUnit 3 和 JUnit 4 的测试用例。

JUnit 5 对 Java 运行环境的最低要求是 Java 8, 同时也兼容测试旧版本JDK编译出来的代码。

更新如下:

Bug Fixes

  • Source JARs no longer contain every source file twice.

  • The Maven Surefire provider now reports a failed test with a cause that is not an instance of AssertionErroras an error instead of a failure for compatibility reasons.

New Features and Improvements

  • Configuration parameters can now be supplied in a number of new ways:

点此查看完整发布说明

BUG清单:

下载地址:

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:JUnit 5.0.0-RC3 发布,离 GA 更近一步
分享
评论(6)
最新评论
0

引用来自“无著方知尘亦珍”的评论

太磨叽了,而且拆分模块后,用起来比junit4麻烦
实际是简单了,而且跟 spring 5 的集成更方便了。
0
太磨叽了,而且拆分模块后,用起来比junit4麻烦
0
都发展成一个测试平台了
0
已经可以用于实际项目了。
0
待我看看为啥需要JD8...
0
GA是那个头上骑个猴的吗?
顶部