Hibernate Validator 6.0.1.Final,支持 JSR 380 规范

局长
 局长
发布于 2017年08月08日
收藏 7

经过六个多月的开发,Hibernate Validator 6.0 的最终正式版 Hibernate Validator 6.0.1.Final 终于发布了,支持最新的 JSR 380 规范 —— Bean Validation 2.0,除此之外,还改进了性能。

Hibernate Validator 是 Bean Validation 的参考实现,下面是自 CR3 以来的重大变化:

  • 文档更新

  • 转换升级

  • 性能改进

  • 减少内存占用

  • 支持最新的 JDK 9(build 180)

完整的问题修复列表请查看 JIRA

发布主页下载地址

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 开源中国社区 [http://www.oschina.net]
本文标题:Hibernate Validator 6.0.1.Final,支持 JSR 380 规范
加载中

最新评论(6

小杨阿哥哥
小杨阿哥哥

引用来自“JaysHung”的评论

切换成6.0.1后,ClassNotFoundException: javax.validation.ClockProvider
<groupId>javax.validation</groupId>
<artifactId>validation-api</artifactId>
<version>2.0.1.Final</version>
JaysHung
JaysHung
切换成6.0.1后,ClassNotFoundException: javax.validation.ClockProvider
_
_hejg
ajax请求怎么用啊?
_
_hejg
nice
zzuqiang
zzuqiang

引用来自“加加0”的评论

就问 springmvc 支持吗?
支持呀
加加0
加加0
就问 springmvc 支持吗?
返回顶部
顶部