VS Code 现可作为 snap 包在 Linux 发行版上使用

局长
 局长
发布于 2017年05月24日
收藏 12

微软的代码编辑器 Visual Studio Code 在 Linux 上更容易安装了 —— 现在支持通过 snap 包进行安装。此前,你需要从 Visual Studio Code 网站下载 .deb 或 .rpm 文件,这也很简单,但需要较多的步骤。使用 snap 包可以在终端使用一行简单的命令进行安装。

要安装 Visual Studio Code,只需打开终端应用程序并输入(需要权限):

sudo snap install --classic vscode

随着编辑器成为 snap 目录的一部分,这意味着使用它的开发者将获得内置的自动更新和内置的所有依赖项,从而更容易安装。Ubuntu 的 David Calle 在博客文章中写道:

 “snap 包使得最新版本的 Visual Studio Code 可以在 Ubuntu 14.04,16.04 和更新的受支持版本上轻松安装和自动更新,和第三方 PPAs 和一般的包管理器说再见吧。”

Visual Studio Code 已成为 Linux 平台上开发者的重要工具。其成功的一些原因包括基于类型和功能的智能完成,多功能集成调试器,git 内置支持以及可靠的 git 命令用户界面和扩展支持。

来自:neowin

>>>【全民狂欢,评论有礼】5月15日-31日评论每日更新的“新闻资讯和软件更新资讯”,评论点赞数超过 20 的可登上每周更新的“源资讯”和“软件周刊”两大栏目,点赞数超过 50 的还将获得 5 活跃积分奖励和开源中国定制好礼。详情

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动共创开源社区。
转载请注明:文章转载自 OSCHINA 社区 [http://www.oschina.net]
本文标题:VS Code 现可作为 snap 包在 Linux 发行版上使用
加载中

精彩评论

h
hummerstudio

引用来自“NiceIve”的评论

snap , 印象中是为了解决rpm和deb包的不兼容而起的新项目?
@NiceIve 是Ubuntu为了解决包依赖问题开发的包格式,对应RedHat提出了flatpak格式。
TUPUNCO
TUPUNCO
github 搜索 hosts 第一个~
卖爷爷的老红薯
卖爷爷的老红薯
vscode下载go的工具包失败,有人知道怎么让vscode走ss的代理吗?

最新评论(21

chinleo
chinleo

引用来自“红薯丸子”的评论

vscode下载go的工具包失败,有人知道怎么让vscode走ss的代理吗?
setting里面的proxy设置,试试
h
hummerstudio

引用来自“NiceIve”的评论

snap , 印象中是为了解决rpm和deb包的不兼容而起的新项目?
@NiceIve 是Ubuntu为了解决包依赖问题开发的包格式,对应RedHat提出了flatpak格式。
TUPUNCO
TUPUNCO
github 搜索 hosts 第一个~
TUPUNCO
TUPUNCO

引用来自“红薯丸子”的评论

vscode下载go的工具包失败,有人知道怎么让vscode走ss的代理吗?
这个时候 就需要来出手了~
冰力
冰力
flatpak 应该多支持一下。
百世经纶之傲笑红尘
百世经纶之傲笑红尘
你在逗我吗,VScode不用snap很早之前也可以下载安装
Tony1952466760
Tony1952466760
这个VS Code 在解决代码冲突的时候就麻烦了,不知道有没有好点解决办法,在用VS 2015 这样的编辑器解决起来比较方便
LarryYan
LarryYan
snap , 印象中是为了解决rpm和deb包的不兼容而起的新项目?
车篷草
车篷草
微软的东西是好用,但是,钱少的话,有的不好买。
返回顶部
顶部